Bug 338515 - korganizer, does not take care of the time zone of an event sent by another tool
Summary: korganizer, does not take care of the time zone of an event sent by another tool
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-24 09:43 UTC by Philippe ROUBACH
Modified: 2016-12-23 15:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
capture of the same event in google calendar (111.51 KB, image/png)
2015-03-08 07:54 UTC, Philippe ROUBACH
Details
how google calendar dispalys the event (98.64 KB, image/png)
2015-03-08 08:05 UTC, Philippe ROUBACH
Details
how owncloud display the test event in owncloud editor (73.57 KB, image/png)
2015-03-08 11:14 UTC, Philippe ROUBACH
Details
how owncloud dispalays in the web page the test event (57.57 KB, image/png)
2015-03-08 11:15 UTC, Philippe ROUBACH
Details
how korganizer displays the owncloud test event (60.22 KB, image/png)
2015-03-08 11:23 UTC, Philippe ROUBACH
Details
how korganizer displays the owncloud test event (119.91 KB, image/png)
2015-03-08 11:24 UTC, Philippe ROUBACH
Details
how korganizer editor displays the pessac_arcahon event (62.19 KB, image/png)
2015-03-08 11:31 UTC, Philippe ROUBACH
Details
how korganizer displays the pessac_arachon event (123.07 KB, image/png)
2015-03-08 11:31 UTC, Philippe ROUBACH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2014-08-24 09:43:13 UTC
opensuse 13.1 x86_64
kde 4.13.3
akonadi 4.13.3

1. first experiment
1.1 in google agenda

i create a rendez-vous at 15 h

1.2 in korganizer

some time later

the rendez-vous is added at 15 h

2. second experiment
2.1 i buy a ticket to the french railway operator SNCF via their android app

this automatically creates a rendez-vous à 7 h 10 in android agenda

2.2 in google agenda

some time later a rendez-vous is created at 7 h 10

2.3 in korganizer

some time later a rendez-vous is created at 9 h 10 !!!!!!

3. i check this

in android gmt+2
in google gmt+1 (I did not find any parameter about energy saving time but google agenda displays well the gmt+2)
in korganizer (no parameter) i assume it uses kde settings thus gmt+2

accurately :
- in kde settings "date et heure" is set to europe/paris (PMT) (i assume gmt+1)
- in kde clock settings 
"clock by default at" is set to "local"
"define automatically date and hour" is not checked

- the hour is set by ntp service managed by opensuse tool thus gmt+2
- hardware clock uses UTC
Comment 1 Philippe ROUBACH 2014-08-24 15:33:21 UTC
1. 

i open the rendez-vous of the first experiment

the hour is 7 h 10
the zone is "europe/paris"

2. 
i open the rendez-vous of of the second experiment
the hour is 7 h 10
the zone is "UTC"

what software does the error to set to "utc" the zone ?
Comment 2 Philippe ROUBACH 2014-09-22 08:39:47 UTC
ok now i have a better definition of the pb .

the event sent by SNCF uses utc (gmt+0) time
for example if you get a train à 13 h 18 then the hour of the event sent by SNCF is  11 h 18 utc
then
android using utc+2 creates an event at 13 h 18 : this is good
google using utc+2   cretates an event at 13 h 18 : this is good
but
korganizer(akonadi) creates an event at 15 h 18    : this is wrong

it seems it uses the kde clock time instead of utc time and does not care about the parameters "utc" in the event sent by SNCF

kde clock time is "europe/paris" and "europe/paris" is utc+2
thus
utc+2+2 leads to 15 h 18

notes : SNCF is the french railways company
Comment 3 Philippe ROUBACH 2014-09-22 09:06:58 UTC
opensuse 13.1 x86_64 
kde 4.14.1 akonadi 4.14.1

i made this experiment :

with android i create an event at 10 h by setting the time at "8 h utc"
then
android using utc + 2 creates an event at 10 h : good
google using utc+2 creates an event at 10 h : good

korganizer creates an event at 12 h : bad

now i am sure that korganizer does not take care of the time zone of the event sent by another tool
Comment 4 Philippe ROUBACH 2014-12-15 15:06:53 UTC
opensuse 13.1 x86_64 
kde 4.14.3

pb still there

any chance to get a fix ? thanks .
Comment 5 Philippe ROUBACH 2014-12-20 06:55:35 UTC
i see that you assigned this report to Daniel Vratil.

i think D Vratil is a developper of akonadi but not korganizer .

i think this is a bug about korganizer and the pb is in korganizer not in google akonadi backend thus it must be assigned to another person , perhaps laurent montel . no ?

or at least add laurent montel.
Comment 6 Philippe ROUBACH 2015-01-01 06:40:19 UTC
another experiment 
i buy a train ticket at  "Capitaine Train" via their android app 
in kmail i receive a mail with a event .ics
i add the event to korganizer by clicking "accept" the event
in korganizer an event is created at 12 h 11 !

this time the shift is 1 h instead of 2 h because we use winter time .
Comment 7 Allen Winter 2015-03-08 01:03:37 UTC
I really need to see the calendar event.  any chance you can send me such an event?  you can sanitize it, except for any info related to dates or timezones.
Comment 8 Philippe ROUBACH 2015-03-08 07:52:14 UTC
here is a ticket to take train from Pessac to Arcachon at 14 h 11 mn (2015/02/27)

korganizer creates an event for 15 h 11 mn

BEGIN:VCALENDAR
PRODID:-//K Desktop Environment//NONSGML libkcal 4.3//EN
VERSION:2.0
X-KDE-ICAL-IMPLEMENTATION-VERSION:1.0
BEGIN:VEVENT
DTSTAMP:20150227T094154Z
CREATED:20150227T094154Z
UID:hd6o77k4be297du99m4ngkjomg
LAST-MODIFIED:20150227T094154Z
DESCRIPTION:14:11 \n PESSAC - ARCACHON \n Train N°66329\, Sans 
 réservation\n
SUMMARY:PESSAC - ARCACHON
LOCATION:PESSAC
STATUS:CONFIRMED
DTSTART:20150227T141100Z
DTEND:20150227T145600Z
TRANSP:OPAQUE
BEGIN:VALARM
DESCRIPTION:
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT2H
X-KDE-KCALCORE-ENABLED:TRUE
END:VALARM
END:VEVENT

END:VCALENDAR

i don't know how to get the event vcf code in google calendar so attach a capture google_calendar_event.png
Comment 9 Philippe ROUBACH 2015-03-08 07:54:07 UTC
Created attachment 91470 [details]
capture of the same event in google calendar
Comment 10 Philippe ROUBACH 2015-03-08 08:05:04 UTC
Created attachment 91471 [details]
how google calendar dispalys the event

we see the event displayed by google calendar
Comment 11 Philippe ROUBACH 2015-03-08 11:02:05 UTC
here is the google calendar pessac-arcachon event in raw format by exporting the google calendar

BEGIN:VEVENT
DTSTART:20150227T131100Z
DTEND:20150227T135600Z
DTSTAMP:20150308T092018Z
UID:hd6o77k4be297du99m4ngkjomg@google.com
CREATED:20150227T094154Z
DESCRIPTION:14:11 \n PESSAC - ARCACHON \n Train N°66329\, Sans réservation\
 n
LAST-MODIFIED:20150227T094154Z
LOCATION:PESSAC
SEQUENCE:0
STATUS:CONFIRMED
SUMMARY:PESSAC - ARCACHON
TRANSP:OPAQUE
BEGIN:VALARM
ACTION:DISPLAY
DESCRIPTION:This is an event reminder
TRIGGER:-P0DT2H0M0S
END:VALARM
END:VEVENT
Comment 12 Philippe ROUBACH 2015-03-08 11:04:56 UTC
here is the owncmoud test event in raw format by exporting the owncloud event :

BEGIN:VEVENT
CREATED;VALUE=DATE-TIME:20150308T085837Z
UID:318a6d8266
LAST-MODIFIED;VALUE=DATE-TIME:20150308T085837Z
DTSTAMP;VALUE=DATE-TIME:20150308T085837Z
SUMMARY:test event title
DTSTART;VALUE=DATE-TIME;TZID=Europe/Andorra:20150308T153000
DTEND;VALUE=DATE-TIME;TZID=Europe/Andorra:20150308T160000
LOCATION:Paris
DESCRIPTION:test description
CATEGORIES:Anniversaire
END:VEVENT
END:VCALENDAR
Comment 13 Philippe ROUBACH 2015-03-08 11:14:27 UTC
Created attachment 91473 [details]
how owncloud display the test event in owncloud editor
Comment 14 Philippe ROUBACH 2015-03-08 11:15:47 UTC
Created attachment 91474 [details]
how owncloud dispalays in the web page the test event
Comment 15 Philippe ROUBACH 2015-03-08 11:19:42 UTC
the owncloud test event in akonadi in raw format :

BEGIN:VCALENDAR
PRODID:-//K Desktop Environment//NONSGML libkcal 4.3//EN
VERSION:2.0
X-KDE-ICAL-IMPLEMENTATION-VERSION:1.0
BEGIN:VEVENT
DTSTAMP:20150308T085837Z
CREATED:20150308T085837Z
UID:318a6d8266
LAST-MODIFIED:20150308T085837Z
DESCRIPTION:test description
SUMMARY:test event title
LOCATION:Paris
CATEGORIES:Anniversaire
DTSTART;TZID=Europe/Andorra:20150308T153000
DTEND;TZID=Europe/Andorra:20150308T160000
TRANSP:OPAQUE
END:VEVENT
BEGIN:VTIMEZONE
TZID:Europe/Andorra
BEGIN:STANDARD
TZNAME:WET
TZOFFSETFROM:+0604
TZOFFSETTO:+0000
DTSTART:19011213T205156
RDATE;VALUE=DATE-TIME:19011213T205156
END:STANDARD
BEGIN:STANDARD
TZNAME:CET
TZOFFSETFROM:+0000
TZOFFSETTO:+0100
DTSTART:19460930T000000
RDATE;VALUE=DATE-TIME:19460930T000000
END:STANDARD
BEGIN:DAYLIGHT
TZNAME:CEST
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
DTSTART:19850331T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZNAME:CET
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
DTSTART:19961027T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
BEGIN:STANDARD
TZNAME:CET
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
DTSTART:19850929T030000
RRULE:FREQ=YEARLY;COUNT=11;BYDAY=-1SU;BYMONTH=9
END:STANDARD
END:VTIMEZONE

END:VCALENDAR
Comment 16 Philippe ROUBACH 2015-03-08 11:23:26 UTC
Created attachment 91475 [details]
how korganizer displays the owncloud test event
Comment 17 Philippe ROUBACH 2015-03-08 11:24:12 UTC
Created attachment 91476 [details]
how korganizer displays the owncloud test event
Comment 18 Philippe ROUBACH 2015-03-08 11:31:17 UTC
Created attachment 91477 [details]
how korganizer editor displays the pessac_arcahon event
Comment 19 Philippe ROUBACH 2015-03-08 11:31:59 UTC
Created attachment 91478 [details]
how korganizer displays the pessac_arachon event
Comment 20 Philippe ROUBACH 2015-03-08 17:42:04 UTC
there is no pb with owncloud
Comment 21 Philippe ROUBACH 2016-12-23 15:54:32 UTC
no more problem
with opensuse 42.2 and korganizer 16.08