Bug 338309 - Akregator 4.14 RC crashes when closing
Summary: Akregator 4.14 RC crashes when closing
Status: RESOLVED DUPLICATE of bug 336417
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-15 21:25 UTC by Marco
Modified: 2015-05-18 21:22 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
akregatorkcrash (4.30 KB, text/plain)
2014-08-15 21:25 UTC, Marco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco 2014-08-15 21:25:54 UTC
Created attachment 88270 [details]
akregatorkcrash

Application: akregator (4.14 rc)
KDE Platform Version: 4.13.97
Qt Version: 4.8.6
Operating System: Linux 3.13.0-34-generic i686
Distribution: Ubuntu 14.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Distro: Kubuntu 14.04 LTS
Akregator crashes when closing. The crash occurred 4 times since I upgraded to KDE 4.14 RC

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb33b6980 (LWP 2027))]

Thread 2 (Thread 0xa9875b40 (LWP 2031)):
#0  0xb48e118a in __GI___pthread_mutex_lock (mutex=0xa8f00558) at ../nptl/pthread_mutex_lock.c:125
#1  0xb5ed6c74 in pthread_mutex_lock (mutex=0xa8f00558) at forward.c:192
#2  0xb484d100 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb48079bd in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb48082df in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4808528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb6d6d95f in QEventDispatcherGlib::processEvents (this=0xa8f00468, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#7  0xb6d3c823 in QEventLoop::processEvents (this=this@entry=0xa9875258, flags=...) at kernel/qeventloop.cpp:149
#8  0xb6d3cb49 in QEventLoop::exec (this=this@entry=0xa9875258, flags=...) at kernel/qeventloop.cpp:204
#9  0xb6c2923d in QThread::exec (this=this@entry=0xa0b7680) at thread/qthread.cpp:537
#10 0xb6d1cc44 in QInotifyFileSystemWatcherEngine::run (this=0xa0b7680) at io/qfilesystemwatcher_inotify.cpp:265
#11 0xb6c2bb6f in QThreadPrivate::start (arg=0xa0b7680) at thread/qthread_unix.cpp:349
#12 0xb48def70 in start_thread (arg=0xa9875b40) at pthread_create.c:312
#13 0xb5ec988e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:129

Thread 1 (Thread 0xb33b6980 (LWP 2027)):
[KCrash Handler]
#7  data (this=0x5d) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:135
#8  qGetPtrHelper<QScopedPointer<QObjectData> > (p=...) at ../../include/QtCore/../../src/corelib/global/qglobal.h:2467
#9  d_func (this=0x59) at ../../include/QtCore/../../src/corelib/kernel/qobject.h:115
#10 QMetaObject::activate (sender=sender@entry=0x9e56748, m=m@entry=0xb75ddc1c <Akregator::Frame::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0xbffd59f8) at kernel/qobject.cpp:3489
#11 0xb75c4325 in Akregator::Frame::signalCompleted (this=this@entry=0x9e56748, _t1=_t1@entry=0x9e56748) at moc_frame.cpp:200
#12 0xb75b9cfc in Akregator::Frame::slotSetState (this=0x9e56748, state=state@entry=Akregator::Frame::Completed) at ../../../akregator/src/frame.cpp:94
#13 0xb075b8b8 in Akregator::MainWidget::slotFetchingStopped (this=0x9db7020) at ../../../akregator/src/mainwidget.cpp:808
#14 0xb077c178 in Akregator::MainWidget::qt_static_metacall (_o=0x9e484d0, _id=164091624, _a=0xbffd5af8, _c=<optimized out>) at moc_mainwidget.cpp:190
#15 0xb6d530f7 in QMetaObject::activate (sender=sender@entry=0x9c8c3a0, m=m@entry=0xb75ddc4c <Akregator::FetchQueue::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#16 0xb75c3d85 in Akregator::FetchQueue::signalStopped (this=this@entry=0x9c8c3a0) at moc_fetchqueue.cpp:126
#17 0xb75b961a in Akregator::FetchQueue::slotAbort (this=this@entry=0x9c8c3a0) at ../../../akregator/src/fetchqueue.cpp:68
#18 0xb75b9699 in Akregator::FetchQueue::~FetchQueue (this=0x9c8c3a0, __in_chrg=<optimized out>) at ../../../akregator/src/fetchqueue.cpp:50
#19 0xb75b971c in Akregator::FetchQueue::~FetchQueue (this=0x9c8c3a0, __in_chrg=<optimized out>) at ../../../akregator/src/fetchqueue.cpp:53
#20 0xb75b8457 in Akregator::Kernel::~Kernel (this=0xb75de65c <Akregator::Kernel::self()::self>, __in_chrg=<optimized out>) at ../../../akregator/src/kernel.cpp:66
#21 0xb5e104e1 in __run_exit_handlers (status=status@entry=0, listp=0xb5f893c4 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#22 0xb5e1053d in __GI_exit (status=0) at exit.c:104
#23 0xb5df6a8b in __libc_start_main (main=0x804dd00 <main(int, char**)>, argc=5, argv=0xbffd5cf4, init=0x8050830 <__libc_csu_init>, fini=0x80508a0 <__libc_csu_fini>, rtld_fini=0xb772a180 <_dl_fini>, stack_end=0xbffd5cec) at libc-start.c:321
#24 0x0804e426 in _start ()

Segnala a https://bugs.kde.org/
Comment 1 Mark Christie 2014-08-23 17:43:27 UTC
Comment on attachment 88270 [details]
akregatorkcrash

I get the same on Opensuse 13.1 however if I disable the systray icon everything is ok and the program shuts down gracefully.

Can anyone else confirm please?

Backtrace:

Application: akregator (4.14)
KDE Platform Version: 4.14.0
Qt Version: 4.8.5
Operating System: Linux 3.11.10-21-desktop x86_64
Distribution: "openSUSE 13.1 (Bottle) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed: Akregator segfaults ever time it is closed while it is showing the notification icon in the systray

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f44bacef880 (LWP 4233))]

Thread 2 (Thread 0x7f4497b23700 (LWP 4235)):
#0  0x00007f44b7848b3d in poll () from /lib64/libc.so.6
#1  0x00007f44b1c1b604 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f44b1c1b70c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f44b9125d76 in QEventDispatcherGlib::processEvents (this=0x7f44900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007f44b90f7d0f in QEventLoop::processEvents (this=this@entry=0x7f4497b22d20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f44b90f8005 in QEventLoop::exec (this=this@entry=0x7f4497b22d20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f44b8ff6fef in QThread::exec (this=this@entry=0x1781740) at thread/qthread.cpp:536
#7  0x00007f44b90d9513 in QInotifyFileSystemWatcherEngine::run (this=0x1781740) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f44b8ff968f in QThreadPrivate::start (arg=0x1781740) at thread/qthread_unix.cpp:338
#9  0x00007f44b2a2d0db in start_thread () from /lib64/libpthread.so.0
#10 0x00007f44b785190d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f44bacef880 (LWP 4233)):
[KCrash Handler]
#5  deref (this=0x720077003a003a) at ../../src/corelib/arch/qatomic_x86_64.h:133
#6  QString::operator= (this=this@entry=0x16cd860, other=...) at tools/qstring.cpp:1411
#7  0x00007f44ba1d286b in Akregator::Frame::slotSetStatusText (this=0x16cd820, s=...) at /usr/src/debug/kdepim-4.14.0/akregator/src/frame.cpp:65
#8  0x00007f44a148a105 in Akregator::MainWidget::slotFetchingStopped (this=0x16ec7a0) at /usr/src/debug/kdepim-4.14.0/akregator/src/mainwidget.cpp:810
#9  0x00007f44b910cd68 in QMetaObject::activate (sender=sender@entry=0x16a1140, m=m@entry=0x7f44ba3f47c0 <Akregator::FetchQueue::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x0) at kernel/qobject.cpp:3556
#10 0x00007f44ba1db783 in Akregator::FetchQueue::signalStopped (this=this@entry=0x16a1140) at /usr/src/debug/kdepim-4.14.0/build/akregator/src/moc_fetchqueue.cpp:126
#11 0x00007f44ba1d2459 in Akregator::FetchQueue::slotAbort (this=this@entry=0x16a1140) at /usr/src/debug/kdepim-4.14.0/akregator/src/fetchqueue.cpp:68
#12 0x00007f44ba1d24ca in Akregator::FetchQueue::~FetchQueue (this=0x16a1140, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.14.0/akregator/src/fetchqueue.cpp:50
#13 0x00007f44ba1d2539 in Akregator::FetchQueue::~FetchQueue (this=0x16a1140, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.14.0/akregator/src/fetchqueue.cpp:53
#14 0x00007f44ba1d1519 in Akregator::Kernel::~Kernel (this=0x7f44ba3f5c58 <Akregator::Kernel::self()::self>, __in_chrg=<optimized out>) at /usr/src/debug/kdepim-4.14.0/akregator/src/kernel.cpp:66
#15 0x00007f44b77a23d9 in __run_exit_handlers () from /lib64/libc.so.6
#16 0x00007f44b77a2425 in exit () from /lib64/libc.so.6
#17 0x00007f44b778bbec in __libc_start_main () from /lib64/libc.so.6
#18 0x000000000040872d in _start () at ../sysdeps/x86_64/start.S:122
Comment 2 Michael 2014-08-26 17:47:06 UTC
Application: akregator (4.14)
KDE Platform Version: 4.14.0
Qt Version: 4.8.2
Operating System: Linux 3.13.11 x86_64
Distribution: Neptune

-- Information about the crash:
- What I was doing when the application crashed:

i  re-setup my feeds - via hand and copy & paste or via rekonq. 
i close akregator whit crash ....

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8096c47760 (LWP 19235))]

Thread 2 (Thread 0x7f8071259700 (LWP 19240)):
#0  0x00007f809378e5c3 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f808e03cc2c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f808e03cd54 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f809438d296 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f809435d8af in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f809435db38 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f8094260d70 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f8094263d0b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f808e510b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#9  0x00007f809379920d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f8096c47760 (LWP 19235)):
[KCrash Handler]
#5  0x00007f80943742f9 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f8096120ce2 in Akregator::Frame::signalCompleted(Akregator::Frame*) () from /usr/lib/libakregatorprivate.so.4
#7  0x00007f8096116bfa in Akregator::Frame::slotSetState(Akregator::Frame::State) () from /usr/lib/libakregatorprivate.so.4
#8  0x00007f807ce07716 in Akregator::MainWidget::slotFetchingStopped() () from /usr/lib/kde4/akregatorpart.so
#9  0x00007f809437454f in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f80961167b9 in Akregator::FetchQueue::slotAbort() () from /usr/lib/libakregatorprivate.so.4
#11 0x00007f8096116829 in Akregator::FetchQueue::~FetchQueue() () from /usr/lib/libakregatorprivate.so.4
#12 0x00007f8096116899 in Akregator::FetchQueue::~FetchQueue() () from /usr/lib/libakregatorprivate.so.4
#13 0x00007f809611574d in Akregator::Kernel::~Kernel() () from /usr/lib/libakregatorprivate.so.4
#14 0x00007f80936f3ec2 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#15 0x00007f80936f3f15 in exit () from /lib/x86_64-linux-gnu/libc.so.6
#16 0x00007f80936dbef4 in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#17 0x000000000040871d in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 336417.

Possible duplicates by query: bug 336417.

An https://bugs.kde.org/ berichten
Comment 3 Christoph Feck 2014-09-05 13:37:08 UTC

*** This bug has been marked as a duplicate of bug 336417 ***