Bug 338227 - Kwin slide effect should keep window fixed relative to viewport when moving to another desktop
Summary: Kwin slide effect should keep window fixed relative to viewport when moving t...
Status: RESOLVED DUPLICATE of bug 213847
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-window-management (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-12 22:25 UTC by Igor Tarasov
Modified: 2014-08-13 06:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Tarasov 2014-08-12 22:25:59 UTC
Currently when you move window from one desktop to the other with Slide effect enabled it looks like this: http://www.youtube.com/watch?v=iDHsHoOiPqs

That is, when you move window to another workspace it disappears, and then appears at the new desktop, and it doesn't look intuitive, you don't really have a feeling that this window is moving to another desktop. Animation was slowed down for the above video, in reality you don't really understand what happens (try playing that video on 2x speed, but this won't give you the real speed).

In compiz however, window that is being moved is fixed relative to the viewport. So that you really see the animation how this window moves to another desktop. It looks like this: http://www.youtube.com/watch?v=gVTppLvXnUc#t=271 This one is much more intuitive - you see your workspaces switching and window moving from one workspace to the other.
Comment 1 Martin Flöser 2014-08-13 06:11:16 UTC

*** This bug has been marked as a duplicate of bug 185710 ***
Comment 2 Igor Tarasov 2014-08-13 06:33:31 UTC
Martin, that bug relates to another problem - inconsistency in behavior of slide animation in some directions under some conditions. The behavior described in this bug is consistent, but counter-intuitive. However, I've found another bug that describes exactly this behavior. Changing dupe status to that one.

*** This bug has been marked as a duplicate of bug 213847 ***