Bug 338222 - False positive critical warnings for KStandardActions
Summary: False positive critical warnings for KStandardActions
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kxmlgui
Classification: Unclassified
Component: general (show other bugs)
Version: 5.1.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-12 16:34 UTC by Cristian Oneț
Modified: 2014-09-09 14:08 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.2.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian Oneț 2014-08-12 16:34:19 UTC
I'm getting these critical warnings for KStandardActions. I understand the reason to notify the application developer that he should set a default shortcut instead of the shortcut but this should not be done for standard actions or KActionCollection::addAction should properly set a default shortcut for standard actions. Either way the issue is in the KXmlGui framework.

Critical:Shortcut for action  "file_new" "&New" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
Comment 1 Friedrich W. H. Kossebau 2014-08-31 16:44:09 UTC
Am also annoyed by those warning, enough to try a first approach to it with some patches:
* https://git.reviewboard.kde.org/r/120024/
* https://git.reviewboard.kde.org/r/120025/
* https://git.reviewboard.kde.org/r/120026/

Not sure this perfect solution yet, as I still miss the complete picture. But it might be one step into the right direction.
Comment 2 Cristian Oneț 2014-09-09 14:08:03 UTC
Fixed by https://git.reviewboard.kde.org/r/120088/ it's a shame that bug reports are not maintained.