Bug 338215 - A substring in a call to drkonqi from akonadi in kdepimlibs is not completely filled in
Summary: A substring in a call to drkonqi from akonadi in kdepimlibs is not completely...
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: libakonadi (show other bugs)
Version: GIT (master)
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-12 10:57 UTC by Freek de Kruijf
Modified: 2016-09-25 15:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of window of drkonqi in Dutch (66.95 KB, image/png)
2014-08-12 10:57 UTC, Freek de Kruijf
Details
second screenshot of window of drkonqi in Dutch (68.31 KB, image/png)
2014-08-12 11:04 UTC, Freek de Kruijf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Freek de Kruijf 2014-08-12 10:57:04 UTC
Created attachment 88229 [details]
screenshot of window of drkonqi in Dutch

drkonqi is called and uses a string "We are sorry, <application>%1</application> closed unexpectedly." to show the application. Apparently the string to be used in %1 comes from libakonadi and reads "%1 of type %2". However %1 is filled in with the name of an account but %2 in not filled in.
The text I see in the window of drkonqi shows "We are sorry, IMAP-eik of type closed unexpectedly." I assume IMAP should be present after type. I see it in Dutch and I have transported the text back to the English version using the texts in the po files.
Comment 1 Freek de Kruijf 2014-08-12 11:04:30 UTC
Created attachment 88230 [details]
second screenshot of window of drkonqi in Dutch
Comment 2 Freek de Kruijf 2014-08-12 11:05:20 UTC
After the previous report I pressed Restart application and again the window of drkonqi appeared. However now the type has been filled in. See the attached second screenshot.
Comment 3 Denis Kurz 2016-09-24 20:41:35 UTC
This bug has only been reported for versions older than KDEPIM 4.14 (at most akonadi-1.3). Can anyone tell if this bug still present?

If noone confirms this bug for a recent version of akonadi (part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 4 Freek de Kruijf 2016-09-25 15:54:10 UTC
I am unable to check this for kmail5 or rather akonadi. It appeared when connecting to a courier IMAP server with a problem. Now I am using dovecot. Can't reproduce it.