Bug 338204 - opus files not correctly added to collection
Summary: opus files not correctly added to collection
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Collections/Local (show other bugs)
Version: 2.8.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-11 21:39 UTC by m.eik michalke
Modified: 2014-08-12 20:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m.eik michalke 2014-08-11 21:39:17 UTC
i just converted a CD ("halber mensch" by einstürzende neubauten) into *.opus files with soundKonverter 2.0.5, then edited the metadata with easyTag 2.2.3, and finally rescanned my collection with amarok 2.8.0.

unfortunately, the files do not appear in my collection. when added to amarok's playlist via drag&drop, the files are played fine, but the metadata looks like a total mess, made up of parts from the file name and combined fields (e.g., the title field also contains the track number). it kinda fits the music. but it would be great if someone could try to replicate & solve this.
Comment 1 Matěj Laitl 2014-08-11 22:40:00 UTC
You need to have Amarok (>= 2.8) compiled against TagLib >= 1.9, see original bug.

*** This bug has been marked as a duplicate of bug 312905 ***
Comment 2 m.eik michalke 2014-08-12 00:36:53 UTC
this *is* amarok 2.8.0 (with TagLib 1.9.1).
Comment 3 m.eik michalke 2014-08-12 20:21:42 UTC
i recompiled amarok using the standard ubuntu package sources, and now it works! probably a packaging issue. sorry for the fuzz.