Bug 338079 - Kleopatra will not import 4096 byte keys from keyserver
Summary: Kleopatra will not import 4096 byte keys from keyserver
Status: RESOLVED FIXED
Alias: None
Product: kleopatra
Classification: Applications
Component: general (show other bugs)
Version: 2.2.0
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-06 21:09 UTC by John Andersen
Modified: 2016-04-08 18:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of import from certificate server. (42.00 KB, image/png)
2016-04-08 16:47 UTC, Andre Heinecke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Andersen 2014-08-06 21:09:55 UTC
The lookup on a keyserver of a 4096 byte key will work reliably.
Examples 0x8B1994F4 OR 0x69D25DF4
But it will not successfully import these keys from the server.
Using Kgpg, you can import these keys, and Kleopatra will show them.

Keyserver used on all tests was hpk://zimmermann.mayfirst.org

Reproducible: Always

Steps to Reproduce:
1. launch Kleopatra, click lookup certificates on server
2. key 0x8B1994F4 or any 4096 byte key, click search
3. Key is shown, select key, click import
4. zero keys are imported.
5. Launch Kgpg, file Key Management, key server dialog
6. enter same key 0x8B1994F4 click search see details
7. click import, key is imported and immediatly shows in both Kgpg and Kleopatra

Actual Results:  
As above

Expected Results:  
Kelopatra should import 4096 byte keys properly

All installed from Opensuse 12.3 RPMs KDE Platform Version 4.13.3 
With most recommendations being to move to longer keys this functionality is critical.
Comment 1 Andre Heinecke 2016-04-08 16:46:45 UTC
Hi,
Using kleopatra 2.3.0 (which will be part of applications 16.04) with gnupg 2.1.11 I was unable to reproduce this. I've configured keyserver to be  hpk://zimmermann.mayfirst.org and was able to import both the certificates you've mentioned in your report without issue.

So I think this is fixed, although I'm not sure why or where it was fixed :-)

Regards,
Andre
Comment 2 Andre Heinecke 2016-04-08 16:47:34 UTC
Created attachment 98290 [details]
Screenshot of import from certificate server.
Comment 3 John Andersen 2016-04-08 18:06:54 UTC
Confirming this still fails on Opensuse 13.2
Total number processed: 0
Imported: 0

On Kleopatra Version 2.2.0  (latest in repository)
Kde Dev platform 4.14.9
KGpg 2.14.1
gpg (GnuPG) 2.0.26
All from Opensuse 13.2 Repositories 

Confirm it WORKS on Manjaro (arch) Linux 15.12
Total number processed: 1
Imported: 1

On Kleopatra Version 2.2.0  (latest in repository)
Kde Framework 5.20.0
KGpg 2.17.0  
gpg (GnuPG) 2.1.11
All from Manjaro 15.12 Repositories 

-----------------------------------------------------
Summary:
Failure on KDE 4.14 (opensuse)
Success on KDE Framework 5.  (manjaro)
Entirely possible bug is in some of the underlying gpg systems that Kleopatra requires.