Bug 338054 - recipient is marked invalid because of at in caption and mail in brackets
Summary: recipient is marked invalid because of at in caption and mail in brackets
Status: RESOLVED NOT A BUG
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 4.11.5
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-05 16:42 UTC by Robert Riemann
Modified: 2014-08-06 07:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Riemann 2014-08-05 16:42:56 UTC
I wanted to send a mail to:

all@listes.what.ever <all@listes.what.ever>

and I couldn't because this recipient doesn't pass validation. I believe that this should pass and consider thus the validation as malformed.

What is your opinion about this? I think I got mails with a recipient like this.

Reproducible: Always

Steps to Reproduce:
1. just put "all@listes.what.ever <all@listes.what.ever>" in the recipient list
2. try to send the mail
3. an alert pops out and the mail doesn't get sent
Actual Results:  
cannot send mail

Expected Results:  
recipient should be valid
Comment 1 Laurent Montel 2014-08-06 07:26:25 UTC
Server informs us that we can't send.
it's not kmail.
So it's invalid.