Bug 337889 - Klauncher blocks upon starting DBusMulti applications
Summary: Klauncher blocks upon starting DBusMulti applications
Status: RESOLVED DUPLICATE of bug 343673
Alias: None
Product: frameworks-kinit
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-29 21:30 UTC by Hrvoje Senjan
Modified: 2016-07-21 18:37 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hrvoje Senjan 2014-07-29 21:30:05 UTC
This is at least case with Kate master (KF5 based).
I am not 100% sure whether bug is really in klauncher, or kdbusaddons, or kate.
Though the issue could be due to kate registering not org.kde.kate, but org.kde.kate-$PID.


It can be reproduced by opening 2nd document in kate, either via dolphin, or konsole, etc.

Symptoms are the same as in bug 75492.
Comment 1 demm 2015-01-06 17:57:14 UTC
Any progress on this?  Or ways to fix?
I can open a second document from dolphin (all frameworks 5/plasma 5 based), but need to close that second document in Kate, to get this message:
KDEInit could not launch '/usr/bin/kate'

After closing that message, dolphin becomes active again.
Comment 2 fademind 2015-01-20 06:23:36 UTC
Distro: Arch x64
KDE: 4.14.4 with parts of KF5 5.6.0

[tomasz@arch ~]$ pacman -Q|grep kdelib
kdelibs 4.14.4-1
kdelibs4support 5.6.0-1

FS#43513 [kdebase-dolphin] [kate] kdeinit could not launch '/usr/bin/kate'

[tomasz@arch ~]$ pacman -Q|grep kate
kate 14.12.1-2
katepart4 4.14.3-2
libkate 0.4.1-5
[tomasz@arch ~]$ pacman -Q|grep dolphin
kdebase-dolphin 14.12.1-2
[tomasz@arch ~]$ 



Steps:
Open Dolphin
Open in Kate any text File. 
Switch to Dolhin Window and try any action. For example open next tab.
Window freeze. After some time content is not visible:
http://i.imgur.com/PQktkVX.png

Console output:
[tomasz@arch ~]$ dolphin 
dolphin(3471) Baloo::XattrDetector::Private::init: supportedPaths: ("/home/tomasz")
dolphin(3471) Baloo::XattrDetector::Private::init: UnsupportedPaths: ("/", "/tmp", "/proc")
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-excel.sheet.binary.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-excel.sheet.binary.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-excel.addin.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-powerpoint.slideshow.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-powerpoint.slideshow.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-excel.sheet.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-excel.sheet.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-powerpoint.presentation.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-powerpoint.presentation.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-word.template.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-word.template.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-excel.template.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-excel.template.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-powerpoint.template.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-powerpoint.template.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-word.document.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-word.document.macroEnabled.12" 
dolphin(3471) KMimeTypeRepository::parents: "/usr/share/mime/subclasses" refers to unknown mimetype "application/vnd.ms-powerpoint.slide.macroEnabled.12" 
dolphin(3471) KSambaSharePrivate::isSambaInstalled: Samba is not installed! 
dolphin(3471) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf! 
dolphin(3471) KSambaSharePrivate::isSambaInstalled: Samba is not installed! 
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Brak dostępu 
QFileSystemWatcher: failed to add paths: /lost+found 
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Brak dostępu
QFileSystemWatcher: failed to add paths: /root
dolphin(3471) Baloo::FileFetchJob::doStart: No file index information found "/home/tomasz/kadu"
dolphin(3471) Baloo::FileFetchJob::doStart: No file index information found "/home/tomasz/kadu/kadu.install"
dolphin(3471) Baloo::FileFetchJob::doStart: No file index information found "/home/tomasz/kadu/kadu.install"
dolphin(3471) Baloo::FileFetchJob::doStart: No file index information found "/home/tomasz/kadu/PKGBUILD"

Console Output of kate:
[tomasz@arch ~]$ kate
kate: openURL

AFTER close kate window I see prompt:
http://i.imgur.com/T1BcyjY.png (Translation: kdeinit could not launch '/usr/bin/kate')
AFTER close prompt Dolphin window is good and working fine again:
http://i.imgur.com/Bz3qmZd.png
Comment 3 fademind 2015-01-24 18:57:34 UTC
 Comment by Antonio Rojas (arojas) - Saturday, 24 January 2015, 19:33 GMT+1
Removing X-DBUS-StartupType=Multi from the .desktop file fixes this for me. Can this be implemented as a workaround while this is fixed upstream? This is a really bad bug IMO, it makes kate useless for any advanced use.
  Comment by Tomasz (FadeMind) - Saturday, 24 January 2015, 19:49 GMT+1 — Edit
One more issue:
looping loading animation on kate icon after open several files. This feature can be disabe by adding value:

StartupNotify=false

in to the file /usr/share/applications/org.kde.kate.desktop
I confirm:
Disabling/removing X-DBUS-StartupType=Multi line in org.kde.kate.desktop file fixed issue kdeinit could not launch '/usr/bin/kate'
  Comment by Andrea Scarpino (BaSh) - Saturday, 24 January 2015, 19:51 GMT+1
Great. Please report those informations in the upstream bug report.

https://bugs.archlinux.org/task/43513
Comment 4 Konrad Materka 2015-03-31 06:53:55 UTC
Probably a duplicate of 343673
Comment 5 Konrad Materka 2016-07-21 13:40:03 UTC
I think this bug can be closed. During last year problem never occurred for me. Probably it was fixed in https://bugs.kde.org/show_bug.cgi?id=343673
Comment 6 David Faure 2016-07-21 18:37:32 UTC

*** This bug has been marked as a duplicate of bug 343673 ***