Bug 337757 - Wallpaper from theme not applied
Summary: Wallpaper from theme not applied
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Image Wallpaper (show other bugs)
Version: master
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-24 07:43 UTC by Pier Luigi Fiorini
Modified: 2019-06-14 22:32 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pier Luigi Fiorini 2014-07-24 07:43:19 UTC
My l&f package specifies a default theme with a custom wallpaper however the wallpaper plugin still shows Next, however if I use theme.wallpaperPathForSize() from the lock screen then the right wallpaper image is picked up.
Comment 1 Marco Martin 2014-07-24 08:48:20 UTC
Is the session started from a clean one or there was already an appletsrc? (if a wallpaer is saved, is not supposed to override the user choice)
Comment 2 Pier Luigi Fiorini 2014-07-24 08:59:45 UTC
It's always a clean session from the live CD.
Comment 3 Marco Martin 2014-07-24 10:12:18 UTC
hmm, can't reproduce
if i start with a theme that has this added to the metadata file

[Wallpaper]
defaultWallpaperTheme=Green_Leaves
defaultFileSuffix=.png
defaultWidth=1920
defaultHeight=1080


but not a saved wallpaper in the appletsrc yet, the right wallpaper is picked.

is the default plasma theme picked from l&f yet? is that correct at first start?
Comment 4 Pier Luigi Fiorini 2014-07-24 11:09:37 UTC
I did one more test.


At the first session (no saved config) it keeps using Next as a wallpaper picture. If I logout and login again it shows my wallpaper.

To logout I right click the desktop and select Leave.
When the logout window is shown I notice it has the right wallpaper which is loaded with this code: theme.wallpaperPathForSize(...) this means that somehow Plasma knows what is the default wallpaper but the wallpaper plugin has some issues.

Could it be because the wallpaper name contains a dash?
Comment 5 Marco Martin 2014-07-24 11:27:49 UTC
I think that the reason is that the plasma theme gets assigned too late, and somehow the wallpaper was already assigned when the theme was switched.

where exactly the plasma theme is assigned in that session? does it come from a plasmarc or somewhere else?
Comment 6 Pier Luigi Fiorini 2014-08-14 05:09:25 UTC
The theme is specified by my l&f package (defaults file) not by /etc/xdg/kdeglobals and the "theme" object from QML recognize the theme. It's the wallpaper plugin that keeps showing the Next wallpaper

If I remove ~/.config and add the following lines to /etc/xdg/kdeglobals then the wallpaper plugin loads the picture as specified by the maui desktoptheme:

[Theme]
name=maui

Looks like the wallpaper plugin is not affected by the configuration provided by l&f. Hope this helps tracking down the issue.
Comment 7 Marco Martin 2014-08-15 16:00:06 UTC
Git commit 030f536383376d8448675bfafeec88e4f775fa9d by Marco Martin.
Committed on 15/08/2014 at 15:54.
Pushed by mart into branch 'mart/LookAndFeelKCM'.

use the proper l&f package, with LookAndFeelAccess

still not enough but a part of 337757

M  +4    -12   shell/shellcorona.cpp
M  +0    -2    shell/shellcorona.h

http://commits.kde.org/plasma-workspace/030f536383376d8448675bfafeec88e4f775fa9d
Comment 8 Marco Martin 2014-08-15 16:09:41 UTC
Can you test it again after above commit?
to me it seems to fix it if i have a kdeglobals with a different lookandfeel package and no plasmarc at all
Comment 9 David Edmundson 2014-09-30 23:01:56 UTC
Closing as no-one responded to Marco in ages.
Please re-open if it doesn't fix it.
Comment 10 demm 2014-10-29 22:52:10 UTC
A rather similar issue here, also in live mode, selected wallpaper is not used. Difference is, the Live session gets a ~/.config/ plasma-org.kde.plasma.desktop-appletsrc with custom settings.  All settings are kept (example, switch from kickoff to kicker, add the volume-control plasmoid, switch from taskmanager to icons-only), but the line that sets the wallpaper is removed on start of the live session.
File in use, with line 91 being removed on start of the live session:
https://github.com/KaOSx/live-uefi/blob/master/configs/shared/overlay/home/live/.config/plasma-org.kde.plasma.desktop-appletsrc#L90
Which results in "Next" being the set wallpaper
Once logged into live mode, change wallpaper to desired setting, logout and in again, correct wallpaper settings are maintained.
Comment 11 Pier Luigi Fiorini 2014-10-30 19:05:48 UTC
Looks like configuration from l&f is honored and appletsrc is not then.
Reopening.
Comment 12 Nate Graham 2019-06-14 22:32:52 UTC
Cannot reproduce with various LNF packages today. Please re-open if you can reproduce.