Bug 337696 - Crash when unplugging bluetooth adapter
Summary: Crash when unplugging bluetooth adapter
Status: RESOLVED DUPLICATE of bug 340577
Alias: None
Product: solid
Classification: Frameworks and Libraries
Component: bluetooth (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-22 13:02 UTC by Alexandre Nunes
Modified: 2014-11-12 13:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Nunes 2014-07-22 13:02:53 UTC
This happens everytime. I suspect it started when bluez was upgraded from 4.whatever to 5.21.

Also, bluedevil doesn't "see" the device at all anymore (it doesn't appear neither in systray icon (no adapters found) and in settings tabs.

-- Backtrace:
Application: Bluetooth (bluedevil-monolithic), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#5  BlueDevil::Adapter::removeDevice (this=0x0, objectPath=...) at /tmp/pqp/libbluedevil-2.0~rc1/bluedevil/bluedeviladapter.cpp:283
#6  0x00007f0401b237c8 in BlueDevil::ManagerPrivate::_k_interfacesRemoved (this=0x8e6c70, objectPath=..., interfaces=...) at /tmp/pqp/libbluedevil-2.0~rc1/bluedevil/bluedevilmanager_p.cpp:178
#7  0x00007f04003b3a0a in QMetaObject::activate (sender=sender@entry=0x8ec2c0, m=m@entry=0x7f0401d3da00 <OrgFreedesktopDBusObjectManagerInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=1, argv=argv@entry=0x7fff14a29220) at kernel/qobject.cpp:3567
#8  0x00007f0401b2faba in OrgFreedesktopDBusObjectManagerInterface::InterfacesRemoved (this=this@entry=0x8ec2c0, _t1=..., _t2=...) at /tmp/pqp/libbluedevil-2.0~rc1/obj-x86_64-linux-gnu/bluedevil/dbusobjectmanager.moc:116
#9  0x00007f0401b2fc4a in OrgFreedesktopDBusObjectManagerInterface::qt_static_metacall (_o=_o@entry=0x8ec2c0, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=1, _a=_a@entry=0x7fff14a29480) at /tmp/pqp/libbluedevil-2.0~rc1/obj-x86_64-linux-gnu/bluedevil/dbusobjectmanager.moc:58
#10 0x00007f0401b2fdb3 in OrgFreedesktopDBusObjectManagerInterface::qt_metacall (this=0x8ec2c0, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fff14a29480) at /tmp/pqp/libbluedevil-2.0~rc1/obj-x86_64-linux-gnu/bluedevil/dbusobjectmanager.moc:99
#11 0x00007f040072abf6 in QDBusConnectionPrivate::deliverCall (this=0x8e7b20, object=0x8ec2c0, msg=..., metaTypes=..., slotIdx=6) at qdbusintegrator.cpp:951
#12 0x00007f04003b7ed1 in QObject::event (this=0x8ec2c0, e=<optimized out>) at kernel/qobject.cpp:1222
#13 0x00007f0401027c0c in QApplicationPrivate::notify_helper (this=this@entry=0x7921f0, receiver=receiver@entry=0x8ec2c0, e=e@entry=0x785580) at kernel/qapplication.cpp:4570
#14 0x00007f040102e360 in QApplication::notify (this=0x7fff14a29b30, receiver=0x8ec2c0, e=0x785580) at kernel/qapplication.cpp:4356
#15 0x00007f0401f8379a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#16 0x00007f040039f7fd in QCoreApplication::notifyInternal (this=0x7fff14a29b30, receiver=receiver@entry=0x8ec2c0, event=event@entry=0x785580) at kernel/qcoreapplication.cpp:953
#17 0x00007f04003a2ed1 in sendEvent (event=0x785580, receiver=0x8ec2c0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x75d020) at kernel/qcoreapplication.cpp:1577
#19 0x00007f04003a3363 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#20 0x00007f04003cce43 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0x785750) at kernel/qeventdispatcher_glib.cpp:280
#22 0x00007f03fc855e04 in g_main_dispatch (context=0x792460) at /tmp/buildd/glib2.0-2.40.0/./glib/gmain.c:3064
#23 g_main_context_dispatch (context=context@entry=0x792460) at /tmp/buildd/glib2.0-2.40.0/./glib/gmain.c:3663
#24 0x00007f03fc856048 in g_main_context_iterate (context=context@entry=0x792460, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /tmp/buildd/glib2.0-2.40.0/./glib/gmain.c:3734
#25 0x00007f03fc8560ec in g_main_context_iteration (context=0x792460, may_block=1) at /tmp/buildd/glib2.0-2.40.0/./glib/gmain.c:3795
#26 0x00007f04003ccf8d in QEventDispatcherGlib::processEvents (this=0x75e9a0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#27 0x00007f04010c72c6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007f040039e481 in QEventLoop::processEvents (this=this@entry=0x7fff14a29a70, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007f040039e795 in QEventLoop::exec (this=this@entry=0x7fff14a29a70, flags=...) at kernel/qeventloop.cpp:204
#30 0x00007f04003a3ef7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#31 0x0000000000404757 in ?? ()
#32 0x00007f03ffb91b45 in __libc_start_main (main=0x4044b0, argc=1, argv=0x7fff14a29c68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff14a29c58) at libc-start.c:287
#33 0x00000000004047a6 in _start ()
Comment 1 David Rosca 2014-11-12 13:08:08 UTC
This is the same crash in libbluedevil as in the original report, but this time it crashes monolithic instead of kded.
I believe the patch in original report should fix it, so I am marking it as duplicate.

*** This bug has been marked as a duplicate of bug 340577 ***