Bug 337432 - allocine.fr does not find some movies
Summary: allocine.fr does not find some movies
Alias: None
Product: tellico
Classification: Applications
Component: general (show other bugs)
Version: 2.3.10
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: ---
Assignee: Robby Stephenson
Depends on:
Reported: 2014-07-14 09:46 UTC by Olivier Delaune
Modified: 2015-02-23 06:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 2.3.10


Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Delaune 2014-07-14 09:46:27 UTC
I created an entry for the movie "Bad Ass". Then, I tried to fill the entry automatically using allocine.fr. It did not find any information whereas the entry exists on the website (http://www.allocine.fr/film/fichefilm_gen_cfilm=201108.html?nopub=1)

Reproducible: Always
Comment 1 Olivier Delaune 2014-07-14 09:50:38 UTC
It is the same for the movie "Goal ! : naissance d'un prodige". The allocine entry is http://www.allocine.fr/film/fichefilm_gen_cfilm=56435.html?nopub=1
Comment 2 Olivier Delaune 2014-07-14 09:59:58 UTC
The same thing with "Ghost Dog: la voie du samourai". The allocine entry is http://www.allocine.fr/film/fichefilm_gen_cfilm=20172.html
Comment 3 Olivier Delaune 2014-07-14 10:17:02 UTC
Same thing with "Mais où est donc passée la septième compagnie ?". The allocine entry is http://www.allocine.fr/film/fichefilm_gen_cfilm=36384.html?nopub=1
Comment 4 Olivier Delaune 2014-07-14 11:46:57 UTC
The same for "Trop belle !". Allocine entry: http://www.allocine.fr/film/fichefilm_gen_cfilm=132095.html
Comment 5 Olivier Delaune 2014-08-19 20:33:40 UTC
The same for "Mince alors !". Allocine entry: http://www.allocine.fr/film/fichefilm_gen_cfilm=129372.html
Comment 6 Robby Stephenson 2014-10-11 23:56:21 UTC
*** Bug 338389 has been marked as a duplicate of this bug. ***
Comment 7 Robby Stephenson 2014-10-20 02:59:17 UTC
Git commit 81debef3052b56798693570c1ff71a44038a1c3f by Robby Stephenson.
Committed on 20/10/2014 at 02:57.
Pushed by rstephenson into branch '2.3'.

Remove punctuation from Allocine API search text

The Allocine API evidently doesn't like most punctuation. For now,
rather than removing all non alphabetic characters, limit to just a
specific set.
FIXED-IN: 2.3.10

M  +4    -0    ChangeLog
M  +18   -3    src/fetch/allocinefetcher.cpp
M  +21   -0    src/tests/allocinefetchertest.cpp
M  +1    -0    src/tests/allocinefetchertest.h

Comment 8 Olivier Delaune 2015-02-21 19:01:18 UTC
I reopen this bug report since there are still some title that do not whereas the entry exists on allocine.fr in the 2.3.10 version.
For example, "Alien, la résurrection" is not find. The allocine entry is there: http://www.allocine.fr/film/fichefilm_gen_cfilm=9046.html
Comment 9 Olivier Delaune 2015-02-21 20:26:52 UTC
The same for "Ernest et Célestine"
Comment 10 Robby Stephenson 2015-02-23 00:46:05 UTC
Make sure you're using the version of the data source that uses the Allocine API. The Allocine script from older versions isn't really supported any more by the author who wrote it. I can find both "Ernest et Célestine" and "Alien, la résurrection" in version 2.3.10.

If you're in doubt which version you're using, remove the data source and then add it back.
Comment 11 Olivier Delaune 2015-02-23 06:31:01 UTC
I compiled the latest release, the 2.3.10 version. I di not try to compiled the trunk since the patch you pushed few months ago should be present in the 2.3.10 version
Comment 12 Olivier Delaune 2015-02-23 06:33:47 UTC
Oops, you were right. I removed the script and downloaded it again and indeed now it works. Sorry for the noise.