Bug 337328 - Advanced color selector do not allow to show Shade selector only
Summary: Advanced color selector do not allow to show Shade selector only
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Dockers (show other bugs)
Version: git master (please specify the git hash!)
Platform: unspecified Linux
: NOR wishlist
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-10 15:14 UTC by Camille Bissuel
Modified: 2019-01-02 13:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
shade selector patch (5.06 KB, patch)
2015-06-19 20:08 UTC, Halla Rempt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Camille Bissuel 2014-07-10 15:14:46 UTC
Hi,

I'd like to have only the MyPaint shade selector in the Advanced Color Selector :
Right now I can't hide the classic color selector, and for my workflow it's only a duplicate of the right-click pop-up palette... so a waste of screen space.

Checked with Timothée before submiting ;)

Thanks
Comment 1 Camille Bissuel 2015-02-13 14:00:49 UTC
Any hope to see this solved in 2.9 ? 
A simple "do not show" radio button in the "Color selector" tab of the options of the "advanced color selector" docker would do the trick ;)

Thanks again for your great work on Krita !
Comment 2 Halla Rempt 2015-02-13 14:58:27 UTC
Argh... I'm sorry, but this sliped through, and right now we're in string freeze so we cannot add a single checkbox before we release :-(
Comment 3 Camille Bissuel 2015-02-13 15:11:44 UTC
My fault, I should have updated sooner... 
But, no worries, it's not urgent : a shortcut do the job right now... I just would prefer to have it in a docker.

Maybe for an 2.9.X version, or something like that ;)

Thanks again !
Comment 4 Ranveer 2015-02-14 13:03:45 UTC
Hi Camille,

If I'm not wrong, there needs to be a checkbox in Settings > Configure Krita > Color Selector Settings > Advanced Color Selector Docker Settings to turn on or off the color selector (the big triangle encompassed by a ring) in the Advanced Color Selector window on the right. Am I right? (Also, please pardon my lack of sense of naming components; I'm a newbie over here :) ).
I'll try and fix it then.
Comment 5 Camille Bissuel 2015-02-14 17:49:06 UTC
Yes, Ranveer, that's it, thanks for your proposal !
You can access the same settings by clicking the "spanner" icon in the docker itself.
But the idea is to be able to hide this big triangle encompassed by a ring to display only the shade selector.

Is it a problem if the window become fully empty (if the shade selector is also hidden)... ?
I don't think so, but if it's a yes, hiding one should automatically show the other...
Comment 6 Ranveer 2015-02-14 18:44:29 UTC
(In reply to Camille Bissuel from comment #5)
> Is it a problem if the window become fully empty (if the shade selector is
> also hidden)... ?
> I don't think so, but if it's a yes, hiding one should automatically show
> the other...

I didn't get you. Do you intend to hide the whole docker? AFAIK, the advanced color selector is composed of the color selector and the shade selector only. Hiding both would mean empty-ing the whole docker.
Comment 7 Ranveer 2015-02-14 20:36:33 UTC
@Boud So I was wondering how to do this.
I tracked down the file that renders the color chooser as "<path-to-src>/src/calligra/krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_ng_docker_widget.cpp"
There, `m_colorSelectorContainer` is an object of the class `KisColorSelectorContainer` that controls the color selector (I removed all occurrences of this object in the file to see if this was indeed the case; It did work). So, I'll be storing a boolean value in `KGlobal::config()->group("advancedColorSelector")` that'll pertain to the visibility of the color selector. 
What would be the best way to hide it though? Also, is my approach correct?
Comment 8 Camille Bissuel 2015-02-16 07:57:53 UTC
Hi Ranveer,

I'll try to be more clear : even if the Color selector (2nd tab) and the Sshade selector (3rd tab) are hidden, there may be the "Color patches" (4th tab) left.
So one may use this docker only to keep track of color history for example.

So hiding both Color selector and Shade selector should ideally be possible, even if the docker look empty temporary ;)
Comment 9 Ranveer 2015-02-16 10:47:34 UTC
(In reply to Camille Bissuel from comment #8)
> Hi Ranveer,
> 
> I'll try to be more clear : even if the Color selector (2nd tab) and the
> Sshade selector (3rd tab) are hidden, there may be the "Color patches" (4th
> tab) left.
> So one may use this docker only to keep track of color history for example.
> 
Ah! I get it now. 

> So hiding both Color selector and Shade selector should ideally be possible,
> even if the docker look empty temporary ;)

Yes, it is definitely possible, as far as I see in the source code, both components are getting placed in the docker in a similar way. 
I'll try and implement it and send you a screenshot of the result to confirm, just in case.
Comment 10 Halla Rempt 2015-02-19 18:18:51 UTC
Git commit cb207e27e7cda184f0901e4ea5bcb79cb8bcf666 by Boudewijn Rempt.
Committed on 19/02/2015 at 18:17.
Pushed by rempt into branch 'master'.

REVIEW:122638
CCMAIL:ranveeraggarwal@gmail.com

Patch by Ranveer Aggarwal. Thanks!

M  +6    -0    krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_container.cpp
M  +1    -0    krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_container.h
M  +6    -0    krita/plugins/extensions/dockers/advancedcolorselector/kis_color_selector_settings.cpp
M  +7    -0    krita/plugins/extensions/dockers/advancedcolorselector/wdg_color_selector_settings.ui

http://commits.kde.org/calligra/cb207e27e7cda184f0901e4ea5bcb79cb8bcf666
Comment 11 Camille Bissuel 2015-02-20 07:48:02 UTC
Great ! Thanks Ranveer !
Now I'm not only waiting 2.9, but 2.9.1 too ;)
I'll try to compile from master in the meantime to give my feedback ;)
Comment 12 Camille Bissuel 2015-03-16 10:17:37 UTC
Mmh... can't see anything compiling from AUR (https://aur.archlinux.org/packages/krita-git/)
neither from the latest 2.9.1 packages... (https://www.archlinux.org/packages/extra/x86_64/calligra-krita/)

Is this on a special branch ?

Thanks !
Camille
Comment 13 Camille Bissuel 2015-05-06 08:57:42 UTC
I'm sorry if I'm dumb... but it's now 2.9.4, and I still can't find this option in Krita... 
This patch was sent to master... but will it be included in the 2.9 releases ?
Or some issue prevent it ?

Sorry to disturb you with a resolved wishlist bug...
Comment 14 Halla Rempt 2015-05-06 09:02:25 UTC
There are other patches in master that I probably should merge to 2.9, since it's going to take a long time for master to reach users :-( This is one of them, so thanks for reminding me!
Comment 15 Camille Bissuel 2015-05-06 09:09:30 UTC
Thanks Boudewijn.... !
I just understood today that 'master' branch was separated from '2.9' (and releases in general)...

Making users and developers understand each other is still difficult... despite the Krita team is the most open minded and welcoming I ever met ;)
Comment 16 Camille Bissuel 2015-06-19 16:12:38 UTC
I use the starting Bug hunting week to say again this is waiting for inclusion ;)

Maybe a special tag in the bug tracker is needed for such waiting patches ? 
What do you suggest ?

Thanks a lot again !
Comment 17 Halla Rempt 2015-06-19 20:08:14 UTC
Created attachment 93247 [details]
shade selector patch

This is the patch; it got broken in the meantime and doesn't apply to 2.9 anymore, so it needs reworking.
Comment 18 Camille Bissuel 2015-06-22 07:39:37 UTC
Sadly reopening... Hope it's not too much work to make it work again...
Comment 19 Halla Rempt 2016-01-24 16:05:35 UTC
WISHGROUP: Small Usability Fixes
Comment 20 Anna Medonosova 2019-01-01 12:58:57 UTC
Git commit 52afd0cbfc8e23d1b4c9f519356dbe847fc2a890 by Anna Medonosova.
Committed on 01/01/2019 at 12:58.
Pushed by amedonosova into branch 'master'.

Advanced Color Selector: option to hide color selector

Summary:
I have resurrected the original patch by Ranveer Aggarwal, which enables the user to hide the
color selector part of the docker.

There was one issue with the original: the docker settings button is inside the color selector, therefore when you hide
the selector, the only way to configure the docker is via the main menu, "Settings" -> "Configure Krita". To solve that I have added
a fallback settings button to the docker widget, which appears when the color selector part is hidden.

Reviewers: #krita, rempt

Reviewed By: #krita, rempt

Subscribers: rempt

Tags: #krita

Differential Revision: https://phabricator.kde.org/D17893

M  +15   -8    plugins/dockers/advancedcolorselector/kis_color_selector_container.cpp
M  +1    -0    plugins/dockers/advancedcolorselector/kis_color_selector_container.h
M  +68   -4    plugins/dockers/advancedcolorselector/kis_color_selector_ng_docker_widget.cpp
M  +8    -0    plugins/dockers/advancedcolorselector/kis_color_selector_ng_docker_widget.h
M  +3    -3    plugins/dockers/advancedcolorselector/kis_color_selector_settings.cpp
M  +256  -244  plugins/dockers/advancedcolorselector/wdg_color_selector_settings.ui

https://commits.kde.org/krita/52afd0cbfc8e23d1b4c9f519356dbe847fc2a890
Comment 21 Camille Bissuel 2019-01-02 13:50:21 UTC
Thanks a lot Anna ! and Happy new year ;)
Hopefully this will land successfully into next release ;)