Bug 337254 - [UserBase Wiki] Unable to use Google accounts to login
Summary: [UserBase Wiki] Unable to use Google accounts to login
Status: RESOLVED FIXED
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-09 01:53 UTC by André Marcelo Alvarenga
Modified: 2020-07-13 18:07 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (19.37 KB, image/png)
2014-07-09 01:54 UTC, André Marcelo Alvarenga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André Marcelo Alvarenga 2014-07-09 01:53:46 UTC
I can't to login with my Google account (Error 400 (Bad Request)). See screenshot attached.

Learn more link: http://developers.google.com/accounts/docs/OpenID

Reproducible: Always
Comment 1 André Marcelo Alvarenga 2014-07-09 01:54:23 UTC
Created attachment 87655 [details]
Screenshot
Comment 2 Ben Cooksley 2014-07-09 01:59:01 UTC
Please use your Identity account to login in the interim.
It can be accessed from the same page used to initiate a OpenID login.
Comment 3 André Marcelo Alvarenga 2014-07-09 02:47:17 UTC
(In reply to comment #2)
> Please use your Identity account to login in the interim.
> It can be accessed from the same page used to initiate a OpenID lgin.

Thank you for replying.

Yes, I did it. But when I use my Identity account I can't to access my settings, like watchlist, user page, user_talk page.
Comment 4 Ben Cooksley 2014-07-09 08:05:24 UTC
You should still be able to. Can you provide a screenshot of where this is not working?
Comment 5 André Marcelo Alvarenga 2014-07-09 12:28:15 UTC
(In reply to comment #4)
> You should still be able to. Can you provide a screenshot of where this is
> not working?

Hi Ben.

My Identity account is using Alvarenga username:   https://userbase.kde.org/User:Alvarenga
My Google account is using André_Marcelo_Alvarenga username: https://userbase.kde.org/User:André_Marcelo_Alvarenga

I'm not using Alvarenga username. It's possible remove this username and set my Identity account to use André_Marcelo_Alvarenga username?
Comment 6 Will Entriken 2015-01-27 22:25:55 UTC
I cannot reproduce this, it seems to work now. Recommending to close the issue.
Comment 7 André Marcelo Alvarenga 2015-01-27 22:44:31 UTC
(In reply to Will Entriken from comment #6)
> I cannot reproduce this, it seems to work now. Recommending to close the
> issue.

Hi.

I can to login now, but there are this message:

Important warning: The OpenID2 to Google Accounts is no longer avaliable after April 20, 2015.
Comment 8 Will Entriken 2015-01-27 22:45:26 UTC
Yes, we will need to switch to OpenID connect on 4/20. But that's another issue :-)
Comment 9 Ben Cooksley 2015-01-27 22:48:51 UTC
André: are your duplicate account problems sorted out now?
Comment 10 André Marcelo Alvarenga 2015-01-27 23:25:45 UTC
(In reply to Will Entriken from comment #8)
> Yes, we will need to switch to OpenID connect on 4/20. But that's another
> issue :-)

Yes, but after the 24/20 we will have the same problem.

> André: are your duplicate account problems sorted out now?

No, but now I can use a password to login in https://userbase.kde.org/User:André_Marcelo_Alvarenga.
I cannot set my Identity account to use André_Marcelo_Alvarenga username because it is being used by Alvarenga username.
Comment 11 qubodup 2016-01-25 01:41:23 UTC
Logging in using Google ins still impossible. Please remove google as an option.
Comment 12 carl 2020-07-13 18:07:30 UTC
The option doesn't exist anymore.