Bug 336859 - kmail becomes unsable on moving a lot of msg (~8000) for a longer time (> 5 min)
Summary: kmail becomes unsable on moving a lot of msg (~8000) for a longer time (> 5 min)
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: UI (show other bugs)
Version: 4.13.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-29 09:13 UTC by Christoph Thielecke
Modified: 2016-06-08 20:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2014-06-29 09:13:34 UTC
When moving a lot of messages (~8000) from mixed maildir ressource to maildir ressource mail responds very slow. This means it freezes for a while, then gui was refreshed and again. This effect seems to be same on opening a maildir ressource folder containing a lot of messages or marking all messages in this folder.


Reproducible: Always

Steps to Reproduce:
1. go to a folder containing a lot of msg (> 5000)
2. select all
3. right click -> move msg to other maildir ressource folder
Actual Results:  
- files are moved but gui hangs during move process for longer time 

Expected Results:  
- gui should be stay in usable state on messages move is in processs

I moved from mixed maildir ressource to maildir ressource.
Comment 1 Martin Steigerwald 2016-06-08 20:14:22 UTC
Thank you for your report, Christoph. As KDEPIM SC 4 and Akonadi 1 is unmaintained, I am closing it. For the case of a pure maildir I reported this issue as:

Bug 364114 - moving a folder within one maildir resource is extremely slow and inefficient

I bet the behavior with mixedmaildir resource would be similar to what I observed. But feel free to create a bug report about moving within mixedmaildir and mention it as related in above bug report or add your findings to my bug report in case they are similar enough.