Bug 336809 - amarok crashes since I changed from OpenRC to systemd
Summary: amarok crashes since I changed from OpenRC to systemd
Status: RESOLVED DUPLICATE of bug 323635
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.8.0
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-27 20:42 UTC by blumberg.christian
Modified: 2014-06-28 17:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description blumberg.christian 2014-06-27 20:42:46 UTC
My Amarok-2.8.0-r1/...-r2 is always crashing at start since I've changed from OpenRC to systemd.

Reproduceable: always

Console output:
********************
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QString)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QString)
amarok(1787)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
KCrash: Application 'amarok' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/christian/.kde4/socket-detlef/kdeinit4__0
unnamed app(1786): Communication problem with  "amarok" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" " 
***************

Backtrace (probably useless):
***************
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2f794fe7c0 (LWP 1810))]

Thread 7 (Thread 0x7f2f57017700 (LWP 1813)):
#0  0x00007f2f761855cd in poll () from /lib64/libc.so.6
#1  0x00007f2f6ce9bd11 in ?? () from /usr/lib64/libpulse.so.0
#2  0x00007f2f6ce8d45c in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#3  0x00007f2f6ce8dac9 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#4  0x00007f2f6ce8db90 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#5  0x00007f2f6ce9bccf in ?? () from /usr/lib64/libpulse.so.0
#6  0x00007f2f683620b2 in ?? () from /usr/lib64/pulseaudio/libpulsecommon-5.0.so
#7  0x00007f2f742b1063 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2f7618f4fd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f2f55f8f700 (LWP 1814)):
#0  0x00007f2f761855cd in poll () from /lib64/libc.so.6
#1  0x00007f2f70a3ad8c in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f2f70a3aeac in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f2f7690b98e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f2f768dbe8f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f2f768dc170 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f2f767df820 in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f2f768bddff in ?? () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007f2f767e1fbc in ?? () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007f2f742b1063 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f2f7618f4fd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f2f54def700 (LWP 1815)):
#0  0x00007f2f742b503c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f767e256b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f2f73393b1e in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f2f7339644b in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2f73396464 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2f7339509f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2f767e1fbc in ?? () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007f2f742b1063 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2f7618f4fd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f2f545ee700 (LWP 1816)):
#0  0x00007f2f742b503c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f767e256b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f2f73393b1e in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f2f7339644b in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2f7339509f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2f767e1fbc in ?? () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f2f742b1063 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f2f7618f4fd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f2f53ded700 (LWP 1817)):
#0  0x00007f2f742b503c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f767e256b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007f2f73393b1e in ?? () from /usr/lib64/libthreadweaver.so.4
#3  0x00007f2f7339644b in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2f7339509f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2f767e1fbc in ?? () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007f2f742b1063 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f2f7618f4fd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f2f51087700 (LWP 1818)):
#0  0x00007f2f742b503c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2f46ca8eeb in ?? () from /usr/lib64/egl/egl_gallium.so
#2  0x00007f2f742b1063 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f2f7618f4fd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f2f794fe7c0 (LWP 1810)):
[KCrash Handler]
#5  0x00007f2f46cfbefe in ?? () from /usr/lib64/egl/egl_gallium.so
#6  0x00007f2f46d67cd7 in ?? () from /usr/lib64/egl/egl_gallium.so
#7  0x00007f2f46d681fb in ?? () from /usr/lib64/egl/egl_gallium.so
#8  0x00007f2f469255ed in ?? () from /usr/lib64/egl/egl_gallium.so
#9  0x00007f2f4692519f in ?? () from /usr/lib64/egl/egl_gallium.so
#10 0x00007f2f46a4f179 in ?? () from /usr/lib64/egl/egl_gallium.so
#11 0x00007f2f46a4b8b6 in ?? () from /usr/lib64/egl/egl_gallium.so
#12 0x00007f2f70d2cba3 in ?? () from /usr/lib64/libEGL.so.1
#13 0x00007f2f70d2ced4 in ?? () from /usr/lib64/libEGL.so.1
#14 0x00007f2f70d2806a in eglInitialize () from /usr/lib64/libEGL.so.1
#15 0x00007f2f7797b4d1 in QEgl::display() () from /usr/lib64/qt4/libQtGui.so.4
#16 0x00007f2f7797d925 in QEgl::chooseConfig(QEglProperties const*, QEgl::PixelFormatMatch) () from /usr/lib64/qt4/libQtGui.so.4
#17 0x00007f2f7797e2ae in QEglContext::chooseConfig(QEglProperties const&, QEgl::PixelFormatMatch) () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007f2f6a14fb65 in QGLContext::chooseContext(QGLContext const*) () from /usr/lib64/qt4/libQtOpenGL.so.4
#19 0x00007f2f6a0d8e0d in QGLContext::create(QGLContext const*) () from /usr/lib64/qt4/libQtOpenGL.so.4
#20 0x00007f2f6a14ff67 in QGLWidget::setContext(QGLContext*, QGLContext const*, bool) () from /usr/lib64/qt4/libQtOpenGL.so.4
#21 0x00007f2f6a0d84aa in ?? () from /usr/lib64/qt4/libQtOpenGL.so.4
#22 0x00007f2f6a14fff2 in ?? () from /usr/lib64/qt4/libQtOpenGL.so.4
#23 0x00007f2f6a0d8c9f in QGLWidget::QGLWidget(QWidget*, QGLWidget const*, QFlags<Qt::WindowType>) () from /usr/lib64/qt4/libQtOpenGL.so.4
#24 0x00007f2f516ce29a in ?? () from /usr/lib64/kde4/amarok_context_applet_analyzer.so
#25 0x00007f2f516ce389 in ?? () from /usr/lib64/kde4/amarok_context_applet_analyzer.so
#26 0x00007f2f516d0e70 in ?? () from /usr/lib64/kde4/amarok_context_applet_analyzer.so
#27 0x00007f2f516cc940 in ?? () from /usr/lib64/kde4/amarok_context_applet_analyzer.so
#28 0x00007f2f516cd415 in ?? () from /usr/lib64/kde4/amarok_context_applet_analyzer.so
#29 0x00007f2f727da5d9 in Plasma::Containment::addApplet(Plasma::Applet*, QPointF const&, bool) () from /usr/lib64/libplasma.so.3
#30 0x00007f2f727da961 in ?? () from /usr/lib64/libplasma.so.3
#31 0x00007f2f528f09b4 in ?? () from /usr/lib64/kde4/amarok_containment_vertical.so
#32 0x00007f2f528f1ba4 in ?? () from /usr/lib64/kde4/amarok_containment_vertical.so
#33 0x00007f2f7836db2d in Context::ContextView::loadConfig() () from /usr/lib64/libamaroklib.so.1
#34 0x00007f2f7836e0c6 in Context::ContextView::showHome() () from /usr/lib64/libamaroklib.so.1
#35 0x00007f2f7836b4d8 in ?? () from /usr/lib64/libamaroklib.so.1
#36 0x00007f2f768f17e4 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/qt4/libQtCore.so.4
#37 0x00007f2f727e93ef in Plasma::Corona::containmentAdded(Plasma::Containment*) () from /usr/lib64/libplasma.so.3
#38 0x00007f2f727eb58c in ?? () from /usr/lib64/libplasma.so.3
#39 0x00007f2f7836aacb in Context::ContextScene::loadDefaultSetup() () from /usr/lib64/libamaroklib.so.1
#40 0x00007f2f7836af41 in ?? () from /usr/lib64/libamaroklib.so.1
#41 0x00007f2f785d1fe4 in MainWindow::init() () from /usr/lib64/libamaroklib.so.1
#42 0x00007f2f785d374b in MainWindow::MainWindow() () from /usr/lib64/libamaroklib.so.1
#43 0x00007f2f785b8e1d in App::continueInit() () from /usr/lib64/libamaroklib.so.1
#44 0x00007f2f785ba43c in App::App() () from /usr/lib64/libamaroklib.so.1
#45 0x0000000000407ce5 in ?? ()
#46 0x00007f2f760c4c35 in __libc_start_main () from /lib64/libc.so.6
#47 0x0000000000407e15 in _start ()
**************

I've rebuilt glibc, and all other dependencies from amarok.

Reproducible: Always

Steps to Reproduce:
1. open console
2. start amarok
3. crashing....
Actual Results:  
It gives ne a crash of amarok.

Expected Results:  
A starting GUI of amarok.

I will provide you with any additional information, when you ask for it. ;-)
Comment 1 Myriam Schweingruber 2014-06-28 17:30:20 UTC
The crash is not related to systemd, but to openGL, and already solved in the deff build.

As a workaround, please disable the analyzer, see also bug 323635

*** This bug has been marked as a duplicate of bug 323635 ***