Bug 336643 - Feature request: "undo" command
Summary: Feature request: "undo" command
Status: RESOLVED DUPLICATE of bug 117855
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-24 02:03 UTC by sparhawk
Modified: 2021-09-30 04:34 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sparhawk 2014-06-24 02:03:31 UTC
Version: 4.13.2 (not in the list?)

RSSOwl has an undo functionality. Occasionally, I accidentally mark news as read. It'd be great to be able to undo this action in Akregator, so that I can re-find my unread news. Often, I find myself accidentally missing several news items since I cannot undo.

I think RSSOwl also lets you undo deletion of feeds, which might be helpful to some users.

Reproducible: Always

Steps to Reproduce:
1. Mark news as read.
2. Attempt to undo.
Actual Results:  
Nothing.

Expected Results:  
Last "read" news item is again marked as unread.

It's also be useful to allow undo when multiple articles are marked as read, and keep a history for multiple iterations of undo.
Comment 1 sparhawk 2015-02-18 21:57:22 UTC
FWIW I've gone back to RSSOwl solely for this functionality. (RSSOwl was crashing a lot for me on the previous version, but now it's fixed.)
Comment 2 Justin Zobel 2021-03-09 04:11:20 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 3 sparhawk 2021-03-09 04:15:32 UTC
I appreciate the "thank you", but the lack of response after I try to contribute to KDE means I don't bother filing bugs/requests any more.

In a similar vein, I can't confirm or deny this bug because I don't use Akregator any more, and haven't done for six years.
Comment 4 Fushan Wen 2021-09-29 15:24:23 UTC
What about showing a warning before "Mark Feed as Read"?
Comment 6 Fushan Wen 2021-09-30 04:34:17 UTC

*** This bug has been marked as a duplicate of bug 117855 ***