Bug 336268 - Crash of "Stich images into a panorama"
Summary: Crash of "Stich images into a panorama"
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Generic-Panorama (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-15 15:46 UTC by Mathieu MD
Modified: 2021-08-27 03:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu MD 2014-06-15 15:46:49 UTC
Application: digikam (4.0.0)
KDE Platform Version: 4.13.1
Qt Version: 4.8.6
Operating System: Linux 3.13-1-amd64 x86_64
Distribution: Debian GNU/Linux testing (jessie)

-- Information about the crash:
I was trying to make a panorama from 4 photos, using the tools > Stich images into a panorama

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb758bb0b00 (LWP 18898))]

Thread 9 (Thread 0x7fb733730700 (LWP 18899)):
#0  0x00007fb751c77d5d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb738208798 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#2  0x00007fb74dc890ca in start_thread (arg=0x7fb733730700) at pthread_create.c:312
#3  0x00007fb751c82ffd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 8 (Thread 0x7fb727fff700 (LWP 18901)):
#0  0x00007fb74a50940f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb74a50b62b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb74a50bf03 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb74a50c0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb752b8d676 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fb752b5efef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fb752b5f2e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fb752a5bbef in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fb752b40763 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fb752a5e2bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fb74dc890ca in start_thread (arg=0x7fb727fff700) at pthread_create.c:312
#11 0x00007fb751c82ffd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 7 (Thread 0x7fb726390700 (LWP 18905)):
#0  0x00007fb751c77d5d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb74a50bfe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb74a50c0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb752b8d676 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fb752b5efef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fb752b5f2e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fb752a5bbef in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fb752b40763 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fb752a5e2bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fb74dc890ca in start_thread (arg=0x7fb726390700) at pthread_create.c:312
#10 0x00007fb751c82ffd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 6 (Thread 0x7fb6a87ac700 (LWP 18972)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb752a5e7a6 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007fb704168b9d in KIPIPlugins::KPRawThumbThread::run() () from /usr/lib/digikam/libkipiplugins.so.4.0.0
#3  0x00007fb752a5e2bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fb74dc890ca in start_thread (arg=0x7fb6a87ac700) at pthread_create.c:312
#5  0x00007fb751c82ffd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7fb6a7fab700 (LWP 18973)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb752a5e7a6 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007fb756666d01 in KDcrawIface::RActionThreadBase::run() () from /usr/lib/libkdcraw.so.23
#3  0x00007fb752a5e2bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fb74dc890ca in start_thread (arg=0x7fb6a7fab700) at pthread_create.c:312
#5  0x00007fb751c82ffd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7fb6a77aa700 (LWP 18974)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb752a5e7a6 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007fb75721a83c in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007fb75721d2d3 in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007fb75721bfef in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#5  0x00007fb752a5e2bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fb74dc890ca in start_thread (arg=0x7fb6a77aa700) at pthread_create.c:312
#7  0x00007fb751c82ffd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fb6a6fa9700 (LWP 18975)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb752a5e7a6 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007fb75721a83c in ?? () from /usr/lib/libthreadweaver.so.4
#3  0x00007fb75721d2d3 in ?? () from /usr/lib/libthreadweaver.so.4
#4  0x00007fb75721bfef in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#5  0x00007fb752a5e2bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fb74dc890ca in start_thread (arg=0x7fb6a6fa9700) at pthread_create.c:312
#7  0x00007fb751c82ffd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fb6a67a8700 (LWP 18976)):
[KCrash Handler]
#5  0x00007fb6d85de6c0 in panoScriptFree () from /usr/lib/kde4/kipiplugin_panorama.so
#6  0x00007fb6d85dea88 in panoScriptParse () from /usr/lib/kde4/kipiplugin_panorama.so
#7  0x00007fb6d85ca8b1 in ?? () from /usr/lib/kde4/kipiplugin_panorama.so
#8  0x00007fb6d85d735c in ?? () from /usr/lib/kde4/kipiplugin_panorama.so
#9  0x00007fb75721c682 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0x00007fb75721c83e in ThreadWeaver::Job::execute(ThreadWeaver::Thread*) () from /usr/lib/libthreadweaver.so.4
#11 0x00007fb75721e2db in ?? () from /usr/lib/libthreadweaver.so.4
#12 0x00007fb75721c08b in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#13 0x00007fb752a5e2bf in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007fb74dc890ca in start_thread (arg=0x7fb6a67a8700) at pthread_create.c:312
#15 0x00007fb751c82ffd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fb758bb0b00 (LWP 18898)):
#0  0x00007fb74dc8a500 in pthread_join (threadid=140424818919168, thread_return=0x0) at pthread_join.c:92
#1  0x00007fb738208ae9 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#2  0x00007fb7382063f8 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#3  0x00007fb7381fff64 in libusb_exit () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#4  0x00007fb73e0baf71 in ?? () from /usr/lib/x86_64-linux-gnu/libdc1394.so.22
#5  0x00007fb73e0a9816 in dc1394_free () from /usr/lib/x86_64-linux-gnu/libdc1394.so.22
#6  0x00007fb7482ee761 in CvDC1394::~CvDC1394() () from /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4
#7  0x00007fb751bd6f6f in __cxa_finalize (d=0x7fb748510000) at cxa_finalize.c:56
#8  0x00007fb7482dbb63 in ?? () from /usr/lib/x86_64-linux-gnu/libopencv_highgui.so.2.4
#9  0x00007fff815712d0 in ?? ()
#10 0x00007fb758a2803a in _dl_fini () at dl-fini.c:252
Backtrace stopped: frame did not save the PC


Reproducible: Always

Steps to Reproduce:
1. Select 4 photos
2. Click "Tools > Stich images into a panorama"
3. Check that all binaries are found and have a green "V" mark; then click Next
4. Click Next (list of images)
5. Click Next (confirmation)
6. Windows showing "Pre-processing is in progress, please wait. This can take a while..."
Actual Results:  
Digikam crash.
Popup to report a bug is shown (but it says that not enought information is available and suggest to manually submit the bug)

Expected Results:  
Images joint into a panorama, as it used to work "before".
Comment 1 Benjamin Girault 2014-06-15 16:57:57 UTC
You are using Hugin 2014. Please downgrade to 2013.

*** This bug has been marked as a duplicate of bug 334284 ***
Comment 2 caulier.gilles 2021-08-27 03:44:17 UTC
Fixed with #334284