Bug 335825 - Search filters don't really work
Summary: Search filters don't really work
Status: RESOLVED DUPLICATE of bug 348364
Alias: None
Product: kmail2
Classification: Applications
Component: search (show other bugs)
Version: 4.13
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-05 07:57 UTC by Martin Tlustos
Modified: 2017-01-13 14:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Tlustos 2014-06-05 07:57:02 UTC
I set up a search with the following conditions:
age is less than 35 days AND
subject does NOT contain "newsletter"

The search result only shows emails that do have "newsletter" in the subject line. Playing around with "contains" "begins with" and stuff changes nothing.

Reproducible: Always
Comment 1 Denis Kurz 2016-09-24 17:57:49 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 2 Martin Tlustos 2016-09-27 08:28:45 UTC
It still does not work in 5.1.3 - at least on my computer
Comment 3 Denis Kurz 2017-01-13 14:54:48 UTC
Although this bug is older, I mark it as duplicate of Bug 348364 because that one is a bit more specific. Thank you for your feedback.

*** This bug has been marked as a duplicate of bug 348364 ***