Bug 335746 - Floating messages mess up the navigation keys.
Summary: Floating messages mess up the navigation keys.
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: git master (please specify the git hash!)
Platform: Ubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-03 12:23 UTC by wolthera
Modified: 2014-06-03 18:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wolthera 2014-06-03 12:23:49 UTC
When using the navigation keys that call up a floating message(Zoom, rotation, reset canvas, mirror etc.) the canvas-input seems to freeze.

So, for example, when using 'Plus' to zoom in, pressing it once will summon the floating message, but after wards pressing it again will not do anything. It is not until the user presses on another button or the canvas that the 'plus' key will work again.

Reproducible: Always




Seems to be gnome specific?

Disabling floating messages through creative commenting in the source removes all problems... except you lose the floating messages.

May actually be an older problem, but just not as obvious because the only thing using floating messages was 'tab-to-fullscreen', and you're unlikely to rapidly tap 'tab'.
Comment 1 Halla Rempt 2014-06-03 14:40:12 UTC
Could you try this:

diff --git a/krita/ui/widgets/kis_floating_message.cpp b/krita/ui/widgets/kis_floating_message.cpp
index 3a1046b..0bbabbd 100644
--- a/krita/ui/widgets/kis_floating_message.cpp
+++ b/krita/ui/widgets/kis_floating_message.cpp
@@ -131,7 +131,7 @@ KisFloatingMessage::KisFloatingMessage(const QString &message, QWidget *parent,
 {
     m_icon = koIcon("calligrakrita").pixmap(256, 256).toImage();
 
-    setWindowFlags(Qt::FramelessWindowHint | Qt::Tool);
+    setWindowFlags(Qt::FramelessWindowHint | Qt::ToolTip);
     setFocusPolicy(Qt::NoFocus);
     setAttribute(Qt::WA_ShowWithoutActivating);
 
lines 1-13/13 (END)

And see what happens?
Comment 2 Halla Rempt 2014-06-03 18:47:49 UTC
Git commit 9eb9cb9960aa530fcc975778856ce02fcce57b67 by Boudewijn Rempt.
Committed on 03/06/2014 at 18:47.
Pushed by rempt into branch 'master'.

Using Tooltip instead of Tool seems to fix that.

M  +1    -1    krita/ui/widgets/kis_floating_message.cpp

http://commits.kde.org/calligra/9eb9cb9960aa530fcc975778856ce02fcce57b67
Comment 3 Halla Rempt 2014-06-03 18:48:04 UTC
Git commit 70de6717c8103226549bf42bcb5c9dbe04882da3 by Boudewijn Rempt.
Committed on 03/06/2014 at 18:47.
Pushed by rempt into branch 'calligra/2.8'.

Using Tooltip instead of Tool seems to fix that.

M  +1    -1    krita/ui/widgets/kis_floating_message.cpp

http://commits.kde.org/calligra/70de6717c8103226549bf42bcb5c9dbe04882da3