Bug 335374 - Visual Polish: Vertically center text beside icon in task entry
Summary: Visual Polish: Vertically center text beside icon in task entry
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: master
Platform: unspecified Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-26 15:04 UTC by Andrew Lake
Modified: 2014-06-18 23:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Lake 2014-05-26 15:04:38 UTC
For each task entry the text appears to be bottom aligned instead of vertically centered relative to the icon. It could be improved if it followed the Icons and Text vertical alignment guidelines: http://techbase.kde.org/Projects/Usability/HIG/IconsAndText

Reproducible: Always
Comment 1 Eike Hein 2014-05-26 15:34:25 UTC
Yeah, all of this got mightily screwed up when someone decided to replace the original, correctly frame magin-aware positioning code for the labels - unfortunately the reasons for that were never really communicated to me. I have restoring/overhauling it on the TODO before the release.
Comment 2 Eike Hein 2014-06-18 22:00:27 UTC
Git commit a4093645466eac3243a1a3664df0c923e8df67e8 by Eike Hein.
Committed on 18/06/2014 at 21:56.
Pushed by hein into branch 'master'.

Restore the original icon and label positioning approach.

Now again actually looks at the theme element's frame margins
to shift things around and size things.

Unbreaks:
- When exactly multi-line wrapping occurs.
- Relative alignment between text and icons.

Please move changes to this through RB next time :)

Breeze has to be tweaked a little for nice results, commit
following.

M  +8    -7    applets/taskmanager/package/contents/ui/Task.qml

http://commits.kde.org/plasma-desktop/a4093645466eac3243a1a3664df0c923e8df67e8
Comment 3 Andrew Lake 2014-06-18 22:44:23 UTC
Awesome Eike. Could you say what tweaking Breeze might need for nice results?
Comment 4 Eike Hein 2014-06-18 23:19:50 UTC
The margin hints on the task frame needed to be made a bit smaller, I've already commited that :). The net change is to improve the centering a bit and reduce the margins so the icon stays sharp at common panel sizes, in conjunction with the behavior change in the applet, which is basically "actually respect the margins properly".
Comment 5 Andrew Lake 2014-06-18 23:56:43 UTC
Ok thanks for the explanation. I just wanted to make sure there wasn't anything you needed from our side. :-)