Bug 335196 - Effects KCM list view doesn't react to wheel events with the same scroll delta as standard KCM list views
Summary: Effects KCM list view doesn't react to wheel events with the same scroll delt...
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: git master
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: 5
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-22 14:41 UTC by Eike Hein
Modified: 2021-12-07 04:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eike Hein 2014-05-22 14:41:10 UTC
Title says it all.

Reproducible: Always
Comment 1 Martin Flöser 2014-05-22 14:48:09 UTC
(In reply to comment #0)
> Title says it all.

what is exactly the difference? Do you know whether that's something lacking in QtQuick?
Comment 2 Eike Hein 2014-05-22 14:57:41 UTC
> what is exactly the difference? Do you know whether that's something lacking in QtQuick?

The scroll distance. My mouse settings are "Scroll wheel scrolls by: 3 lines" in System Settings (the default), and in QWidget list views (even ones with complex arbitrary-height delegates instead of ones that map neatly to lines) this translates to a bigger delta than in the effects KCM list.

Cliff notes:

- Needs investigation what QWidget views actually do. I have a vague memory the style is involved to some degree too, but I'm not certain. And then investigation of the options for teaching QQC how to do it too.

- The user doesn't care what state upstream QQC is in, though, and shipping unfinished/broken basic settings UIs is not acceptable imho, so a workaround would need to be implemented if the Qt available at release time can't be fixed. Taking over wheel handling ourselves and multiplying http://doc-snapshot.qt-project.org/qt5-stable/qapplication.html#wheelScrollLines-prop by $ui_font_mHeight could be that, if it turns out that's basically what QWidget does.
Comment 3 Andrew Crouthamel 2018-11-11 04:29:10 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Andrew Crouthamel 2018-11-21 04:25:00 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!
Comment 5 kde.org 2021-11-07 10:24:26 UTC
This issue report is quite old. Can you please confirm, that it still persists with Plasma 5.23?
Comment 6 Bug Janitor Service 2021-11-22 04:38:47 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Bug Janitor Service 2021-12-07 04:36:27 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!