Bug 335021 - Cannot turn Baloo off from System Settings
Summary: Cannot turn Baloo off from System Settings
Status: RESOLVED DUPLICATE of bug 331932
Alias: None
Product: Baloo
Classification: Unclassified
Component: General (show other bugs)
Version: 4.13
Platform: Kubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Vishesh Handa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-19 02:10 UTC by Roger
Modified: 2014-05-21 14:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roger 2014-05-19 02:10:06 UTC
Baloo sucks 100% of CPU. Baloo generates gigabytes of unnecessary files on a small hard drive. System Settings should include the option to turn this waste of space OFF.

Reproducible: Always

Steps to Reproduce:
1. Enable Baloo.
2. Restart KDE.
3. Baloo sucks resources like a Black Hole.
4. Look for system setting to turn off Baloo.
5. Can't find system setting, look on web.
6. Find setting in obscure config file.
Actual Results:  
Can't find system setting to turn off Baloo. Turning off indexing in /home did not turn off indexing in /home.

Expected Results:  
A system setting to turn off Baloo should exist WITHOUT altering a text file directly. A simple check box that alters the text file appropriately would be the right way to deal with this.

In addition, it seems that the developers are really in love with file indexing. I don't like file indexing, for all the reasons given above. I have yet to see a file indexing scheme that doesn't use excessive CPU cycles. At least one other bug report demonstrates 800% of resources being used by Baloo.

I turned Baloo off. Completely off. I had to alter a text file to do it. I shouldn't have to do that to turn it off.

In addition, the information at http://community.kde.org/Baloo/Debugging is incorrect. One of the major sucks of resources is mentioned there, but baloo_file_indexer isn't even mentioned, and it's major sucker of resource.
Comment 1 Martin Walch 2014-05-19 03:25:33 UTC
Take a look at 4.13.1 (has been released last week) and bug #331932.
Comment 2 Vishesh Handa 2014-05-21 14:53:03 UTC
There is no process called baloo_file_indexer. Also please avoid using phrases such as "sucks resources like a black hole". It does not help, and demotivates the developers to look at bug reports.

It would be nice if you followed the guide and filled bug reports as to which process is problematic.

*** This bug has been marked as a duplicate of bug 331932 ***