Bug 334953 - When clicking on a category another category is entered
Summary: When clicking on a category another category is entered
Status: RESOLVED DUPLICATE of bug 332808
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: master
Platform: Compiled Sources Linux
: NOR normal
Target Milestone: 1.0
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-17 17:37 UTC by Lasse Liehu
Modified: 2014-05-19 15:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lasse Liehu 2014-05-17 17:37:56 UTC
There might be a pattern that the entered category is one that mouse pointer hovered a little while ago. If clicking repeatedly on Development and being careful not to hover over any other categories, Development is always entered. Tested about a dozen times.

I also cannot reproduce this if I select categories using keyboard and keep the mouse pointer always on top of the button to go back to All applications.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Kickoff
2. Switch to Applications tab
3. Click on Utilities
4. Click on All applications to go back to category selection
5. Click on Utilities again and repeat 3-5 if necessary
Actual Results:  
Sooner or later some other category like Development or System is entered even though Utilities was clicked.

Expected Results:  
Clicking on Utilities enters the same category.
Comment 1 Bhushan Shah 2014-05-18 05:00:34 UTC

*** This bug has been marked as a duplicate of bug 332808 ***
Comment 2 Bhushan Shah 2014-05-18 05:01:06 UTC
Fixed with ad0c73b3 in plasma-desktop
Comment 3 Martin Klapetek 2014-05-19 15:32:16 UTC
Note that this is was not fixed with that commit, I can still reproduce this.