Bug 334674 - KDE Plasma died on logon
Summary: KDE Plasma died on logon
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kshareddatacache (show other bugs)
Version: 4.12.5
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords: drkonqi, triaged
: 334636 348769 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-12 19:06 UTC by Pawel Kraszewski
Modified: 2018-10-27 02:23 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pawel Kraszewski 2014-05-12 19:06:12 UTC
Application: plasma-desktop (4.11.9)
KDE Platform Version: 4.12.5
Qt Version: 4.8.6
Operating System: Linux 3.14.3-200.fc20.x86_64 x86_64
Distribution: "Fedora release 20 (Heisenbug)"

-- Information about the crash:
- What I was doing when the application crashed:

Logged on, desktop appeared, went to black, crashed and restarted. Happened once or twice before.

- OS:
Plain Fedora 20 with closed binary NVidia drivers via RPM Fusion.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Powłoka pulpitu Plazmy (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f2f979dc900 (LWP 3203))]

Thread 3 (Thread 0x7f2f7ef5d700 (LWP 3208)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x000000374078ef2b in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x3740a8df00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x000000374078ef69 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00000039cf807f33 in start_thread (arg=0x7f2f7ef5d700) at pthread_create.c:309
#4  0x00000039cf0f4ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f2efceb6700 (LWP 3209)):
#0  0x00000039cf0ea9dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00000039d1c495b4 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f2ef8002bb0, timeout=-1, context=0x7f2ef80009a0) at gmain.c:4007
#2  g_main_context_iterate (context=context@entry=0x7f2ef80009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3708
#3  0x00000039d1c496dc in g_main_context_iteration (context=0x7f2ef80009a0, may_block=1) at gmain.c:3774
#4  0x00000037383b5af6 in QEventDispatcherGlib::processEvents (this=0x7f2ef80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5  0x000000373838595f in QEventLoop::processEvents (this=this@entry=0x7f2efceb5c80, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003738385cad in QEventLoop::exec (this=this@entry=0x7f2efceb5c80, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003738279e8f in QThread::exec (this=this@entry=0x2286130) at thread/qthread.cpp:538
#8  0x00000037383662e3 in QInotifyFileSystemWatcherEngine::run (this=0x2286130) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x000000373827c6bf in QThreadPrivate::start (arg=0x2286130) at thread/qthread_unix.cpp:349
#10 0x00000039cf807f33 in start_thread (arg=0x7f2efceb6700) at pthread_create.c:309
#11 0x00000039cf0f4ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f2f979dc900 (LWP 3203)):
[KCrash Handler]
#6  0x00000039cf811298 in _xend () at ../nptl/sysdeps/unix/sysv/linux/x86/elision-unlock.c:33
#7  __lll_unlock_elision (lock=0x7f2f884b1008, private=128) at ../nptl/sysdeps/unix/sysv/linux/x86/elision-unlock.c:29
#8  0x0000003828a37d66 in unlock (this=0x3b47170) at /usr/src/debug/kdelibs-4.12.5/kdecore/util/kshareddatacache.cpp:1245
#9  ~CacheLocker (this=<synthetic pointer>, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.12.5/kdecore/util/kshareddatacache.cpp:1317
#10 KSharedDataCache::insert (this=this@entry=0x32c3df0, key=..., data=...) at /usr/src/debug/kdelibs-4.12.5/kdecore/util/kshareddatacache.cpp:1595
#11 0x00000038290aece1 in KImageCache::insertImage (this=this@entry=0x32c3df0, key=..., image=...) at /usr/src/debug/kdelibs-4.12.5/kdeui/util/kimagecache.cpp:103
#12 0x00000038290aeea9 in KImageCache::insertPixmap (this=0x32c3df0, key=..., pixmap=...) at /usr/src/debug/kdelibs-4.12.5/kdeui/util/kimagecache.cpp:119
#13 0x000000382bdd4c7f in Plasma::ThemePrivate::scheduledCacheUpdate (this=0x1b76a30) at /usr/src/debug/kdelibs-4.12.5/plasma/theme.cpp:403
#14 0x000000382bddc709 in Plasma::Theme::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0x7ffffa100c20, _c=<optimized out>) at /usr/src/debug/kdelibs-4.12.5/x86_64-redhat-linux-gnu/plasma/theme.moc:99
#15 0x000000373839b938 in QMetaObject::activate (sender=0x1a34440, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3567
#16 0x000000373839fce1 in QObject::event (this=0x1a34440, e=<optimized out>) at kernel/qobject.cpp:1184
#17 0x00000037389caebc in QApplicationPrivate::notify_helper (this=0x1a1e3a0, receiver=0x1a34440, e=0x7ffffa101090) at kernel/qapplication.cpp:4565
#18 0x00000037389d1825 in QApplication::notify (this=this@entry=0x19d7590, receiver=receiver@entry=0x1a34440, e=e@entry=0x7ffffa101090) at kernel/qapplication.cpp:4351
#19 0x000000382904ab0a in KApplication::notify (this=0x19d7590, receiver=0x1a34440, event=0x7ffffa101090) at /usr/src/debug/kdelibs-4.12.5/kdeui/kernel/kapplication.cpp:311
#20 0x0000003738386ebd in QCoreApplication::notifyInternal (this=0x19d7590, receiver=0x1a34440, event=event@entry=0x7ffffa101090) at kernel/qcoreapplication.cpp:953
#21 0x00000037383b8713 in sendEvent (event=0x7ffffa101090, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#22 QTimerInfoList::activateTimers (this=this@entry=0x1a1e890) at kernel/qeventdispatcher_unix.cpp:621
#23 0x00000037383b5861 in timerSourceDispatch (source=source@entry=0x1a1e830) at kernel/qeventdispatcher_glib.cpp:186
#24 0x00000039d1c492a6 in g_main_dispatch (context=0x1a1e740) at gmain.c:3066
#25 g_main_context_dispatch (context=context@entry=0x1a1e740) at gmain.c:3642
#26 0x00000039d1c49628 in g_main_context_iterate (context=context@entry=0x1a1e740, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3713
#27 0x00000039d1c496dc in g_main_context_iteration (context=0x1a1e740, may_block=1) at gmain.c:3774
#28 0x00000037383b5ad5 in QEventDispatcherGlib::processEvents (this=0x1999650, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#29 0x0000003738a6cda6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#30 0x000000373838595f in QEventLoop::processEvents (this=this@entry=0x7ffffa101320, flags=...) at kernel/qeventloop.cpp:149
#31 0x0000003738385cad in QEventLoop::exec (this=this@entry=0x7ffffa101320, flags=...) at kernel/qeventloop.cpp:204
#32 0x000000373838b399 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#33 0x00000037389c952c in QApplication::exec () at kernel/qapplication.cpp:3823
#34 0x000000382ac3d9cc in kdemain (argc=1, argv=0x7ffffa101598) at /usr/src/debug/kde-workspace-4.11.9/plasma/desktop/shell/main.cpp:126
#35 0x00000039cf021d65 in __libc_start_main (main=0x400940 <main(int, char**)>, argc=1, argv=0x7ffffa101598, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffffa101588) at libc-start.c:285
#36 0x0000000000400971 in _start ()

Reported using DrKonqi
Comment 1 Christoph Feck 2014-06-13 17:18:02 UTC
*** Bug 334636 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2015-06-07 10:14:55 UTC
*** Bug 348769 has been marked as a duplicate of this bug. ***
Comment 3 Bhushan Shah 2015-06-23 11:35:27 UTC
Are you using bleachbit?

If yes, please remove it. Read http://blog.martin-graesslin.com/blog/2012/07/do-not-use-bleachbit/ for more information
Comment 4 Andrew Crouthamel 2018-09-25 21:43:57 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Andrew Crouthamel 2018-10-27 02:23:34 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!