Bug 334448 - imap stuck on "Retrieving extra folder information" for some folders.
Summary: imap stuck on "Retrieving extra folder information" for some folders.
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: GIT (master)
Platform: Compiled Sources Other
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-07 03:31 UTC by Luis Silva
Modified: 2017-04-21 06:59 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luis Silva 2014-05-07 03:31:14 UTC
The imap resource gets stuck at some point (near the end, I am guessing) during mail retrieval. This happens only for imap resources fetching mail from Microsoft outlook servers. In kmail or akonadiconsole I have a message saying "Retrieving extra folder information for <folder>" Most of the time this folder is INBOX but sometimes it is other random folder. I have waited to see if it was just a matter of time but after a couple of hours the situation remains. When this happens, I have to restart akonadi (or just the resources) to be able to see my mail again in any folder, independently of the acount.

Reproducible: Always




All the imap acounts have the "Disconnected mode" enabled.
Comment 1 Christian Mollekopf 2014-05-07 12:05:22 UTC
Git commit c876ae9e9ea92f2f61d127899272cda3ab478770 by Christian Mollekopf.
Committed on 07/05/2014 at 12:04.
Pushed by cmollekopf into branch 'master'.

IMAP-Resource: Properly count started and completed jobs.

I.e. if no job was started because of no metadata capabilities the job would get stuck otherwise.

M  +14   -7    resources/imap/retrievecollectionmetadatatask.cpp

http://commits.kde.org/kdepim-runtime/c876ae9e9ea92f2f61d127899272cda3ab478770
Comment 2 Christian Mollekopf 2014-05-20 23:15:28 UTC
Git commit 94424520284417366159ea8e358a9e7eb0ee5d5f by Christian Mollekopf.
Committed on 07/05/2014 at 12:04.
Pushed by cmollekopf into branch 'kolab/integration/4.13.0'.

IMAP-Resource: Properly count started and completed jobs.

I.e. if no job was started because of no metadata capabilities the job would get stuck otherwise.

M  +14   -7    resources/imap/retrievecollectionmetadatatask.cpp

http://commits.kde.org/kdepim-runtime/94424520284417366159ea8e358a9e7eb0ee5d5f
Comment 3 Michael Barraclough 2017-04-21 06:59:00 UTC
I have this exact problem with KMail 5.4.3

As far as I am aware the IMAP server is a Linux host and not Microsoft

Reproducible: always