Bug 334327 - Klipper fails to Clear Clipboard History, when manually selected.
Summary: Klipper fails to Clear Clipboard History, when manually selected.
Status: RESOLVED DUPLICATE of bug 336053
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: 0.9.7
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Esben Mose Hansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-04 13:17 UTC by B
Modified: 2014-06-10 20:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description B 2014-05-04 13:17:25 UTC
Klipper is an awesome tool!  I use it all the time, but I like to clear the clipboard history from time to time, but under Kubuntu 14.04 LTS x64, Klipper fails to Clear Clipboard History, when manually selected.  The work around now - I have to select from config menu, to not save clipboard history on exit, then reboot computer.  Is this a 64bit issue, as I used to run Kubuntu 12.04.4 LTS x86 with PAE (for some reason 14.04 x86 fails to itialize PAE, so I had to switch to x64 to utilize all my RAM 16G).  I love how snappy x64 is, much quicker than x86.  This hopefully will be a easy fix, sounds like the clearing function is looking to the wrong folder to clear.. or doesn't have proper permissions?

B.Seeya

Reproducible: Always

Steps to Reproduce:
1.click on Klipper
2.select clear clipboard history
3.click on Klipper to see if cleared, it fails..
Actual Results:  
1.click on Klipper
2.select clear clipboard history
3.click on Klipper to see if cleared, it fails..

Expected Results:  
Clipboard history is still present.

Cipboard should be empty.

Note:  Prevent Empty Clipboard does nothing.  I've tried toggled and not.  Same result.
Comment 1 Christoph Feck 2014-05-04 14:23:10 UTC
Do you get a message dialog "Really delete entire clipboard history?" if you invoke the "Clear Clipboard History" menu item?
Comment 2 Christoph Feck 2014-05-16 21:15:07 UTC
If you can provide the information requested in comment #1, please add it.
Comment 3 Martin Flöser 2014-05-21 06:45:25 UTC
waiting for more info - works fine for me.
Comment 4 B 2014-05-30 11:05:37 UTC
Hello, sorry for the long delay, this seams to only happens on one of my
machines.   I have Kubuntu 14.04 installed on 4 machines, the other three
are win7 dual boot.  The machine which has this problem has only linux on
it, but it is also a web server, team speak server, and therefore is on a
DMZ part of my network.  To answer your question, Yes, Klipper did ask the
regular prompt, and I put a check in the box, do not ask again, so it does
not show up any more.  Being my only native install on Kubuntu 14.04 LTS -
I figured it had to be a bug in Klipper or the new KDE.

I have noticed something else to add, is if I select to 'save clipboard
contents on exit', then the list keeps on building with everything I
highlight.  So I leave the box unchecked, and log off, log on, then it's
clear..  It's not that big of a deal, as I don't have to do a full reboot,
just very strange..


On Wed, May 21, 2014 at 1:45 AM, Martin Gräßlin <mgraesslin@kde.org> wrote:

> https://bugs.kde.org/show_bug.cgi?id=334327
>
> Martin Gräßlin <mgraesslin@kde.org> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |NEEDSINFO
>                  CC|                            |mgraesslin@kde.org
>          Resolution|---                         |WAITINGFORINFO
>
> --- Comment #3 from Martin Gräßlin <mgraesslin@kde.org> ---
> waiting for more info - works fine for me.
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 5 Martin Flöser 2014-05-30 11:10:02 UTC
might it be that you by accident clicked "No" when you checked the "do not ask again"?
Comment 6 Christoph Feck 2014-06-10 20:48:52 UTC
No response, assuming it is a duplicate. If you see a different issue, please add a comment.

*** This bug has been marked as a duplicate of bug 336053 ***