Bug 334315 - With desktop search module enabled krunner eats all memory when entering calculation
Summary: With desktop search module enabled krunner eats all memory when entering calc...
Status: RESOLVED DUPLICATE of bug 332253
Alias: None
Product: krunner
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-04 08:02 UTC by Paul Worrall
Modified: 2014-05-04 10:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Worrall 2014-05-04 08:02:43 UTC
Entering a simple calculation in krunner with the Desktop Search module enabled eats all available memory.

Reproducible: Always

Steps to Reproduce:
1. Ensure "Desktop Search" and "Calculator" plugins are enabled in krunner
2. Alt-F2
3. enter:  =2*2
Actual Results:  
result of calculation is shown but after a few seconds memory usage starts rapidly increasing until all memory and swap is consumed.

Expected Results:  
Memory use does not significanly change

Memory usage is OK if "Desktop Search" plugin is disabled.

KDE version 4.13.0
Comment 1 Christoph Feck 2014-05-04 10:27:10 UTC

*** This bug has been marked as a duplicate of bug 332253 ***