Bug 334248 - Kate crashes every time whem pressing enter key at the begining of a file
Summary: Kate crashes every time whem pressing enter key at the begining of a file
Status: RESOLVED DUPLICATE of bug 332426
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: 3.13.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-05-02 21:20 UTC by fsanchez
Modified: 2014-06-04 11:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Text file from which I can reproduce the problem every time (11.47 KB, text/plain)
2014-05-02 21:22 UTC, fsanchez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fsanchez 2014-05-02 21:20:49 UTC
Application: kate (3.13.0)
KDE Platform Version: 4.13.0
Qt Version: 4.8.2
Operating System: Linux 3.2.0-61-generic x86_64
Distribution: Ubuntu 12.04.4 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I have a text file which, when I try to press enter to move the first line below, Kate crashes.

It happens every time, and Dr. Konqi only installed some of the necesary debugging symbols. I intalled as much "dbg" packages I realized were necesary.

Dr. Konqi installed
kate-dbg

And so far, I installed:
kdebase-runtime-dbg{a} 
kdesdk-dbg
kde-workspace-dbg
libqt4-script-dbg
libglib2.0-0-dbg
libqt4-xmlpatterns-dbg 
qt4-bin-dbg

which at least improve the "qualification" made by Dr. Konqi, but it seems they aren't enough. Since it happens every time, please tell me which packages I'm missing and I'll install them.

More info:
Kubuntu 12.04.4 x86_64, with KDE 4.13.0 just installed today
AMD Phenom X3 8450
NVidia 9500 G with 331.20 driver

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb9c8d98780 (LWP 16700))]

Thread 4 (Thread 0x7fb9b4a9a700 (LWP 16701)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb9b5ecc022 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7fb9b61c4e80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007fb9b5ecc059 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007fb9c5cb0e9a in start_thread (arg=0x7fb9b4a9a700) at pthread_create.c:308
#4  0x00007fb9c86da3fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb9319e8700 (LWP 16702)):
#0  0x00007fb9c86cea43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb9c57e3ff6 in g_main_context_poll (n_fds=2, fds=0x7fb92c002bb0, timeout=-1, context=0x7fb92c0009a0, priority=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3440
#2  g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x7fb92c0009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3141
#3  g_main_context_iterate (context=0x7fb92c0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3083
#4  0x00007fb9c57e4124 in g_main_context_iteration (context=0x7fb92c0009a0, may_block=1) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3207
#5  0x00007fb9c65a6926 in QEventDispatcherGlib::processEvents (this=0x7fb92c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fb9c6575e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fb9c65760b7 in QEventLoop::exec (this=0x7fb9319e7dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fb9c6475077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fb9c6555b6f in QInotifyFileSystemWatcherEngine::run (this=0x2802da0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fb9c647809b in QThreadPrivate::start (arg=0x2802da0) at thread/qthread_unix.cpp:307
#11 0x00007fb9c5cb0e9a in start_thread (arg=0x7fb9319e8700) at pthread_create.c:308
#12 0x00007fb9c86da3fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb930c7a700 (LWP 16704)):
#0  0x00007fb9c86cea43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb9c57e3ff6 in g_main_context_poll (n_fds=2, fds=0x7fb9240029b0, timeout=-1, context=0x7fb9240009a0, priority=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3440
#2  g_main_context_iterate (dispatch=1, block=<optimized out>, context=0x7fb9240009a0, self=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3141
#3  g_main_context_iterate (context=0x7fb9240009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3083
#4  0x00007fb9c57e4124 in g_main_context_iteration (context=0x7fb9240009a0, may_block=1) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3207
#5  0x00007fb9c65a6926 in QEventDispatcherGlib::processEvents (this=0x7fb9240008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fb9c6575e62 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fb9c65760b7 in QEventLoop::exec (this=0x7fb930c79dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fb9c6475077 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fb9c6555b6f in QInotifyFileSystemWatcherEngine::run (this=0x28fd800) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fb9c647809b in QThreadPrivate::start (arg=0x28fd800) at thread/qthread_unix.cpp:307
#11 0x00007fb9c5cb0e9a in start_thread (arg=0x7fb930c7a700) at pthread_create.c:308
#12 0x00007fb9c86da3fd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb9c8d98780 (LWP 16700)):
[KCrash Handler]
#6  KateDocument::defStyleNum (this=0x20e4d10, line=<optimized out>, column=<optimized out>) at ../../part/document/katedocument.cpp:5487
#7  0x00007fb9b653d629 in KateDocument::isComment (this=<optimized out>, line=<optimized out>, column=<optimized out>) at ../../part/document/katedocument.cpp:5508
#8  0x00007fb9b64c1c65 in KateScriptDocument::qt_static_metacall (_o=0x297e2b0, _id=<optimized out>, _a=0x7fff9cb10ba0, _c=<optimized out>) at moc_katescriptdocument.cpp:404
#9  0x00007fb9b64c2cab in KateScriptDocument::qt_metacall (this=0x297e2b0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff9cb10ba0) at moc_katescriptdocument.cpp:468
#10 0x00007fb9b5f38d71 in QScript::callQtMethod (exec=0x7fb92b7c7330, callType=QMetaMethod::Method, thisQObject=0x297e2b0, scriptArgs=..., meta=0x7fb9b69038a0, initialIndex=93, maybeOverloaded=true) at bridge/qscriptqobject.cpp:960
#11 0x00007fb9b5f3ae0b in QScript::QtFunction::execute (this=0x7fb92b7479c0, exec=0x7fb92b7c7330, thisValue=..., scriptArgs=...) at bridge/qscriptqobject.cpp:1015
#12 0x00007fb9b5f3b01a in QScript::QtFunction::call (exec=0x7fb92b7c7330, callee=0x7fb92b7479c0, thisValue=..., args=...) at bridge/qscriptqobject.cpp:1030
#13 0x00007fb9b5e44770 in QTJSC::NativeFuncWrapper::operator() (this=0x7fff9cb10d70, exec=0x7fb92b7c7330, jsobj=0x7fb92b7479c0, thisValue=..., argList=...) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:46
#14 0x00007fb9b5e1b4e6 in QTJSC::cti_op_call_NotJSFunction (args=0x7fff9cb10dc0) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:1780
#15 0x00007fb934225c1c in ?? ()
#16 0x0000000000000000 in ?? ()

Reported using DrKonqi
Comment 1 fsanchez 2014-05-02 21:22:23 UTC
Created attachment 86413 [details]
Text file from which I can reproduce the problem every time

Text file from which I can reproduce the problem every time. 
I have been able to reproduce with other file, but not all of them.
Comment 2 Jekyll Wu 2014-05-03 01:05:56 UTC

*** This bug has been marked as a duplicate of bug 328271 ***
Comment 3 fsanchez 2014-05-03 01:17:57 UTC
Hi Jekyll. Thanks for look a this so quickly. I just have a question, if you don't mind:

If bug 328271 was fixed in dicember for KDE 4.12, and KDE 4.13 was released in april, should that bug be reopened? Or the patch haven't landed in 4.13?

Thanks in advance.
Comment 4 Christoph Feck 2014-06-04 11:01:25 UTC
Reopening based on comment #3.
Comment 5 Dominik Haumann 2014-06-04 11:06:47 UTC
The root for this crash was found only 3 weeks ago. It should be in KDE 4.13.2, hopefully. See bug #332426 for further details.

*** This bug has been marked as a duplicate of bug 332426 ***