Bug 334093 - Names of newly added tables and queries not properly sorted in forms data source combo
Summary: Names of newly added tables and queries not properly sorted in forms data sou...
Status: CLOSED FIXED
Alias: None
Product: KEXI
Classification: Unclassified
Component: Forms (show other bugs)
Version: 2.9 Alpha
Platform: Mint (Ubuntu based) Linux
: NOR normal (vote)
Target Milestone: 2.8.4
Assignee: Wojciech Kosowicz
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2014-04-29 17:37 UTC by robert leleu
Modified: 2014-06-03 21:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8.4


Attachments
A name of a newly added query does not appear on proper position on the list. (50.53 KB, image/jpeg)
2014-05-10 09:15 UTC, Jarosław Staniek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description robert leleu 2014-04-29 17:37:20 UTC
Although these queries display datas, they are not in the combo box used to choose the internal source of a form.
I just created a query ... which doesn't appear

Reproducible: Sometimes
Comment 1 Jarosław Staniek 2014-04-30 22:29:27 UTC
Hi Robert, could you confirm this is the following scenario?

1. Start creating a new form, do not close the design
2. Create a new query Q
3. Go back to the form design

Result: form Q is listed but not properly ordered within the list.

Expected result: form Q is listed and ordered within the list.
Comment 2 Jarosław Staniek 2014-05-10 09:15:14 UTC
Created attachment 86555 [details]
A name of a newly added query does not appear on proper position on the list.
Comment 3 Jarosław Staniek 2014-05-10 09:17:30 UTC
Just checked, the same applies a newly added table.
Comment 4 Jarosław Staniek 2014-05-10 09:21:14 UTC
No feedback from the reporter so for now I am changing the summary so first visible, directly related and obvious defects can get fixed. 

@Robert If you meant any unrelated bug we can create another report.
Comment 5 Wojciech Kosowicz 2014-06-03 21:29:28 UTC
Git commit f3949bc88b3a3266980c7e405617dac6a3360c06 by Wojciech Kosowicz.
Committed on 03/06/2014 at 21:24.
Pushed by wkosowicz into branch 'calligra/2.8'.

Change of addItem to insertItem in KexiDataSourceComboBox slot

In slotNewItemStored of KexiDataSourceComboBox there was called addItem
method that adds to the end of combobox. Method insertItem should be
called instead so that items are in correct order
FIXED-IN: 2.8.4
REVIEW: 118485

M  +2    -2    kexi/widget/KexiDataSourceComboBox.cpp

http://commits.kde.org/calligra/f3949bc88b3a3266980c7e405617dac6a3360c06
Comment 6 Wojciech Kosowicz 2014-06-03 21:33:54 UTC
Git commit 5a4e7a9e04273635cd50899f4104c51e37b0a045 by Wojciech Kosowicz.
Committed on 03/06/2014 at 21:24.
Pushed by wkosowicz into branch 'master'.

Change of addItem to insertItem in KexiDataSourceComboBox slot

In slotNewItemStored of KexiDataSourceComboBox there was called addItem
method that adds to the end of combobox. Method insertItem should be
called instead so that items are in correct order
FIXED-IN: 2.8.4
REVIEW: 118485

M  +2    -2    kexi/widget/KexiDataSourceComboBox.cpp

http://commits.kde.org/calligra/5a4e7a9e04273635cd50899f4104c51e37b0a045
Comment 7 Jarosław Staniek 2014-06-03 21:59:58 UTC
Wojciech,
Nice, just one minor remark. The commit message should better mention the
summary of the bug in the 1st line, i.e.
 "Properly sort newly added tables and queries in forms data source combo"
And primarily, it should explain *why* it exists, *not* what is being done.

Always think about commit message as about input to the official changelog.


Thiago has explained it nicely:
https://plus.google.com/u/0/+ThiagoMacieira/posts/CF5VKSnXXTT



On 3 June 2014 23:33, Wojciech Kosowicz <pcellix@gmail.com> wrote:

>  Wojciech Kosowicz <pcellix@gmail.com> changed bug 334093
> <https://bugs.kde.org/show_bug.cgi?id=334093>
>  What Removed Added  Latest Commit
> http://commits.kde.org/calligra/f3949bc88b3a3266980c7e405617dac6a3360c06
> http://commits.kde.org/calligra/5a4e7a9e04273635cd50899f4104c51e37b0a045
>
>  *Comment # 6 <https://bugs.kde.org/show_bug.cgi?id=334093#c6> on bug
> 334093 <https://bugs.kde.org/show_bug.cgi?id=334093> from Wojciech Kosowicz
> <pcellix@gmail.com> *
>
> Git commit 5a4e7a9e04273635cd50899f4104c51e37b0a045 by Wojciech Kosowicz.
> Committed on 03/06/2014 at 21:24.
> Pushed by wkosowicz into branch 'master'.
>
> Change of addItem to insertItem in KexiDataSourceComboBox slot
>
> In slotNewItemStored of KexiDataSourceComboBox there was called addItem
> method that adds to the end of combobox. Method insertItem should be
> called instead so that items are in correct order
> FIXED-IN: 2.8.4
> REVIEW: 118485
>
> M  +2    -2    kexi/widget/KexiDataSourceComboBox.cpp
> http://commits.kde.org/calligra/5a4e7a9e04273635cd50899f4104c51e37b0a045
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>    - You are watching someone on the CC list of the bug.
>    - You are watching the assignee of the bug.
>
>