Bug 334041 - krunner hung stealing ram and cpu, freeze xorg
Summary: krunner hung stealing ram and cpu, freeze xorg
Status: RESOLVED DUPLICATE of bug 332253
Alias: None
Product: krunner
Classification: Unclassified
Component: calculator (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-28 21:28 UTC by mombelli.mauro
Modified: 2014-04-29 08:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
dmesg auto-kill capture (25.10 KB, application/octet-stream)
2014-04-28 22:23 UTC, mombelli.mauro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mombelli.mauro 2014-04-28 21:28:54 UTC
alt+f2, do some basic math (division, multiplication, "enter" to work with result) and if i leave the bar opened for more than10-15sec it hungs the system, or i kill it by virtual console or the system will kill it for me.

High reproducibility, it will also hung X. tell me what to do/debug and i'll do it.

ps. it hung ram 78% of 8GB and multiple core of cpu, it was over 200% CPU in "top" (and my system is a tricore.. the rest was xorg)

Reproducible: Always

Steps to Reproduce:
1. do some math
2. leave the gui open
3. crash!
Actual Results:  
x hungs for some sendons, the systemd (i think) kicks in and kill krunner

Expected Results:  
just sit there showinge the result.
Comment 1 Hrvoje Senjan 2014-04-28 21:34:48 UTC
compare with bug 332253
i.e. try to disable desktop search plugin
Comment 2 mombelli.mauro 2014-04-28 22:00:11 UTC
will try but 
delve . -a -1 | grep '^2' | wc -l return 0
and
baloosearch '=2*2'
is fine for me
Comment 3 mombelli.mauro 2014-04-28 22:23:50 UTC
Created attachment 86323 [details]
dmesg auto-kill capture

restarted krunner, writed "=2*2", chars, system killed it, hare the dmesg output.

NB: launching krunned give:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QString)
Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QString)
krunner(3240) KDevelopSessions::KDevelopSessions: INIT KDEV 
I/O warning : failed to load external entity "/home/mauro/.qalculate/eurofxref-daily.xml"
I/O warning : failed to load external entity "/home/mauro/.qalculate/eurofxref-daily.xml"
Comment 4 Christoph Feck 2014-04-28 22:51:25 UTC
If this is reproducible, please disable krunner plugins to find out which one is the culprit. For example, if you think the calculator plugin causes the issue, try enabling only that plugin, or try disabling it.

To disable plugins, click on the Configure wrench in the Alt+F2 dialog.
Comment 5 mombelli.mauro 2014-04-28 23:01:49 UTC
Thanks, from "the wrench" i found out search plugin was still enabled (i had "disabled" it removing the .desktop in /usr/share/kde4/services/plasma-runner-services.desktop). 
disabling it from there has fixed the hung!

so this is now 332253 duplicate
Comment 6 Christoph Feck 2014-04-29 08:39:30 UTC
Thanks for the update.

*** This bug has been marked as a duplicate of bug 332253 ***