Bug 333947 - High memory consumption with desktop search plugin in krunner
Summary: High memory consumption with desktop search plugin in krunner
Status: RESOLVED DUPLICATE of bug 332253
Alias: None
Product: Baloo
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: Vishesh Handa
URL: http://i.imgur.com/nj8LsIw.png
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-27 08:02 UTC by valdikss
Modified: 2014-05-04 20:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description valdikss 2014-04-27 08:02:30 UTC
There is a memory leak in desktop search krunner plugin.

Reproducible: Always

Steps to Reproduce:
1. Activate krunner with alt+f2, make sure desktop search plugin is enabled
2. Type "1+2+3" in krunner window
Actual Results:  
Krunner uses 800MB+ RAM

Expected Results:  
Krunner uses 20-40MB RAM, just as without desktop search plugin enabled

This bug in Gentoo bugtracker: https://bugs.gentoo.org/show_bug.cgi?id=508556
Comment 1 kroz 2014-04-27 09:50:15 UTC
I have the same problem. I my case after typing "1+2+3" in memory consumption increases from ~0.5G to ~1.4G.
Comment 2 Ivan Shapovalov 2014-04-27 09:52:51 UTC
I've finally managed to confirm this.

In my case, each additional term entered into the textbox ("1+2+3", "1+2+3+4", ...) increases memory consumption of the krunner process, and with 10 terms it is around 1G.
Comment 3 Christoph Feck 2014-05-04 20:57:59 UTC

*** This bug has been marked as a duplicate of bug 332253 ***