Bug 333844 - (wish) configurable default for printing
Summary: (wish) configurable default for printing
Status: RESOLVED UPSTREAM
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 0.17.5
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-24 21:30 UTC by wrinnert
Modified: 2018-06-06 19:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wrinnert 2014-04-24 21:30:11 UTC
When printing on a duplex capable printer, it would be very nice to either have okular use the printer default (which is 'duplex' for me) or, better, have an option in okularrc, which I could not find - I have not checked the source, though.
Every time I forget, my paper consumption is doubled  :-(

Reproducible: Always
Comment 1 wrinnert 2018-01-17 17:54:57 UTC
This bug was reported by me 4 years ago.
The current version 0.26.1 still has the same issue.
There is no documented configuration file, nor configuration dialog that allows to preset the printing parameters (A4 / portrait / duplex / ...).
Regards,
Wolfgang
Comment 2 Michael Weghorn 2018-01-17 18:17:31 UTC
(In reply to wrinnert from comment #1)
> This bug was reported by me 4 years ago.
> The current version 0.26.1 still has the same issue.
> There is no documented configuration file, nor configuration dialog that
> allows to preset the printing parameters (A4 / portrait / duplex / ...).
> Regards,
> Wolfgang

The actual problem is not in Okular but in the underlying Qt library.
There is currently quite some work with regard to the print dialog going on in Qt and this problem will most probably be fixed very soon. The user default value for the printer should be preselected then (which in my opinion is the most reasonable way to deal with this, since it works across applications and allows a per printer default).

PS: The most recent Okular version is actually 1.3.1. If you have an older version, that is probably because the distribution you are using is shipping an older version.
Comment 3 Michael Weghorn 2018-05-02 20:06:17 UTC
(In reply to Michael Weghorn from comment #2)
> 
> The actual problem is not in Okular but in the underlying Qt library.
> There is currently quite some work with regard to the print dialog going on
> in Qt and this problem will most probably be fixed very soon. The user
> default value for the printer should be preselected then (which in my
> opinion is the most reasonable way to deal with this, since it works across
> applications and allows a per printer default).

This is now implemented in Qt's development version (which will become Qt 5.12), s. https://codereview.qt-project.org/#/c/226881/