Bug 333565 - Tagging in Album View deletes picture (Rygel NAS server relevant)
Summary: Tagging in Album View deletes picture (Rygel NAS server relevant)
Status: RESOLVED UPSTREAM
Alias: None
Product: digikam
Classification: Unclassified
Component: Tags-Engine (show other bugs)
Version: 3.5.0
Platform: Fedora RPMs Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-18 05:29 UTC by Arne
Modified: 2017-07-10 11:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arne 2014-04-18 05:29:19 UTC
Running Fedora 20 with KDE 4.12.3 ,DigiKam 3.5.0 on a Lenovo T400 tagging a picture in Album View deletes that picture. Nowhere to be found on any attached FS, no renamed version, nothing. Tried tagging via sidebar and context menu: picture gone.
Tagging in ImageEditor works on the other hand.


Reproducible: Always

Steps to Reproduce:
1. Switch to AlbumView
2. Right click on image
3. in context menu select "assign tag"
4. select tag

Actual Results:  
picture is gone, a systemwide search fails in every imaginable way

Expected Results:  
Tag is added, picture is displayed in AlbumView with the new tag displayed beneath
Comment 1 Arne 2014-04-18 05:32:21 UTC
Switching to the english GUI I see that the two views I can reproduce the bug on are called "thumbnails" and "preview"
Comment 2 Arne 2014-06-12 07:14:26 UTC
There seems to be a connection to a running instance of Rygel on my system. When Rygel is stopped, tagging works as usual.
Comment 3 caulier.gilles 2014-06-12 07:19:40 UTC
Rygel ??? 

what is that ?

Gilles Caulier
Comment 4 caulier.gilles 2014-06-12 07:22:10 UTC
This is it :

http://www.collabora.com/projects/rygel/

???

There is no relation with digiKam...

Gilles Caulier
Comment 5 caulier.gilles 2014-06-12 08:20:19 UTC
2014-06-12 9:51 GMT+02:00 Arne Klindt <arneklindt@gmail.com>:
> I found that "Rygel" outputs this, when I tag a file in DigiKam:
> (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> file:///home/arne/Bilder/digikam4.db-journal konnte nicht erhalten werden
>
> (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> file:///home/arne/Bilder/thumbnails-digikam.db-journal konnte nicht erhalten
> werden
>
> (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> file:///home/arne/Bilder/digikam4.db-journal konnte nicht erhalten werden
>
> (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> file:///home/arne/Bilder/2014-06/2014-06-08/jpg/IMG_6468.JPG2135 konnte
> nicht erhalten werden
>
> (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> file:///home/arne/Bilder/digikam4.db-journal konnte nicht erhalten werden
>
> (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> file:///home/arne/Bilder/digikam4.db-journal konnte nicht erhalten werden
>
> sorry for the german installation. Should mean: Fileinformation for xxx
> could not be retrieved. So it definitely does something in file-operations
> like tagging.
> Why this should be a problem I obviously don't know and understand. Fact is:
> Whenever I stop Rygel I can tag files as I used to (with or without
> sidecars), with Rygel running the file is lost during tagging if I don't use
> sidecar-files.

I have no idea.

Rygel use Mysql database. Do you use Mysql database with digiKam ?

Gilles Caulier
Comment 6 Arne 2014-06-12 09:45:11 UTC
Using SQLite...


2014-06-12 10:20 GMT+02:00 Gilles Caulier <caulier.gilles@gmail.com>:

> https://bugs.kde.org/show_bug.cgi?id=333565
>
> --- Comment #5 from Gilles Caulier <caulier.gilles@gmail.com> ---
> 2014-06-12 9:51 GMT+02:00 Arne Klindt <arneklindt@gmail.com>:
> > I found that "Rygel" outputs this, when I tag a file in DigiKam:
> > (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> > file:///home/arne/Bilder/digikam4.db-journal konnte nicht erhalten werden
> >
> > (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> > file:///home/arne/Bilder/thumbnails-digikam.db-journal konnte nicht
> erhalten
> > werden
> >
> > (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> > file:///home/arne/Bilder/digikam4.db-journal konnte nicht erhalten werden
> >
> > (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> > file:///home/arne/Bilder/2014-06/2014-06-08/jpg/IMG_6468.JPG2135 konnte
> > nicht erhalten werden
> >
> > (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> > file:///home/arne/Bilder/digikam4.db-journal konnte nicht erhalten werden
> >
> > (rygel:5850): MediaExport-WARNING **: Dateiinformation für
> > file:///home/arne/Bilder/digikam4.db-journal konnte nicht erhalten werden
> >
> > sorry for the german installation. Should mean: Fileinformation for xxx
> > could not be retrieved. So it definitely does something in
> file-operations
> > like tagging.
> > Why this should be a problem I obviously don't know and understand. Fact
> is:
> > Whenever I stop Rygel I can tag files as I used to (with or without
> > sidecars), with Rygel running the file is lost during tagging if I don't
> use
> > sidecar-files.
>
> I have no idea.
>
> Rygel use Mysql database. Do you use Mysql database with digiKam ?
>
> Gilles Caulier
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 7 caulier.gilles 2014-06-12 09:56:14 UTC
Well, no idea why Rygel open digiKam database files which lock of course digiKam features relevant of database (file are read only).

So it's an important dysfunction provided by this application. This is not a digiKam problem. Please report this to Ubuntu bugzilla as UPSTREAM bug...

Gilles Caulier
Comment 8 Arne 2014-06-12 10:41:48 UTC
Sorry I'm rather new to this bug reporting stuff (thanks to Fedora, KDE and
DigiKam) so should I really use Ubuntu Bugzilla when my system is a fedora
20? Because they are the maintainers of Rygel?


2014-06-12 11:56 GMT+02:00 Gilles Caulier <caulier.gilles@gmail.com>:

> https://bugs.kde.org/show_bug.cgi?id=333565
>
> Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>          Resolution|---                         |UPSTREAM
>
> --- Comment #7 from Gilles Caulier <caulier.gilles@gmail.com> ---
> Well, no idea why Rygel open digiKam database files which lock of course
> digiKam features relevant of database (file are read only).
>
> So it's an important dysfunction provided by this application. This is not
> a
> digiKam problem. Please report this to Ubuntu bugzilla as UPSTREAM bug...
>
> Gilles Caulier
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 9 caulier.gilles 2014-06-12 10:46:58 UTC
No, sorry, my mistake...

Use Fedora bugzilla of course (:=)))

Gilles Caulier
Comment 10 Denis 2014-06-18 12:28:13 UTC
Hi,

I get the same porblem under openbox LXDE on Fedora 20.
digiKam
versió 3.5.0
S'utilitza la «KDE Development Platform» 4.12.5

I notice that it depends of where in the file tree are the pictures you are working on. But I have no idea of what.

Arne, I did not find your bug report in Fedora ...
Comment 11 Arne 2014-06-18 13:25:12 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1108637
It should be there...


2014-06-18 14:28 GMT+02:00 Denis <denisq@free.fr>:

> https://bugs.kde.org/show_bug.cgi?id=333565
>
> Denis <denisq@free.fr> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |denisq@free.fr
>
> --- Comment #10 from Denis <denisq@free.fr> ---
> Hi,
>
> I get the same porblem under openbox LXDE on Fedora 20.
> digiKam
> versió 3.5.0
> S'utilitza la «KDE Development Platform» 4.12.5
>
> I notice that it depends of where in the file tree are the pictures you are
> working on. But I have no idea of what.
>
> Arne, I did not find your bug report in Fedora ...
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 12 Denis 2014-06-19 04:21:13 UTC
Hi,

I have some doubts about rygel guilty. I had desable rygel on my system by 
systemctl desable rygel 
However, does not change that problem.

I should had to my last comment yesterday that it is not upon the directory that its hapen. It is more a random event wherever in the directory tree is the picture.

Since I had changed the option to "settings/metadata/writing only in anexed files" , everything seeems to be normal (I continue to test it) - before the option was : writing in RAW, noticed as experimental.
Arne could you try it confirm ?
Comment 13 caulier.gilles 2014-06-19 07:12:14 UTC
And if Rygel has open digiKam database in writing mode and corrupted table ???

Do you see what i mean ?

Gilles Caulier
Comment 14 Denis 2014-06-19 08:34:19 UTC
Yes, I see what you mean. I had done a copy of the database the first time it happened and asked digikam to rebuild it. The problem happened again. The clue is that I do  not have an other computer/system to test this database with another digikam under kde for example.

Now, the question that digikam developers can answer is the following : does a corrupted data in the database can lead digikam to eradicate the relevant file ?

If it does, this is definitely a bug to my opinion.
Comment 15 Marcel Wiesweg 2014-06-19 15:19:50 UTC
Digikam does not attempt to delete a file unless you tell it to do so via the Delete dialog.