Bug 333424 - The order of options in Muon Updater changes
Summary: The order of options in Muon Updater changes
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-14 20:21 UTC by Mark Fraser
Modified: 2016-03-02 13:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Muon menu 1 (15.73 KB, image/png)
2014-04-14 20:22 UTC, Mark Fraser
Details
Muon menu 2 (15.76 KB, image/png)
2014-04-14 20:22 UTC, Mark Fraser
Details
possible fix (2.46 KB, patch)
2014-04-14 23:47 UTC, Aleix Pol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Fraser 2014-04-14 20:21:32 UTC
There seems to be 2 different ways the menu in Muon updater is shown.
1:
Configure Muon
Configure Shortcuts
Advanced
About Muon Update Manager
About KDE
Report Bug
Check for Updates

2:
Check for Updates
Configure Muon
Configure Shortcuts
Advanced
About Muon Update Manager
About KDE
Report Bug

So that when trying to check for updates, it could be at the top or the bottom.

Reproducible: Always

Steps to Reproduce:
Can't figure out how to reproduce.


Expected Results:  
Check for Updates should either be at the top or bottom, but not switch between both.
Comment 1 Mark Fraser 2014-04-14 20:22:09 UTC
Created attachment 86094 [details]
Muon menu 1
Comment 2 Mark Fraser 2014-04-14 20:22:32 UTC
Created attachment 86095 [details]
Muon menu 2
Comment 3 Billy O'Connor 2014-04-14 22:21:57 UTC
I've observed that the "Check for Updates" menu item sinks to the bottom immediately after a check for updates is completed, presumably because it is the least likely thing that a user will now want to do.
Comment 4 Aleix Pol 2014-04-14 23:47:26 UTC
Created attachment 86102 [details]
possible fix

Can you try this patch and see if it solves your issue?
I didn't manage to reproduce it.
Comment 5 Billy O'Connor 2014-04-15 02:56:54 UTC
I applied the patch to trunk, that seems to have done it, Aleix.
Not bad for not being able to reproduce it!  :)
Comment 6 Aleix Pol 2014-04-15 11:42:35 UTC
Git commit 4ef35b074e2307dda2e99204229605efaf358469 by Aleix Pol.
Committed on 15/04/2014 at 11:42.
Pushed by apol into branch '2.2'.

Regenerate the menu every time the backend actions are added

This way we make sure it looks like we want it to.

M  +19   -10   updater/MainWindow.cpp

http://commits.kde.org/muon/4ef35b074e2307dda2e99204229605efaf358469