Bug 333016 - No usable Open Street Map behind a proxy
Summary: No usable Open Street Map behind a proxy
Status: RESOLVED FIXED
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR minor with 1 vote (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-03 11:12 UTC by Javier Sánchez
Modified: 2021-03-10 07:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Javier Sánchez 2014-04-03 11:12:29 UTC
When I'm behind a proxy, I can't view the OpenStreetMap layer in the map. The application fails to load the tiles. With exactly the same system if I'm not behind a proxy all works fine. I have defined the proxy at system level, in konqueror and with the commands

kwriteconfig --file kioslaverc --group 'Proxy Settings' --key ProxyType 1
kwriteconfig --file kioslaverc --group 'Proxy Settings' --key httpProxy http://myproxy:myport/


Reproducible: Always

Steps to Reproduce:
1. Conect to the network throught a proxy
2. Open digikam
3. Select OpenStreetMap in the map settings
Actual Results:  
You can't see the OSM map if you select a geotagged image.

Expected Results:  
Map tiles are loaded if you are not behind a proxy

I'm on Ubuntu (not Kubuntu) and installed digikam and konqueror from apt.
Comment 1 caulier.gilles 2014-04-03 11:48:52 UTC
Your proxy settings is well recorded in KDE control panel proxy settings ?

Note that it's not Konqueror widget which is used in background through libkgeomap to play with OSM, but marble widget.

Marble is able to show OSM through your proxy in same conditions ?

Gilles Caulier
Comment 2 Javier Sánchez 2014-04-03 13:15:52 UTC
Yes. I check it with kcmshell4 proxy.
Note: Others maps (Atlas, Google) works well.

Javier Sanchez
Comment 3 caulier.gilles 2014-09-01 21:18:45 UTC
Michael,

Sound like this file is relevant of Marble, not digiKam. Right ?

Gilles
Comment 4 Michael G. Hansen 2014-09-04 09:11:05 UTC
Hi Gilles,

I do not know for sure, because I am not sure whether we have to tell the Marble widget about the proxy.

Javier, can you check whether you can see any OSM map in the Marble application with your proxy set up?

Best regards,

Michael Hansen
Comment 5 caulier.gilles 2014-09-04 09:26:10 UTC
Michael, Javier,

If i'm not too wrong, KDE handle proxy into Network Settings section from KDE control panel...

Gilles Caulier
Comment 6 caulier.gilles 2015-09-17 06:02:43 UTC
This problem sound like a Marble one, as digiKam do not have any control how marble widget manage the connection over the network to ping OSM web service.
Comment 7 Justin Zobel 2021-03-09 22:51:24 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 8 Javier Sánchez 2021-03-10 07:36:22 UTC
Tested and working