Bug 332999 - Export shortcut
Summary: Export shortcut
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Keyboard (show other bugs)
Version: 3.5.0
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-04-03 07:18 UTC by DrSlony
Modified: 2017-08-02 17:41 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2014-04-03 07:18:25 UTC
The Export function should have a default keyboard shortcut of Ctrl+Shift+e.

Reproducible: Always
Comment 1 caulier.gilles 2014-08-21 21:59:13 UTC
Which "export" function do you talk about exactly ? From Image Editor ?
Comment 2 DrSlony 2014-08-22 05:54:22 UTC
Hi!

Yes, from showFoto.

I added a custom shortcut myself, but I think for users in general it would be good if a shortcut for exporting existed out-of-the-box, since its a button as common as "save as" in other programs (ctrl+shift+s usually).
Comment 3 caulier.gilles 2014-08-22 06:33:51 UTC
Git commit fa63080dfe476a643f3795c8140d4617256a118e by Gilles Caulier.
Committed on 22/08/2014 at 06:32.
Pushed by cgilles into branch 'master'.

Add new keyboard shortcut to File/Export action from Image Editor (CRTL+SHIFT+E)
constify and polish implementation
FIXED-IN: 4.3.0

M  +4    -2    NEWS
M  +55   -52   utilities/imageeditor/editor/editorwindow.cpp

http://commits.kde.org/digikam/fa63080dfe476a643f3795c8140d4617256a118e