Bug 332832 - Popup Palette broken with unused gray space and hover areas for selecting presets.
Summary: Popup Palette broken with unused gray space and hover areas for selecting pre...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: git master (please specify the git hash!)
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-31 05:05 UTC by vanyossi
Modified: 2014-05-30 15:49 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Popup palette, now and patched. (170.33 KB, image/png)
2014-03-31 05:06 UTC, vanyossi
Details
Proposed fix patch (1.95 KB, patch)
2014-03-31 05:07 UTC, vanyossi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vanyossi 2014-03-31 05:05:44 UTC
Reduced hover area than visible area in presets. (see attached image)
Big gray unused area in the between the color history and presets. (it seems unused on my build at least)

Made a patch for master that does the following
Reduce palette size to 280 diameter
eliminate gap between color history and presets
Reduce a few pixels preset area but readjust hover area to match visible area.
Remove selected color backdrop from the triangle area as this makes color selection more difficult because of surround color. And because we now have the "ear" color that updates as the color changes.


Reproducible: Always
Comment 1 vanyossi 2014-03-31 05:06:35 UTC
Created attachment 85856 [details]
Popup palette, now and patched.
Comment 2 vanyossi 2014-03-31 05:07:51 UTC
Created attachment 85857 [details]
Proposed fix patch
Comment 3 Halla Rempt 2014-03-31 07:55:55 UTC
Git commit 486ee6dbdad4880d1cb3627f9a19369790f51fb6 by Boudewijn Rempt.
Committed on 31/03/2014 at 07:53.
Pushed by rempt into branch 'master'.

Patch by Ghevan
CCMAIL:ghevan@gmail.com

M  +4    -15   krita/ui/kis_popup_palette.cpp

http://commits.kde.org/calligra/486ee6dbdad4880d1cb3627f9a19369790f51fb6
Comment 4 Halla Rempt 2014-05-30 15:49:15 UTC
Git commit b6b993801631bb27ada4c8d139095e637a784933 by Boudewijn Rempt.
Committed on 31/03/2014 at 07:53.
Pushed by dickson into tag 'steam-247500_247566'.

Patch by Ghevan
CCMAIL:ghevan@gmail.com

M  +4    -15   krita/ui/kis_popup_palette.cpp

http://commits.kde.org/calligra/b6b993801631bb27ada4c8d139095e637a784933