Bug 332777 - sent mail is not saved on disk with akonadi 1.12
Summary: sent mail is not saved on disk with akonadi 1.12
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: GIT (master)
Platform: Archlinux Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-03-29 13:18 UTC by Hussam Al-Tayeb
Modified: 2014-04-08 10:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hussam Al-Tayeb 2014-03-29 13:18:34 UTC
Using akonadi 1.12, kmail only stores sent email in akonadi database and not on disk.
This happens both in kdepim 4.12.3 and also after upgrading to kdepim 4.13RC1

(marking as major since there is actually data loss here). Feel free to downgrade.

Reproducible: Always
Comment 1 Hussam Al-Tayeb 2014-03-29 15:42:33 UTC
Even manually moving any email within kmail to 'sent-mail' folder doesn't really move it physically on disk.
Comment 2 mau 2014-04-04 14:05:34 UTC
Same here, kubuntu and KDE 4.12.97
Comment 3 Buddlespit 2014-04-08 10:38:49 UTC
as of this morning, it appears that the emails I sent out yesterday survived in my local 'Sent' folder thru multiple reboots. Fixed?
Comment 4 Hussam Al-Tayeb 2014-04-08 10:56:50 UTC
Yes. It seems fixed in akonadi 1.12.1
I will close the bug.