Bug 332774 - kmail crashed when NOT entering the gpg key for decryption
Summary: kmail crashed when NOT entering the gpg key for decryption
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kmail2
Classification: Applications
Component: crypto (show other bugs)
Version: 4.11.5
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-29 11:54 UTC by Stefan Seide
Modified: 2014-03-31 01:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Seide 2014-03-29 11:54:54 UTC
within the message list i select a gpg encrypted email. A message box "pineentry" - "You need to enter a passphrase to unlock the secret key..." opens. There I press "Cancel". 
Now another Messagebox "PGP-Warnung - Kontact" opens with "Der eingegebene Passwort-Satz war ungültig. ...". (first question - should this happen as i did not enter an passphrase and pressed cancel before?) Now i press "Cancel" again and Kontact crashes. This is reproducible ever time with all pgp encrypted mails.

When i do enter the correct passphrase the mail gets encrypted.

The following is the KDE error report:

Application: kontact (4.11.5)
KDE Platform Version: 4.11.3
Qt Version: 4.8.6
Operating System: Linux 3.13-1-amd64 x86_64
Distribution: Debian GNU/Linux testing (jessie)

-- Information about the crash:
<Erklären Sie bitte ganz genau, was Sie machten, als das Programm abstürzte.>

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcdc1dfa780 (LWP 7402))]

Thread 6 (Thread 0x7fcd9e0f9700 (LWP 7403)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fcdbcc637d2 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fcdbcc63809 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fcdb9b21062 in start_thread (arg=0x7fcd9e0f9700) at pthread_create.c:312
#4  0x00007fcdbf342a3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 5 (Thread 0x7fcd9d7d0700 (LWP 7404)):
#0  0x00007fcdbfab491e in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#1  0x00007fcdb9647291 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcdb96477ab in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcdb964791c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcdbfab4746 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fcdbfa860bf in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fcdbfa863b5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fcdbf982c5f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fcdbf98532f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fcdb9b21062 in start_thread (arg=0x7fcd9d7d0700) at pthread_create.c:312
#10 0x00007fcdbf342a3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 4 (Thread 0x7fcd952a6700 (LWP 7405)):
#0  0x00007fcdb9687072 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fcdb9687349 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcdb9647129 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcdb9647782 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcdb9647b3a in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fcdaaeabad6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#6  0x00007fcdb966c095 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007fcdb9b21062 in start_thread (arg=0x7fcd952a6700) at pthread_create.c:312
#8  0x00007fcdbf342a3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fcd13812700 (LWP 7660)):
#0  0x00007fcdbf33772d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fcdb9647814 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcdb964791c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcdbfab4746 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fcdbfa860bf in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fcdbfa863b5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fcdbf982c5f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fcdbfa67833 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fcdbf98532f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fcdb9b21062 in start_thread (arg=0x7fcd13812700) at pthread_create.c:312
#10 0x00007fcdbf342a3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fcd12d35700 (LWP 7665)):
#0  0x00007fcdb9644cf4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fcdb9646e5b in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcdb9647733 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcdb964791c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcdbfab4746 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fcdbfa860bf in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fcdbfa863b5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fcdbf982c5f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fcdbfa67833 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fcdbf98532f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007fcdb9b21062 in start_thread (arg=0x7fcd12d35700) at pthread_create.c:312
#11 0x00007fcdbf342a3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fcdc1dfa780 (LWP 7402)):
[KCrash Handler]
#5  0x00007fcdb6181104 in KMime::Content::parent() const () from /usr/lib/libkmime.so.4
#6  0x00007fcd21e54b27 in MessageCore::NodeHelper::nextSibling(KMime::Content const*) () from /usr/lib/libmessagecore.so.4
#7  0x00007fcd203ff12d in MessageViewer::ObjectTreeParser::parseObjectTreeInternal(KMime::Content*) () from /usr/lib/libmessageviewer.so.4
#8  0x00007fcd2042ce68 in ?? () from /usr/lib/libmessageviewer.so.4
#9  0x00007fcd2042d612 in ?? () from /usr/lib/libmessageviewer.so.4
#10 0x00007fcd2042e25a in ?? () from /usr/lib/libmessageviewer.so.4
#11 0x00007fcd204359bd in ?? () from /usr/lib/libmessageviewer.so.4
#12 0x00007fcdbfa9b77a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#13 0x00007fcdbfa9f931 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007fcdc048c6cc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#15 0x00007fcdc0492d40 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#16 0x00007fcdc11ae49a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0x00007fcdbfa874ed in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#18 0x00007fcdbfab7203 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#19 0x00007fcdbfab44f1 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#20 0x00007fcdb9647526 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fcdb9647878 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fcdb964791c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fcdbfab4725 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#24 0x00007fcdc052a776 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#25 0x00007fcdbfa860bf in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#26 0x00007fcdbfa863b5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#27 0x00007fcdbfa8bb89 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#28 0x0000000000403660 in ?? ()
#29 0x00007fcdbf27eb45 in __libc_start_main (main=0x402bb0, argc=1, argv=0x7fff7274aa38, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7274aa28) at libc-start.c:287
#30 0x0000000000403b28 in _start ()


Reproducible: Always

Steps to Reproduce:
1. open kontact/kmail
2. select encrypted email in message list, pinentry message box pops up
3. press cancel
4. on new message box asking if i want to enter pin again press cancel
5. crash


Expected Results:  
1. kmail should not ask to enter pin again after pressing cancel in pinentry dialog
2. kmail should not crash
Comment 1 Jekyll Wu 2014-03-31 01:32:42 UTC

*** This bug has been marked as a duplicate of bug 279749 ***