Bug 332624 - NFS support
Summary: NFS support
Status: RESOLVED DUPLICATE of bug 275261
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 4.12
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on: 275261 232086 331848 332013
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-26 11:04 UTC by Martin Steigerwald
Modified: 2021-02-04 20:32 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Steigerwald 2014-03-26 11:04:00 UTC
Please support running Akonadi on NFS based home directories.

Using NFS and LDAP is IMHO quite common in organizations which use Linux on desktops, be it companies, universities or schools.

As to my experience Icedove and Evolution work OK on NFS, but Akonadi / KDEPIM work slowly, partly unusable slowly regarding large mail accounts. Daniel hinted that storing paylouds into file_db_data may contribute to this issue[1].

As to my experience I do not thing the performance issues are not MySQL based. MySQL seems to perform OK on NFS, possibly with raised innodb_buffer_pool_size. MySQL database also seems to be consistent here after month of attempts to use KMail on NFS :)

Also I didn't see issues with Korganizer journal entries. These general worked nice.

I am reporting this as wishlist as suggest by Christian Mollekopf. Yet I think errors of Akonadi on NFS based storage are bugs unless they are caused by failures in the NFS infrastructure.

[1] https://bugs.kde.org/show_bug.cgi?id=332013#c11

Reproducible: Always

Steps to Reproduce:
Currently there are some bugs regarding that:


Bug 332013 - NFS: on moving a mail: ItemRetrieverException: Unable to retrieve item from resource: NO PartHelperException, unable to open for writing, file too big
=> Does not seem to happen mit Akonadi stored on local Ext4

Bug 331848 - displaying, moving, deleting mails takes 10-20 seconds when Akonadi synchronizes in background
=> is party related, performance is much better with Akonadi based on local Ext4.


Bug 275261 - Akonadi on NFS mounted home directories is very fragile 
=> This is a report with Akonadi on MariaDB on NFS.

 Bug 232086 - kmail unusable/broken in enterprise environment $HOME on NFS during kmail was used same user on other client pc in the past hour 
=> Seem possibly may relate to some process not stopped correctly on logout. I had this with MySQL database process once[2]

[2] https://bugs.kde.org/show_bug.cgi?id=332013#c9 – will report separately.
Actual Results:  
Slow performance upto Akonadi not doing appearing to do anything useful for KMail anymore.

Expected Results:  
OK performance. There might be some tradeoffs, yet with low latency based NFS storage I think technically it really can perform better.

My bug reports are with NetApp FAS based NFS exports. As to my knowledge and what I hear from co-workers the NetApp FAS NFS server implementation provides pretty good performance.
Comment 1 Jonathan Marten 2021-02-04 20:32:06 UTC

*** This bug has been marked as a duplicate of bug 275261 ***