Bug 332584 - System tray shows media controller twice
Summary: System tray shows media controller twice
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Media Player (show other bugs)
Version: master
Platform: unspecified Linux
: NOR normal
Target Milestone: 1.0
Assignee: Martin Klapetek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-25 13:35 UTC by Bhushan Shah
Modified: 2014-04-01 18:12 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (15.14 KB, image/png)
2014-03-25 13:35 UTC, Bhushan Shah
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bhushan Shah 2014-03-25 13:35:10 UTC
Created attachment 85733 [details]
screenshot

one active and one passive
Comment 1 Bhushan Shah 2014-03-25 13:36:23 UTC
Adding sebas in CC as it is related to system tray
Comment 2 Martin Klapetek 2014-03-25 13:40:08 UTC
Do you have two mediaplayers running? Which player are you using?
Comment 3 Bhushan Shah 2014-03-25 13:42:48 UTC
I am running VLC and only one time
Comment 4 Marco Martin 2014-03-25 14:31:28 UTC
make sure your installation is clear and you don't actually have 2 media controllers installed with a different name
Comment 5 Bhushan Shah 2014-03-25 14:37:05 UTC
I am sure with that thing, as yesterday I clean installed everything.
Comment 6 Bhushan Shah 2014-03-25 14:41:26 UTC
For ref,

Listing service types: Plasma/Applet, Plasma/Containment
org.kde.desktopcontainment
org.kde.example.bugreport
org.kde.example.conditionalloader
org.kde.example.configuration
org.kde.example.dataenginemodel
org.kde.example.notes
org.kde.example.tasks
org.kde.example.testcomponents
org.kde.example.testcontainment
org.kde.example.testshaders
org.kde.example.testtheme
org.kde.example.widgetgallery
org.kde.example.windowthumbnails
org.kde.examples.compactrepresentation
org.kde.examples.helloworld
org.kde.panel
org.kde.plasma.activitybar
org.kde.plasma.analogclock
org.kde.plasma.battery
org.kde.plasma.calendar
org.kde.plasma.devicenotifier
org.kde.plasma.digitalclock
org.kde.plasma.icon
org.kde.plasma.kickoff
org.kde.plasma.mediacontroller
org.kde.plasma.notifications
org.kde.plasma.pager
org.kde.plasma.panelspacer
org.kde.plasma.showActivityManager
org.kde.plasma.systemtray
org.kde.plasma.taskmanager
org.kde.plasma.trash
org.kde.plasma.windowlist
org.kde.systrayplasmoidtest
org.kde.tests.background
Comment 7 David Edmundson 2014-03-26 10:49:11 UTC
Can you make sure you delete your plasma configs too.
Comment 8 Martin Klapetek 2014-03-26 11:06:27 UTC
Do you have any special settings in VLC? I don't see any mpris setting in there and it's not on the bus
Comment 10 Martin Klapetek 2014-03-26 11:16:34 UTC
Oh interesting. I can now reproduce with VLC and its mpris interface. Will look.
Comment 11 Bhushan Shah 2014-03-26 11:37:06 UTC
Since you are already there, please see that plasmoid is not correctly working with VLC. it is not showing name.. check screenshot.
Comment 12 Martin Klapetek 2014-04-01 14:43:55 UTC
Investigation results:

VLC exports two mpris interfaces on dbus, but they're still the same object with the same dbus unique address

Solution is to implement a hash of dbus addresses and the interface names and then just check if we already have a container for that dbus address.
Comment 13 Martin Klapetek 2014-04-01 18:12:59 UTC
Git commit f18ef033332d27a060e5db37f99ce359796f4d61 by Martin Klapetek.
Committed on 01/04/2014 at 18:12.
Pushed by mklapetek into branch 'master'.

Fix mediacontroller showing twice for VLC

There's a more correct fix to that (see the comment in the diff) but
given the situation, it's just much easier to go with this way.

Reviewed-by: David Edmundson

M  +18   -0    dataengines/mpris2/mpris2engine.cpp

http://commits.kde.org/plasma-workspace/f18ef033332d27a060e5db37f99ce359796f4d61