Bug 332494 - PDF without text
Summary: PDF without text
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Unclassified
Component: PDF backend (show other bugs)
Version: 0.18.95
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL: http://downloadcenter.samsung.com/con...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-24 07:58 UTC by ugo
Modified: 2014-04-11 11:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.13.0


Attachments
how does the open PDF file with okular (50.90 KB, application/octet-stream)
2014-03-25 08:43 UTC, ugo
Details
PDF opened with okular (35.95 KB, application/octet-stream)
2014-03-26 07:06 UTC, ugo
Details
one the other file PDF okular this version no open (127.07 KB, application/pdf)
2014-03-26 09:23 UTC, ugo
Details
okular no open (244.94 KB, application/pdf)
2014-03-31 07:00 UTC, ugo
Details
no open (445.01 KB, application/pdf)
2014-03-31 07:02 UTC, ugo
Details
open without text (173.93 KB, application/pdf)
2014-03-31 07:03 UTC, ugo
Details
come apre PDF asl (271.89 KB, application/octet-stream)
2014-03-31 08:36 UTC, ugo
Details
come apre samsung (155.07 KB, application/octet-stream)
2014-03-31 08:36 UTC, ugo
Details
come apre VBox (141.42 KB, application/octet-stream)
2014-03-31 08:37 UTC, ugo
Details
come apre navetta IKEA (40.67 KB, application/octet-stream)
2014-03-31 08:37 UTC, ugo
Details
Okular 0.18.0 on Kubuntu 14.04 32 bit on VirtualBox KDE 4.12.0 work fine open PDF Samsung with text , but okular 0.18.95 Kubuntu 14.04 64 bit on VirtualBox KDE 4.12.95 open same PDF file without text (389.90 KB, image/png)
2014-03-31 11:54 UTC, ugo
Details
can be linked to the problem? (5.47 KB, application/octet-stream)
2014-03-31 19:38 UTC, ugo
Details
all right ? Terminal it stopped without going back to my name (3.32 KB, text/plain)
2014-04-01 08:17 UTC, ugo
Details
terminal (3.58 KB, text/plain)
2014-04-01 08:20 UTC, ugo
Details
ok ? (55.88 KB, text/plain)
2014-04-01 08:37 UTC, ugo
Details
I do not know if there is a connection but also libreoffice writer has become transparent. (1.78 MB, application/octet-stream)
2014-04-01 18:54 UTC, ugo
Details
as required comm 36 (5.72 KB, text/plain)
2014-04-02 05:30 UTC, ugo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ugo 2014-03-24 07:58:13 UTC
PDF document oper whitout text and image

Reproducible: Always
Comment 1 ugo 2014-03-25 08:43:53 UTC
Created attachment 85727 [details]
how does the open PDF file with okular
Comment 2 Albert Astals Cid 2014-03-25 08:47:12 UTC
Where's the pdf itself?
Comment 3 ugo 2014-03-25 09:03:55 UTC
Il 25/03/2014 09:47, Albert Astals Cid ha scritto:
> https://bugs.kde.org/show_bug.cgi?id=332494
>
> Albert Astals Cid <aacid@kde.org> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>               Status|UNCONFIRMED                 |NEEDSINFO
>                   CC|                            |aacid@kde.org
>           Resolution|---                         |WAITINGFORINFO
>
> --- Comment #2 from Albert Astals Cid <aacid@kde.org> ---
> Where's the pdf itself?
>
the photo is of a PDF file opened with okular -last okular( photo png) , 
it is file PDF  whitout text)
Comment 4 Albert Astals Cid 2014-03-25 09:06:45 UTC
I know what it is. I am asking you for the pdf file. Or how do you expect us to fix your bug without the PDF file that causes this problem?
Comment 5 ugo 2014-03-25 09:44:07 UTC
----Messaggio originale----
Da: aacid@kde.org
Data: 25-mar-2014 10.06
A: <ugo.b.4hvn@alice.it>
Ogg: [okular] [Bug 332494] PDF without text

https://bugs.kde.org/show_bug.cgi?id=332494

--- Comment #4 from Albert Astals Cid <aacid@kde.org> ---
I know what it is. I am asking you for the pdf file. Or how do you expect us to
fix your bug without the PDF file that causes this problem?
Comment 6 Albert Astals Cid 2014-03-25 18:50:27 UTC
I have no idea what that last thing tried to be, but for sure it wasn't what i asked for.
Comment 7 ugo 2014-03-26 06:20:05 UTC
----Messaggio originale----
Da: aacid@kde.org
Data: 25-mar-2014 19.50
A: <ugo.b.4hvn@alice.it>
Ogg: [okular] [Bug 332494] PDF without text

https://bugs.kde.org/show_bug.cgi?id=332494

--- Comment #6 from Albert Astals Cid <aacid@kde.org> ---
I have no idea what that last thing tried to be, but for sure it wasn't what i
asked for.
Comment 8 Yuri Chornoivan 2014-03-26 06:28:04 UTC
(In reply to comment #7)
Attaching file to your email replies does not work.

Please visit this page:
https://bugs.kde.org/show_bug.cgi?id=332494

press "Add an attachment" link and attach your file to the bug report. Thanks in advance.
Comment 9 ugo 2014-03-26 07:01:56 UTC
I think Okular stopped working when there was an update to Kubuntu 14.04 - Linux 3.13.0-19-generic - KDE 4.12.95 - Okular 4,4,12.90-0ubuntu3 - System 64 bit on VirtualBox
Best regard
ugo
Comment 10 ugo 2014-03-26 07:06:10 UTC
Created attachment 85753 [details]
PDF opened with okular
Comment 11 ugo 2014-03-26 07:15:33 UTC
----Messaggio originale----
Da: yurchor@ukr.net
Data: 26-mar-2014 7.28
A: <ugo.b.4hvn@alice.it>
Ogg: [okular] [Bug 332494] PDF without text

https://bugs.kde.org/show_bug.cgi?id=332494

Yuri Chornoivan <yurchor@ukr.net> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |yurchor@ukr.net

--- Comment #8 from Yuri Chornoivan <yurchor@ukr.net> ---
(In reply to comment #7)
Attaching file to your email replies does not work.

Please visit this page:
https://bugs.kde.org/show_bug.cgi?id=332494

press "Add an attachment" link and attach your file to the bug report. Thanks
in advance.
Comment 12 ugo 2014-03-26 07:34:51 UTC
in the lower right corner of the PDF file that Okular try to open it says "nan-nan mm vertical paper format unknow"
Comment 13 ugo 2014-03-26 09:23:59 UTC
Created attachment 85757 [details]
one the other file PDF  okular this version no open
Comment 14 Yuri Chornoivan 2014-03-26 16:26:25 UTC
(In reply to comment #13)
> Created attachment 85757 [details]
> one the other file PDF  okular this version no open

Works fine here (Okular 0.19, poppler 0.25.1, KDE 4.11.4, Mageia 4 x86-64).
Comment 15 Albert Astals Cid 2014-03-26 23:22:42 UTC
Works fine here. Any reason you're on Okular 4,12.90 and not 4,12.95?
Comment 16 ugo 2014-03-27 06:09:52 UTC
----Messaggio originale----
Da: aacid@kde.org
Data: 27-mar-2014 0.22
A: <ugo.b.4hvn@alice.it>
Ogg: [okular] [Bug 332494] PDF without text

https://bugs.kde.org/show_bug.cgi?id=332494

--- Comment #15 from Albert Astals Cid <aacid@kde.org> ---
Works fine here. Any reason you're on Okular 4,12.90 and not 4,12.95?
Comment 17 ugo 2014-03-27 06:19:12 UTC
----Messaggio originale----
Da: aacid@kde.org
Data: 27-mar-2014 0.22
A: <ugo.b.4hvn@alice.it>
Ogg: [okular] [Bug 332494] PDF without text

https://bugs.kde.org/show_bug.cgi?id=332494

--- Comment #15 from Albert Astals Cid <aacid@kde.org> ---
Works fine here. Any reason you're on Okular 4,12.90 and not 4,12.95?
Comment 18 ugo 2014-03-28 08:22:12 UTC
okular 4.12.95 is installed on pc 64 bit and okular 4.12.90  is installed on other pc 32 bit kubuntu 14.04 but also  opens them up PDF files without text
Comment 19 Albert Astals Cid 2014-03-31 00:02:06 UTC
Can you enable all the okular debug output in kdebugdialog (serach for okular in the top bar) and paste all the output you get when starting okular from a terminal and trying to open the pdf document you attached?
Comment 20 ugo 2014-03-31 07:00:16 UTC
Created attachment 85858 [details]
okular no open
Comment 21 ugo 2014-03-31 07:02:15 UTC
Created attachment 85859 [details]
no open
Comment 22 ugo 2014-03-31 07:03:13 UTC
Created attachment 85860 [details]
open without text
Comment 23 ugo 2014-03-31 08:36:01 UTC
Created attachment 85861 [details]
come apre PDF  asl
Comment 24 ugo 2014-03-31 08:36:40 UTC
Created attachment 85862 [details]
come apre samsung
Comment 25 ugo 2014-03-31 08:37:16 UTC
Created attachment 85863 [details]
come apre VBox
Comment 26 ugo 2014-03-31 08:37:50 UTC
Created attachment 85864 [details]
come apre navetta IKEA
Comment 27 ugo 2014-03-31 11:54:11 UTC
Created attachment 85869 [details]
Okular 0.18.0 on Kubuntu 14.04 32 bit on VirtualBox KDE 4.12.0 work fine open PDF Samsung with text , but  okular 0.18.95 Kubuntu 14.04 64 bit on VirtualBox KDE 4.12.95 open same PDF file without text
Comment 28 ugo 2014-03-31 19:38:29 UTC
Created attachment 85875 [details]
can be linked to the problem?
Comment 29 Albert Astals Cid 2014-03-31 22:03:44 UTC
Seriously, I asked a question in comment 19 and instead of answering it you flooded us with stuff we didn't ask for? Why did you do that?
Comment 30 ugo 2014-04-01 07:01:32 UTC
Why I interpreted as a request for comment 19 (include results of how okular opens the PDF file). If it is not the correct interpretation, please show step by step what I should do. Greetings.
Comment 31 Albert Astals Cid 2014-04-01 07:48:07 UTC
Comment 19 in more clear steps:
 * Start a terminal
 * Run kdebugdialog from the terminal (also known as konsole)
 * Enable all okular output in kdebugdialog
 * Close kdebugdialog (with ok button)
 * Start okular from the terminal
 * Open a file that doesn't work
 * Attach the text output okular writes to the terminal to this bug
Comment 32 ugo 2014-04-01 08:17:56 UTC
Created attachment 85879 [details]
all right ?  Terminal it stopped without going back to my name
Comment 33 ugo 2014-04-01 08:20:22 UTC
Created attachment 85880 [details]
terminal
Comment 34 ugo 2014-04-01 08:37:36 UTC
Created attachment 85881 [details]
ok ?
Comment 35 ugo 2014-04-01 18:54:41 UTC
Created attachment 85892 [details]
I do not know if there is a connection but also libreoffice writer has become transparent.
Comment 36 Albert Astals Cid 2014-04-01 23:34:24 UTC
One more thing, can you please run kscreen-console bug on a terminal and attach the output?
Comment 37 Albert Astals Cid 2014-04-01 23:34:44 UTC
The command is 
kscreen-console bug
Comment 38 ugo 2014-04-02 05:30:38 UTC
Created attachment 85896 [details]
as required comm 36
Comment 39 ugo 2014-04-02 07:01:36 UTC
Comment on attachment 85896 [details]
as required comm 36

>kk@kk-VirtualBox:~$ kscreen-console bug
>kscreen-console(2365)/KSharedDataCache KSharedDataCache::insert: Overwriting existing cached entry due to collision.
>kscreen-console(2365)/KSharedDataCache KSharedDataCache::insert: Overwriting existing old cached entry due to collision.
>kscreen-console(2365)/KSharedDataCache KSharedDataCache::insert: Overwriting existing cached entry due to collision.
>kscreen-console(2365)/KSharedDataCache KSharedDataCache::insert: Overwriting existing old cached entry due to collision.
>kscreen-console(2365)/KSharedDataCache KSharedDataCache::insert: Overwriting existing cached entry due to collision.
>START 
>kscreen-console(2365)/KSRandr11 XRandRX11Helper::XRandRX11Helper: Detected XRandR 1.4
>kscreen-console(2365)/KSRandr11 XRandRX11Helper::XRandRX11Helper: Event Base:  89
>kscreen-console(2365)/KSRandr11 XRandRX11Helper::XRandRX11Helper: Event Error:  147
>This backend is only for XRandR 1.1, your version is:  1 . 4 
>kscreen-console(2365)/KSRandr XRandRX11Helper::XRandRX11Helper: Detected XRandR 1.4
>kscreen-console(2365)/KSRandr XRandRX11Helper::XRandRX11Helper: Event Base:  89
>kscreen-console(2365)/KSRandr XRandRX11Helper::XRandRX11Helper: Event Error:  147
>Config::current() took 114 milliseconds 
>
>========================xrandr --verbose========================== 
>
>Screen 0: minimum 64 x 64, current 1920 x 1034, maximum 16384 x 16384
>VBOX0 connected primary 1920x1034+0+0 (0x40) normal (normal) 0mm x 0mm
>        Identifier: 0x3f
>        Timestamp:  37531
>        Subpixel:   unknown
>        Gamma:      1.0:1.0:1.0
>        Brightness: 1.0
>        Clones:    
>        CRTC:       0
>        CRTCs:      0
>        Transform:  1.000000 0.000000 0.000000
>                    0.000000 1.000000 0.000000
>                    0.000000 0.000000 1.000000
>                   filter: 
>        EDID: 
>                00ffffffffffff005858000080070a04
>                0100010380000078eeee91a3544c9926
>                0f505400000001010101010101010101
>                010101010101f22e8006700a06400202
>                2200000000000000000000fd0000c800
>                c864000a202020202020000000fc0056
>                424f58206d6f6e69746f720a00000010
>                000a2020202020202020202020200044
>        VBOX_MODE: ? ? ? ? 
>  1920x1034 (0x40)  120.2MHz *current +preferred
>        h: width  1920 start 1922 end 1924 total 1926 skew    0 clock   62.4KHz
>        v: height 1034 start 1036 end 1038 total 1040           clock   60.0Hz
>  1280x960 (0x41)   74.5MHz
>        h: width  1280 start 1282 end 1284 total 1286 skew    0 clock   58.0KHz
>        v: height  960 start  962 end  964 total  966           clock   60.0Hz
>  1024x768 (0x42)   47.8MHz
>        h: width  1024 start 1026 end 1028 total 1030 skew    0 clock   46.4KHz
>        v: height  768 start  770 end  772 total  774           clock   60.0Hz
>  800x600 (0x43)   29.3MHz
>        h: width   800 start  802 end  804 total  806 skew    0 clock   36.4KHz
>        v: height  600 start  602 end  604 total  606           clock   60.0Hz
>  640x480 (0x44)   18.8MHz
>        h: width   640 start  642 end  644 total  646 skew    0 clock   29.2KHz
>        v: height  480 start  482 end  484 total  486           clock   60.0Hz
> 
>
>========================Outputs=================================== 
>
>KScreen version:  1.0.2.1 
>Screen: 
>        maxSize: QSize(16384, 16384) 
>        minSize: QSize(64, 64) 
>        currentSize: QSize(1920, 1034) 
>
>-----------------------------------------------------
> 
>Id:  63 
>Name:  "VBOX0" 
>Type:  "Unknown" 
>Connected:  true 
>Enabled:  true 
>Primary:  false 
>Rotation:  1 
>Pos:  QPoint(0,0) 
>MMSize:  QSize(0, 0) 
>Size:  QSize(1920, 1034) 
>Clones:  None 
>Mode:  "64" 
>Preferred Mode:  "64" 
>Preferred modes:  ("64") 
>Modes:  
>         "66"    "1024x768"   QSize(1024, 768)   59.9997 
>         "67"    "800x600"   QSize(800, 600)   59.9997 
>         "68"    "640x480"   QSize(640, 480)   59.9989 
>         "64"    "1920x1034"   QSize(1920, 1034)   59.9998 
>         "65"    "1280x960"   QSize(1280, 960)   59.9995 
>EDID Info:  
>        Device ID:  "xrandr-VBOX monitor-67766144" 
>        Name:  "VBOX monitor" 
>        Vendor:  "" 
>        Serial:  "67766144" 
>        EISA ID:  "" 
>        Hash:  "879cc2b99835fcb919842c58210f3e55" 
>        Width:  0 
>        Height:  0 
>        Gamma:  2 
>        Red:  QQuaternion(scalar:1, vector:(0.639648, 0.328125, 0)) 
>        Green:  QQuaternion(scalar:1, vector:(0.299805, 0.599609, 0)) 
>        Blue:  QQuaternion(scalar:1, vector:(0.150391, 0.0595703, 0)) 
>        White:  QQuaternion(scalar:1, vector:(0.3125, 0.329102, 0)) 
>
>========================Configurations============================ 
>
>Configs in:  "/home/kk/.kde/share/apps/kscreen/" 
>Number of files:  3 
>
>"250029cc11aab0b33c969f86586844be" 
>"[
> {
>  "enabled" : true,
>  "id" : "405cde0c0a0604ffb3e5d422ab1eee4d",
>  "metadata" :   {
>   "fullname" : "xrandr-VBOX monitor-62915840",
>   "name" : "VBOX0"
>  },
>  "mode" :   {
>   "refresh" : 59.9995,
>   "size" :    {
>    "height" : 960,
>    "width" : 1280
>   }
>  },
>  "pos" :   {
>   "x" : 0,
>   "y" : 0
>  },
>  "primary" : true,
>  "rotation" : 1
> }
>]" 
>
>"98e2d4ae8a379e796d3f4848baf53ebb" 
>"[
> {
>  "enabled" : true,
>  "id" : "879cc2b99835fcb919842c58210f3e55",
>  "metadata" :   {
>   "fullname" : "xrandr-VBOX monitor-67766144",
>   "name" : "VBOX0"
>  },
>  "mode" :   {
>   "refresh" : 59.9998,
>   "size" :    {
>    "height" : 1034,
>    "width" : 1920
>   }
>  },
>  "pos" :   {
>   "x" : 0,
>   "y" : 0
>  },
>  "primary" : true,
>  "rotation" : 1
> }
>]" 
>
>"c21f969b5f03d33d43e04f8f136e7682" 
>"[
> {
>  "enabled" : true,
>  "id" : "default",
>  "metadata" :   {
>   "name" : "default"
>  },
>  "mode" :   {
>   "refresh" : 61.0,
>   "size" :    {
>    "height" : 768,
>    "width" : 1024
>   }
>  },
>  "pos" :   {
>   "x" : 0,
>   "y" : 0
>  },
>  "primary" : true,
>  "rotation" : 1
> }
>]" 
>
>kk@kk-VirtualBox:~$
Comment 40 Vincenzo 2014-04-02 08:47:37 UTC
Same problem here, Kubuntu 14.04 64 bit running on VM.

$ okular --version
Qt: 4.8.6
KDE Development Platform: 4.12.95
Okular: 0.18.95

I cannot find any PDF that I *can* display. All of them have blank pages.
Comment 41 Albert Astals Cid 2014-04-02 22:43:47 UTC
Git commit a7f3a1ac37af94af5078051ceb5b310fb93194ed by Albert Astals Cid.
Committed on 02/04/2014 at 22:42.
Pushed by aacid into branch 'KDE/4.13'.

Protect us against broken drivers/screens

Some drivers screens return 0x0 as their screen size so we can't use it
to calculate the dpi
Related: bug 332746
FIXED-IN: 4.13.0

M  +17   -9    core/utils.cpp

http://commits.kde.org/okular/a7f3a1ac37af94af5078051ceb5b310fb93194ed
Comment 42 ugo 2014-04-03 09:36:14 UTC
4.13.0 To date there is no fixed list of updates
Comment 43 ugo 2014-04-11 11:06:56 UTC
With today's update 11.04.2014, the okular bug has been fixed. Now okular works well and it also opens the PDF file. Thank you.