Bug 332288 - Crashes when I type forward slash at end of line
Summary: Crashes when I type forward slash at end of line
Status: RESOLVED DUPLICATE of bug 328271
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: 3.11.5
Platform: Ubuntu Packages Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-18 17:34 UTC by amy.worthington
Modified: 2014-03-18 21:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description amy.worthington 2014-03-18 17:34:04 UTC
With text highlighting set to "none", typing a forward slash (/) at the end of any line causes a segmentation fault. It does not happen if some specific highlighting mode is selected. It only seems to happen on files of unrecognised filename suffix (switching highlighing to "none" when editing a .cpp file for instance, does not cause the crash).


Reproducible: Always

Steps to Reproduce:
1. create a file with some arbitrary suffix (tried .mk and .su)
2. type a forward slash (/) at the end of any line
3. enjoy crash
Actual Results:  
segmentation fault

Expected Results:  
I expect a "/" to appear at the end of the line and the application not to crash.

Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f65462ff7c0 (LWP 4886))]

Thread 4 (Thread 0x7f6532671700 (LWP 4887)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f6533c3e06b in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f6533c3e0a9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f6543258f6e in start_thread (arg=0x7f6532671700) at pthread_create.c:311
#4  0x00007f6545c409cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f64af432700 (LWP 4888)):
#0  0x00007f6542dc00ed in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6542dc03c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6542d80299 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6542d80708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6542d807ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6543b55a76 in QEventDispatcherGlib::processEvents (this=0x7f64a80008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f6543b275ef in QEventLoop::processEvents (this=this@entry=0x7f64af431d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f6543b278e5 in QEventLoop::exec (this=this@entry=0x7f64af431d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f6543a2688f in QThread::exec (this=this@entry=0x15f4bb0) at thread/qthread.cpp:542
#9  0x00007f6543b08d13 in QInotifyFileSystemWatcherEngine::run (this=0x15f4bb0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f6543a28f2f in QThreadPrivate::start (arg=0x15f4bb0) at thread/qthread_unix.cpp:338
#11 0x00007f6543258f6e in start_thread (arg=0x7f64af432700) at pthread_create.c:311
#12 0x00007f6545c409cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f64ae787700 (LWP 4889)):
#0  0x00007f6545c33f7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f6542d806a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6542d807ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6543b55a76 in QEventDispatcherGlib::processEvents (this=0x7f64a00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6543b275ef in QEventLoop::processEvents (this=this@entry=0x7f64ae786d70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6543b278e5 in QEventLoop::exec (this=this@entry=0x7f64ae786d70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6543a2688f in QThread::exec (this=this@entry=0x17a6df0) at thread/qthread.cpp:542
#7  0x00007f6543b08d13 in QInotifyFileSystemWatcherEngine::run (this=0x17a6df0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f6543a28f2f in QThreadPrivate::start (arg=0x17a6df0) at thread/qthread_unix.cpp:338
#9  0x00007f6543258f6e in start_thread (arg=0x7f64ae787700) at pthread_create.c:311
#10 0x00007f6545c409cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f65462ff7c0 (LWP 4886)):
[KCrash Handler]
#6  0x00007f6534289fd0 in contextNum (n=<optimized out>, this=<optimized out>) at ../../part/syntax/katehighlight.h:267
#7  KateDocument::defStyleNum (this=0xeb32a0, line=<optimized out>, column=<optimized out>) at ../../part/document/katedocument.cpp:5383
#8  0x00007f65342b18f9 in KateScriptDocument::defStyleNum (this=<optimized out>, line=<optimized out>, column=<optimized out>) at ../../part/script/katescriptdocument.cpp:51
#9  0x00007f65342b1979 in KateScriptDocument::isString (this=<optimized out>, line=<optimized out>, column=<optimized out>) at ../../part/script/katescriptdocument.cpp:83
#10 0x00007f653422f7ad in KateScriptDocument::qt_static_metacall (_o=0x18bbca0, _id=1139333456, _id@entry=90, _a=0x7fffbac7bcf0, _c=<optimized out>) at moc_katescriptdocument.cpp:406
#11 0x00007f6534230823 in qt_static_metacall (_a=0x7fffbac7bcf0, _id=90, _c=QMetaObject::InvokeMetaMethod, _o=0x18bbca0) at moc_katescriptdocument.cpp:467
#12 KateScriptDocument::qt_metacall (this=0x18bbca0, _c=QMetaObject::InvokeMetaMethod, _id=90, _a=0x7fffbac7bcf0) at moc_katescriptdocument.cpp:468
#13 0x00007f6533ca9cc6 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#14 0x00007f6533caae09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#15 0x00007f6533cab099 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#16 0x00007f6533bb0228 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#17 0x00007f6533b8e0c0 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#18 0x00007f64b1e0e1a9 in ?? ()
#19 0x0000000000000000 in ?? ()
Comment 1 Jekyll Wu 2014-03-18 21:19:41 UTC

*** This bug has been marked as a duplicate of bug 328271 ***