Bug 332139 - Panels should consider other struts when maximising
Summary: Panels should consider other struts when maximising
Status: RESOLVED DUPLICATE of bug 336374
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: master
Platform: unspecified Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-14 14:27 UTC by David Edmundson
Modified: 2014-06-18 09:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Edmundson 2014-03-14 14:27:08 UTC
Otherwise panels can overlap which sucks
Comment 1 Martin Klapetek 2014-05-02 15:38:32 UTC
I've investigated this bug, it's another case where QScreen seems to be the cause.

I have two screens here (extended desktop, no cloning), adding a panel does not seem to update QScreen::availableGeometry() and this then still returns the full screen size without struts by the other panels. However it seems to work for primary screen (only) when the panels are loaded on plasma startup.

This may also be a bug in our panels setting struts properly (I found one already) or QScreen reacting to the struts (or NET::WorkArea rather).

Furthermore, the panel sizing & positioning methods actually do not use the availableSize/availableGeometry methods, but always the "full screen" size/geometry methods.

All in all, QScreen seems to be the culprit in this bug.
Comment 2 Elias Probst 2014-05-04 10:54:55 UTC
Is #322480 a dup or just related?
Comment 3 Martin Klapetek 2014-05-06 12:42:27 UTC
Related, yes, duplicate, not so much. Your comment on that bug (comment 11) is I think a different problem - when you place a panel at the shared screen edge, that panel is ignored by kwin and that's deliberate - see https://bugs.kde.org/show_bug.cgi?id=167852

This bug is about panels ignoring other panels (all of them) when changing that panel size (automatically or manually).
Comment 4 David Edmundson 2014-06-18 09:29:29 UTC

*** This bug has been marked as a duplicate of bug 336374 ***