Bug 331975 - ShowPhoto crashes if SD Card is removed
Summary: ShowPhoto crashes if SD Card is removed
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Showfoto-Usability (show other bugs)
Version: 4.0.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-03-10 15:07 UTC by Veaceslav Munteanu
Modified: 2022-02-05 04:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Veaceslav Munteanu 2014-03-10 15:07:04 UTC
Application: showfoto (4.0.0-beta4)
KDE Platform Version: 4.12.3 (Compiled from sources)
Qt Version: 4.8.5
Operating System: Linux 3.13.5-1-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:
- Put SD card with pictures
- Open some RAW and JPEG images from SD Card
- Remove SD card
- Try to go to next picture by clicking on thumbnails
- Crash

Expected:
- Show error message that image is no longer available

The crash can be reproduced every time.

-- Backtrace:
Application: showFoto (showfoto), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
To enable execution of this file add
	add-auto-load-safe-path /usr/lib/libstdc++.so.6.0.19-gdb.py
line to your configuration file "/home/slavik/.gdbinit".
To completely disable this security protection add
	set auto-load safe-path /
line to your configuration file "/home/slavik/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
	info "(gdb)Auto-loading safe path"
[Current thread is 1 (Thread 0x7f6629d909c0 (LWP 1275))]

Thread 4 (Thread 0x7f66039b5700 (LWP 1276)):
#0  0x00007f6624fa835d in poll () from /usr/lib/libc.so.6
#1  0x00007f660bb92918 in ?? () from /usr/lib/libusb-1.0.so.0
#2  0x00007f6625ca40a2 in start_thread () from /usr/lib/libpthread.so.0
#3  0x00007f6624fb0d1d in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f65fd03b700 (LWP 1277)):
#0  0x00007f6625ca804f in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f6625f34266 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f662977b84f in Digikam::ParkingThread::run (this=0x11a2f10) at /media/LinuxHDD/digikam-software-compilation/core/libs/threads/threadmanager.cpp:119
#3  0x00007f6625f33d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f6625ca40a2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f6624fb0d1d in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f65f69fa700 (LWP 1381)):
#0  0x00007f6625ca83f8 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f6625f34244 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#2  0x00007f6625f27945 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f6625f33d8f in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f6625ca40a2 in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f6624fb0d1d in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f6629d909c0 (LWP 1275)):
[KCrash Handler]
#5  0x00007f6629595706 in Digikam::DSharedDataPointer<Digikam::DImg::Private>::assign (this=0x128d920, o=...) at /media/LinuxHDD/digikam-software-compilation/core/libs/dimg/dshareddata.h:223
#6  0x00007f6629593dea in Digikam::DSharedDataPointer<Digikam::DImg::Private>::operator= (this=0x128d920, o=...) at /media/LinuxHDD/digikam-software-compilation/core/libs/dimg/dshareddata.h:202
#7  0x00007f6629584a11 in Digikam::DImg::operator= (this=0x128d920, image=...) at /media/LinuxHDD/digikam-software-compilation/core/libs/dimg/dimg.cpp:189
#8  0x00007f6629837f2d in Digikam::GraphicsDImgItem::setImage (this=0x11ee450, img=...) at /media/LinuxHDD/digikam-software-compilation/core/libs/widgets/graphicsview/graphicsdimgitem.cpp:154
#9  0x00007f66297f36da in Digikam::Canvas::slotImageLoaded (this=0x1265a60, filePath=..., success=false) at /media/LinuxHDD/digikam-software-compilation/core/utilities/imageeditor/widgets/canvas.cpp:170
#10 0x00007f66297f2945 in Digikam::Canvas::qt_static_metacall (_o=0x1265a60, _c=QMetaObject::InvokeMetaMethod, _id=35, _a=0x7fff1b845170) at /media/LinuxHDD/digikam-software-compilation/build/core/digikam/canvas.moc:152
#11 0x00007f6626047b48 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#12 0x00007f6629852c1a in Digikam::EditorCore::signalImageLoaded (this=0x12a1390, _t1=..., _t2=false) at /media/LinuxHDD/digikam-software-compilation/build/core/digikam/editorcore.moc:176
#13 0x00007f6629855bac in Digikam::EditorCore::slotImageLoaded (this=0x12a1390, loadingDescription=..., img=...) at /media/LinuxHDD/digikam-software-compilation/core/utilities/imageeditor/core/editorcore.cpp:309
#14 0x00007f66298528aa in Digikam::EditorCore::qt_static_metacall (_o=0x12a1390, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0x7f65d0020b80) at /media/LinuxHDD/digikam-software-compilation/build/core/digikam/editorcore.moc:89
#15 0x00007f662604befe in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#16 0x00007f6626f050dc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#17 0x00007f6626f0b6a0 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007f6627c2488a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#19 0x00007f6626033ebd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#20 0x00007f6626036f0f in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
#21 0x00007f6626061263 in ?? () from /usr/lib/libQtCore.so.4
#22 0x00007f66192db296 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#23 0x00007f66192db5e8 in ?? () from /usr/lib/libglib-2.0.so.0
#24 0x00007f66192db68c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#25 0x00007f6626060b25 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007f6626fa2216 in ?? () from /usr/lib/libQtGui.so.4
#27 0x00007f6626032b1f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#28 0x00007f6626032e15 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#29 0x00007f6626037f4b in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#30 0x0000000000454089 in main (argc=13, argv=0x7fff1b845bc8) at /media/LinuxHDD/digikam-software-compilation/core/showfoto/main/main.cpp:90

Possible duplicates by query: bug 331714.

Reported using DrKonqi
Comment 1 caulier.gilles 2014-03-10 15:37:22 UTC
Same backtrace than bug #331714.

Now we have an easy way to reproduce the dysfunction. Please merge this report with #331714.

Also, do you seen my comment #1 in this report ?

https://bugs.kde.org/show_bug.cgi?id=331714#c1

Gilles

*** This bug has been marked as a duplicate of bug 331714 ***
Comment 2 Veaceslav Munteanu 2014-03-10 15:41:26 UTC
Ah... I didn't notice that it has the same backtrace....
Comment 3 caulier.gilles 2021-04-04 16:54:22 UTC
Fixed with #331714