Bug 331826 - Emails based on template go to local sent folder instead of that configured
Summary: Emails based on template go to local sent folder instead of that configured
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 4.13.2
Platform: OpenSUSE Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2014-03-06 17:17 UTC by bib
Modified: 2018-10-27 03:33 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bib 2014-03-06 17:17:56 UTC
What should be seen is that the sent email based on a template should be stored in the accounts configured "Sent Items" folder.

Always producible except possibly for the very first email attempt to prove.

Reproducible: Always

Steps to Reproduce:
1. Create a default account where the sent items are stored on IMAP
2. Create a template
3. Open template, edit and send

Actual Results:  
What actually happens is that it gets stored in the local storage "Sent Items".

Expected Results:  
Should get stored in the accounts configured "Sent Items" folder.
Comment 1 Christian González 2014-07-01 19:44:52 UTC
Can confirm exact that behaviour.
Comment 2 Thorsten Schnebeck 2014-08-01 06:48:55 UTC
Can confirm for

kmail --version
Qt: 4.8.2
KDE: 4.13.2
KMail: 4.13.2

akonadictl --version
Akonadi 1.12.1
Comment 3 Laurent Montel 2014-08-01 08:00:34 UTC
We store email against settings from identity.
So if you use an identity which define "send folder" when you send even if you use template it will store in folder configurate in identity.
Comment 4 Thorsten Schnebeck 2014-08-01 08:09:55 UTC
The option for using a Send-folder is on and I use the Inbox-folder also as Send-folder. When opening a template the identity is set correct. Can the double use of Inbox be a problem?
Comment 5 bib 2014-08-01 08:17:37 UTC
(In reply to Laurent Montel from comment #3)
> We store email against settings from identity.
> So if you use an identity which define "send folder" when you send even if
> you use template it will store in folder configurate in identity.

That's wrong. That is not what happens. All my accounts and identities are set to save into IMAP folders. However, regardless of those setting, they all get saved to the local folders.

If you read the initial bug report, you will see that is exactly how I have set it up. See point 1.
Comment 6 bib 2015-06-29 11:17:43 UTC
This bug is still in place with plasma5, it's been confirmed, just wondering if it's being taken seriously?
Comment 7 bib 2015-07-02 15:28:15 UTC
Retried with a new user.

Did more checking with plasma. It now does not save the email at all, either in the imap repository, or in local folders.

This is now a MAJOR bug.
Comment 8 bib 2015-07-19 08:55:13 UTC
I am getting completely fucked off with this,

Here we have a bug which has existed for well over a year, and sweet fuck all has been done about it.

Perhaps the kmail maintainer can tell everyone WHY he has no intention of fixing it?

Perhaps he does not use IMAP, and therefore could not give a shit who loses emails.

Or perhaps he has no idea what the bug actually is.

Perhaps, a new maintainer should be appointed.
Comment 9 Christian González 2015-07-19 09:46:21 UTC
Full ACK. In fact, this is the main bug why I don't (can't) use Kmail as Email client.
Comment 10 Laurent Montel 2015-07-19 12:07:52 UTC
(In reply to bib from comment #8)
> Perhaps, a new maintainer should be appointed.
Thanks to maintain kmail .
Comment 11 bib 2015-08-04 13:32:28 UTC
So basically what you are saying is, no one in the KDE project gives a shit about this core application 'cause they are all using something else.

Not so much not eating your own dog food, more a refusal to eat from the communal trough.
Comment 12 Steve 2016-02-04 18:17:56 UTC
It's still happening in Kmail 5.0.2, it just started not saving the email for me, which is not cool as I do need a record of email I've sent.

It used to save in my local save-mail folder instead of on IMAP, but something changed last week and it just stopped saving template messages altogether.
Comment 13 Denis Kurz 2017-01-18 19:38:19 UTC
I'm not able to reproduce this bug in KMail 5.4.1. I created a template, and tried these two ways to send a message based on the template:

1. Select "File -> New -> Message from Template -> [Template Name]"
2. Open the template folder, select the template, press T

I modified it by adding Subject and To, and sent the resulting message. I tried the second variant twice, with another Identity in the second run. In all cases, the message ended up in the correct Sent folder I set up for the corresponding Identity. My local Sent folder is still empty.

Is anyone still able to reproduce this issue in a recent version of KMail? If so, can you, dear reproducer, please try to provide additional information on how to reproduce it? Please also state your KMail version, which should at least start with a five.
Comment 14 Thorsten Schnebeck 2017-01-26 18:35:16 UTC
Huuh, I tried to check with KMail 5.4.0 but this version seems to have too many bugs. I also tried to define a template folder but its not visible in the "File->New" list.
But I see so many options reset back to a default value when I reopen a saved config dialogue. So this version has already its problems to define a template folder. :-/

Kmail 5.4.0
KDE frameworks 5.29.0
Qt 5.7.0 (kompiliert gegen 5.7.0)
xcb window system
Comment 15 Andrew Crouthamel 2018-09-26 22:14:33 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 16 Andrew Crouthamel 2018-10-27 03:33:37 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!