Bug 331715 - hotshot2calltree script crashes on load due to invalid version string
Summary: hotshot2calltree script crashes on load due to invalid version string
Status: RESOLVED FIXED
Alias: None
Product: kcachegrind
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Josef Weidendorfer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-03 22:20 UTC by Henry de Valence
Modified: 2014-03-03 23:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.13


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henry de Valence 2014-03-03 22:20:45 UTC
Description:

The hotshot2calltree script included in kdesdk-kcachegrind 4.12.2-1 crashes on launch due to an invalid version string.

Specifically, line 56 has:

version = "$Revision$"

and line 347 has:

versiontext = "%s version: %s" % ( progname, version.split()[1], )

which causes a crash because "$Revision$" hasn't been replaced with the actual version string.

Additional info:
* package version(s)

/usr/bin/hotshot2calltree is owned by kdesdk-kcachegrind 4.12.2-1

* config and/or log files etc.

None.

Steps to reproduce:

Run the program.

NOTE: reported downstream at https://bugs.archlinux.org/task/39130
Comment 1 Josef Weidendorfer 2014-03-03 23:37:00 UTC
Git commit beae8fbb974074c6e9b77b371cb479893b27a875 by Josef Weidendorfer.
Committed on 03/03/2014 at 23:31.
Pushed by weidendo into branch 'master'.

Fix hotshot2calltree: remove SVN keyword substitution

Replaced by cmake configuration file substitution feature

M  +11   -2    converters/CMakeLists.txt
R  +1    -1    converters/hotshot2calltree.cmake [from: converters/hotshot2calltree - 099% similarity]

http://commits.kde.org/kcachegrind/beae8fbb974074c6e9b77b371cb479893b27a875
Comment 2 Josef Weidendorfer 2014-03-03 23:40:12 UTC
Git commit 2858c560b2b5af8a9fa4bd9692a306b5edfe264f by Josef Weidendorfer.
Committed on 03/03/2014 at 23:31.
Pushed by weidendo into branch 'KDE/4.13'.

Fix hotshot2calltree: remove SVN keyword substitution

Replaced by cmake configuration file substitution feature

M  +11   -2    converters/CMakeLists.txt
R  +1    -1    converters/hotshot2calltree.cmake [from: converters/hotshot2calltree - 099% similarity]

http://commits.kde.org/kcachegrind/2858c560b2b5af8a9fa4bd9692a306b5edfe264f