Bug 331575 - konversation crashes on exit with oxygen-transparent theme in kde 4.12
Summary: konversation crashes on exit with oxygen-transparent theme in kde 4.12
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: konversation
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konversation Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-27 17:47 UTC by Levis Nickaster
Modified: 2014-02-28 00:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Levis Nickaster 2014-02-27 17:47:15 UTC
Application: konversation (1.5-master #4303)
KDE Platform Version: 4.12.2
Qt Version: 4.8.5
Operating System: Linux 3.13.5-1-ARCH i686
Distribution: "Arch Linux"

-- Information about the crash:
- What I was doing when the application crashed:
when i close konversation window
- Unusual behavior I noticed: oxygen-transparent with kde 4.12.2 on arch linux i686 kernel 3.13.5

- Custom settings of the application: none

The crash can be reproduced every time.

-- Backtrace:
Application: Konversation (konversation), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
To enable execution of this file add
	add-auto-load-safe-path /usr/lib/libstdc++.so.6.0.19-gdb.py
line to your configuration file "/home/levis/.gdbinit".
To completely disable this security protection add
	set auto-load safe-path /
line to your configuration file "/home/levis/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual.  E.g., run from the shell:
	info "(gdb)Auto-loading safe path"
[Current thread is 1 (Thread 0xb42b7980 (LWP 9129))]

Thread 3 (Thread 0xb15b6b40 (LWP 9130)):
#0  0xb7715424 in __kernel_vsyscall ()
#1  0xb54c5e5b in poll () from /usr/lib/libc.so.6
#2  0xb4acb77b in g_poll () from /usr/lib/libglib-2.0.so.0
#3  0xb4abc938 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb4abca78 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb638d87f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#6  0xb635cda3 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb635d0c9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb624bb1d in QThread::exec() () from /usr/lib/libQtCore.so.4
#9  0xb633d254 in ?? () from /usr/lib/libQtCore.so.4
#10 0xb624e40f in ?? () from /usr/lib/libQtCore.so.4
#11 0xb50c8f20 in start_thread () from /usr/lib/libpthread.so.0
#12 0xb54d094e in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0xb093cb40 (LWP 9199)):
#0  0xb50cb0fc in pthread_mutex_lock () from /usr/lib/libpthread.so.0
#1  0xb54dda84 in pthread_mutex_lock () from /usr/lib/libc.so.6
#2  0xb4aff8e0 in g_mutex_lock () from /usr/lib/libglib-2.0.so.0
#3  0xb4abc36b in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#4  0xb4abc8ca in ?? () from /usr/lib/libglib-2.0.so.0
#5  0xb4abca78 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#6  0xb638d87f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#7  0xb635cda3 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#8  0xb635d0c9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#9  0xb624bb1d in QThread::exec() () from /usr/lib/libQtCore.so.4
#10 0xb633d254 in ?? () from /usr/lib/libQtCore.so.4
#11 0xb624e40f in ?? () from /usr/lib/libQtCore.so.4
#12 0xb50c8f20 in start_thread () from /usr/lib/libpthread.so.0
#13 0xb54d094e in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0xb42b7980 (LWP 9129)):
[KCrash Handler]
#6  0xb5a18082 in QRasterWindowSurface::~QRasterWindowSurface() () from /usr/lib/libQtGui.so.4
#7  0xb5a1810c in QRasterWindowSurface::~QRasterWindowSurface() () from /usr/lib/libQtGui.so.4
#8  0xb5a32f04 in ?? () from /usr/lib/libQtGui.so.4
#9  0xb5845873 in ?? () from /usr/lib/libQtGui.so.4
#10 0xb5845a28 in QWidgetPrivate::deleteExtra() () from /usr/lib/libQtGui.so.4
#11 0xb5845c2d in QWidgetPrivate::~QWidgetPrivate() () from /usr/lib/libQtGui.so.4
#12 0xb5845edc in QWidgetPrivate::~QWidgetPrivate() () from /usr/lib/libQtGui.so.4
#13 0xb6378056 in QObject::~QObject() () from /usr/lib/libQtCore.so.4
#14 0xb584f435 in QWidget::~QWidget() () from /usr/lib/libQtGui.so.4
#15 0xb711082c in ?? () from /usr/lib/libkidletime.so.4
#16 0xb7112bdf in ?? () from /usr/lib/libkidletime.so.4
#17 0xb7112a5b in ?? () from /usr/lib/libkidletime.so.4
#18 0xb7110289 in ?? () from /usr/lib/libkidletime.so.4
#19 0xb5416401 in __run_exit_handlers () from /usr/lib/libc.so.6
#20 0xb541645d in exit () from /usr/lib/libc.so.6
#21 0xb53fe99b in __libc_start_main () from /usr/lib/libc.so.6
#22 0x080994d8 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 327798.

Possible duplicates by query: bug 330038, bug 327798, bug 320766.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-02-28 00:58:40 UTC

*** This bug has been marked as a duplicate of bug 261539 ***