Bug 331423 - No icon for wifi + openconnect vpn in plasma-nm
Summary: No icon for wifi + openconnect vpn in plasma-nm
Alias: None
Product: plasma-nm
Classification: Plasma
Component: applet (show other bugs)
Platform: Kubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Jan Grulich
Depends on:
Reported: 2014-02-23 00:47 UTC by Rohan Dhruva
Modified: 2014-03-01 10:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:

System tray icon after VPN is connected (52.47 KB, image/png)
2014-02-23 00:48 UTC, Rohan Dhruva
Output of kstart plasma-desktop (7.61 KB, text/plain)
2014-02-23 10:38 UTC, Rohan Dhruva
kstart output with debugging enabled (74.09 KB, text/plain)
2014-02-23 10:50 UTC, Rohan Dhruva
missing icons in plasma-nm (28.70 KB, image/jpeg)
2014-02-23 18:55 UTC, Sebastian

Note You need to log in before you can comment on or make changes to this bug.
Description Rohan Dhruva 2014-02-23 00:47:03 UTC
I use plasma-nm with my work network's VPN, and it used to show a lock icon on the wifi when VPN was active. After a recent update where the layouts were changed, on activating VPN, there is no icon when VPN is active. It shows a blank icon in place of the wifi signal icon.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: plasma-nm
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-11-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: KDE
Date: Fri Feb 21 20:57:11 2014
InstallationDate: Installed on 2014-01-24 (28 days ago)
InstallationMedia: Kubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140121.1)
SourcePackage: plasma-nm
UpgradeStatus: No upgrade log present (probably fresh install)

Reproducible: Always

Steps to Reproduce:
1. Connect to wifi
2. Connect to VPN
Actual Results:  
The icon in the tray turns blank

Expected Results:  
The icon should be wifi with a lock overlay to show VPN status
Comment 1 Rohan Dhruva 2014-02-23 00:48:04 UTC
Created attachment 85280 [details]
System tray icon after VPN is connected
Comment 2 Jan Grulich 2014-02-23 10:04:01 UTC
Can you please try one thing, because there is sometimes a problem with our new icons. 

1) run "kquitapp plasma-desktop"
2) remove plasma icon cache, it's in ~/kde/cache-your-hostname/plasma*
3) run "kbuildsycoca4 --noincremental
4) and run again plasma-desktop "kstart plasma-desktop"

I don't see anything wrong in the code and it for me it works, so let me know if removing icon cache helped or not. Thanks.
Comment 3 Rohan Dhruva 2014-02-23 10:32:53 UTC
I followed the instructions, but I still see the blank icon. I also tried rebooting the machine after following your instructions, but I still see the same problem.
Comment 4 Rohan Dhruva 2014-02-23 10:38:04 UTC
Created attachment 85285 [details]
Output of kstart plasma-desktop

I tried the instructions once more after rebooting, still no change: I see a blank icon when connected to wifi+vpn. Attaching output of kstart if it is helpful. Note that on disconnecting from the VPN, the wifi icon re-appears correctly.
Comment 5 Jan Grulich 2014-02-23 10:42:06 UTC
The output is not helpful, you have to enable plasma-nm in kdebugdialog first.
Comment 6 Rohan Dhruva 2014-02-23 10:42:40 UTC
Can you please tell me how to do that?
Comment 7 Jan Grulich 2014-02-23 10:48:25 UTC
Just open kdebugdialog and enable plasma-nm (model, applet etc.). Then restart plasma-desktop again and send me the output.
Comment 8 Rohan Dhruva 2014-02-23 10:50:51 UTC
Created attachment 85286 [details]
kstart output with debugging enabled
Comment 9 Jan Grulich 2014-02-23 11:15:35 UTC
I think I've found the problem, we already have the same bug in previous versions. Are you able to test a patch and compile plasma-nm from git?
Comment 10 Rohan Dhruva 2014-02-23 11:17:53 UTC
Awesome, thanks Jan. The version I am using is current as of Was the fix committed after that? 

I can give compiling from git a shot. I will try to make a debian package for it, or just do a "sudo make install". Which patch did you want me to try?
Comment 11 Jan Grulich 2014-02-23 11:33:07 UTC
Git commit 1cce8ee607bb0a25086c765cc95d58167d3d769f by Jan Grulich.
Committed on 23/02/2014 at 11:32.
Pushed by grulich into branch 'master'.

Fix getting device from a primary VPN connection

M  +24   -4    declarative-plugins/applet/connectionicon.cpp
M  +0    -7    declarative-plugins/applet/connectionicon.h

Comment 12 Jan Grulich 2014-02-23 11:36:12 UTC
That one I just pushed to the git. Just let me know if you need compile instructions or anything else. You also need libnm-qt and libmm-qt libraries, I think in Kubuntu they are under NetworkManagerQt-dev and ModemManagerQt-dev packages.
Comment 13 Sebastian 2014-02-23 18:53:59 UTC
It seems, that this Bug isn't specific to VPN. On my machine (Kubuntu trusty alpha) the icons for the config switches on top are missing - see screenshot. Deleting the icon-cache didn't solve this.
Comment 14 Sebastian 2014-02-23 18:55:05 UTC
Created attachment 85294 [details]
missing icons in plasma-nm
Comment 15 Jan Grulich 2014-02-23 20:35:50 UTC
That's a different problem and I'm pretty sure it happens due to not properly refreshed icon cache. Unfortunately I don't know why this is this happening, but I'll try to look at it. This is not definitely a problem in plasma-nm.
Comment 16 Jan Grulich 2014-02-23 20:43:22 UTC
It's also possible that you don't see icons when you use another Plasma theme with its own set of plasma-networkmanagement icons.
Comment 17 Jan Grulich 2014-02-24 20:19:32 UTC
Git commit 68edc66a615277c4e00b8f27dc6a4115f922bff4 by Jan Grulich.
Committed on 24/02/2014 at 20:19.
Pushed by grulich into branch 'master'.

Another attempt to fix the issue with missing icon for VPN connections

M  +14   -18   declarative-plugins/applet/connectionicon.cpp

Comment 18 Rohan Dhruva 2014-02-25 06:45:16 UTC
Jan, would it be possible for you to give me instructions on how to build a deb from git checkout? Are the required build scripts in the repo? 

I'm trying to find the best way to install non-disruptively, so I don't end up confusing the package manager in the future.
Comment 19 Jan Grulich 2014-02-25 07:58:46 UTC
I don't know how to build a deb package and there is no script or something like that for building any packages. You can just simply compile it and install. There is README file with description how to compile it, you just need to install dependencies and follow the insctructions.
Comment 20 Rohan Dhruva 2014-03-01 05:06:04 UTC
Jan: sorry for the delay in getting back. I just compiled a version from git and installed it. I can confirm that the bug is solved, and now I see a lock icon on the wifi when connected to VPN. Thank you so much!